LG 34UM95 and spontaneous waking from sleep for a few seconds

Discussion in 'MacBook Pro' started by recursor, Sep 6, 2014.

  1. recursor, Sep 6, 2014
    Last edited: Oct 15, 2014

    recursor macrumors newbie

    Joined:
    Sep 6, 2014
    #1
    Just received my 34UM95 a couple of days ago. Connected with Thunderbolt to my mid-2012 rMBP 15", which I'm using in clamshell mode. While it's a bummer that sound doesn't automatically switch to the external display's speakers and (moreso) that you can't control the volume from the Mac... Everything pretty much works fine within the limitations of this display (hopefully they'll get the sound output/volume issues resolved with a firmware update...note holding my breath).

    My rMBP detects the display properly, without any hacks or tweaks, etc. Just shows up as a 34UM95 in the Display control, with correct resolution already set (Best for Display, 60Hz). I was worried about that as some users had stated the display was detected as a TV or had to apply a manual hack/config somewhere.

    With that said: I do notice one annoying issue. I leave my display turned on and just let my rMBP go to sleep on its own, or put it to sleep. The LG goes to sleep and the power light blinks. Every once in a while (I think it's maybe once or twice per hour) the display comes to life with a "No signal. Entering power saving mode shortly" message...stays on for a couple of seconds then goes back to sleep. My desk is near my TV so I can see this happening while I'm watching TV. I assume it continues to do this (through the night, day, etc.) until I sit down and start using it again.

    I haven't seen any reports of this bug. But then, I assume most folks are either 1) turning their displays off, 2) not hanging around their computers while they're sleeping, or 3) unplugging their Macbooks when done.

    I don't recall my Apple Thunderbolt display (with the same rMBP) ever doing this. I thought I'd check in here. Maybe it is happening to other people too?

    One theory I have is that it might be PowerNap mode sending a signal out across Thunderbolt...looking for peripherals or a network connection maybe?

    Update 10/15/14
    I discovered that the root cause of this was the Bonjour service. Specifically, if you have an Apple TV or Airport base station (Extreme, TimeCapsule, etc), that device runs a Bonjour Sleep Proxy Server. Every Mac on the same network will register with that server so that it can be awakened from sleep by other devices seeking to access iTunes media, photos, Back To My Mac, etc., on that Mac. For Mavericks, this could be disabled by turning of "Wake for Network Access". "Power Nap" also causes Thunderbolt on the display to power up. Whenever Thunderbolt is activated, the display turns on momentarily with a "No Signal..." message and then turns off. I guess that Apple has designed the Thunderbolt Display to ignore this type of activity.

    Now, this was all working quite well with both of those settings disabled in the Energy Saver panel. Until Yosemite. I installed Developer Preview GM 3 the other day (released October 9, 2014) and apparently the "Wake for Network Access" setting no longer disables this behavior. That is, it doesn't seem to disable wake for network access. This might be a side effect (oversight) of Apple working to replace mDNSResponder with discoveryd. My research indicates it's been a problem with Yosemite all along. I'll file a bug report with Apple about this.

    Of course, the real fix would be for LG to issue a firmware update for the 34UM95 that disables this behavior. It's not clear to me, however, if they'll ever issue any firmware updates; this display may not even be field upgradable.
     
  2. larrysing1963 macrumors regular

    Joined:
    Aug 16, 2014
    #2
    Yosemite 10.10.2, and I have this problem on BOTH of my external monitors - Dell P2715Q and the LG 34UM95.

    If you find a way to stop them from flashing on several times during the night, I, as well as my sleep patterns, would appreciate it !!

    Thanks. :D:apple: :cool:
     
  3. larrysing1963 macrumors regular

    Joined:
    Aug 16, 2014
    #3
    I solved this on my Yosemite rMBP !!

    In System Preferences --> Energy Saver --> Power Adapter I made these two changes:

    "Turn Display off after" -changed from Never to "1 hr"
    Top two boxes checked, bottom two boxes unchecked.

    This stopped the behavior on both the Dell 4K monitor and the LG 34UM95.

    Best of luck !! :apple: :D
     

Share This Page