library not loaded - wrong architecture

Discussion in 'Mac OS X Lion (10.7)' started by jrkff8, Mar 22, 2012.

  1. jrkff8 macrumors newbie

    Joined:
    Mar 22, 2012
    #1
    I was running out of space on my HD so I deleted what I thought were the unnecessary architectures using Monolingual.

    However, now I cannot fun MS Office 2011. Is there a way to reinstall the missing architecture (and which one is it) through time machine without a system restore to make Office work again? I tried a reinstall of office, but that didn't work. Error message is below.

    Thanks.



    Process: Microsoft Word [2911]
    Path: /Applications/Microsoft Office 2011/Microsoft Word.app/Contents/MacOS/Microsoft Word
    Identifier: com.microsoft.Word
    Version: 14.1.4 (14.1.4)
    Build Info: Unknown-111121~0
    Code Type: X86 (Native)
    Parent Process: launchd [150]

    Date/Time: 2012-03-22 21:47:36.129 -0700
    OS Version: Mac OS X 10.7.3 (11D50)
    Report Version: 9

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000

    Application Specific Information:
    dyld: launch, loading dependent libraries

    Dyld Error Message:
    Library not loaded: @rpath/mbunamedstrings.framework/Versions/14/mbunamedstrings
    Referenced from: /Applications/Microsoft Office 2011/Microsoft Word.app/Contents/MacOS/../../../Office/CocoaUI.framework/Versions/14/CocoaUI
    Reason: no suitable image found. Did find:
    /Applications/Microsoft Office 2011/Office/CocoaUI.framework/Versions/14/../../../mbunamedstrings.framework/Versions/14/mbunamedstrings: mach-o, but wrong architecture
    /Applications/Microsoft Office 2011/Office/MicrosoftSetupUI.framework/Versions/14/../../../mbunamedstrings.framework/Versions/14/mbunamedstrings: mach-o, but wrong architecture
    /Applications/Microsoft Office 2011/Microsoft Word.app/Contents/MacOS/../../../Office/mbunamedstrings.framework/Versions/14/mbunamedstrings: mach-o, but wrong architecture


    Model: MacBook5,1, BootROM MB51.007D.B03, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.40f2
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    This is why you should never remove architectures carelessly! Older applications that require and expect 32-bit binaries will FAIL, as you have discovered. However... that being said, it is always safe to strip code for other CPU types (PowerPC code, for Intel Macs).

    Unfortunately, it seems you've also run into one of the goofy things with installers - they try to be smart, and fix only what needs to be fixed. However, they don't always detect everything. The recommended fix in this case is to perform a partial uninstall of Office, by running the uninstaller (leaving your preferences if given the option to remove them), THEN perform a reinstall.
     
  3. jrkff8 thread starter macrumors newbie

    Joined:
    Mar 22, 2012
    #3
    The below advice worked. Thanks!

     

Share This Page