Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Buadhai

macrumors 6502a
Original poster
Jan 15, 2018
789
298
Korat, Thailand
My wife is a long time user of LibreOffice. Currently she's running 7.2.5.2 on an M1 iMac running Monterey. A week or so ago she complained that copying items from a LO Write document would cause the dreaded SPOD which would necessitate a force quit. The same thing happens on her 2015 MBA running Catalina and LO 7.2.7.2. I've observed what happens on both machines:

  1. Select text
  2. Copy text
  3. SPOD
  4. Force Quit and restart LO
And, yes, the copied text is in the clipboard.

I've been unable to duplicate the issue on my 2017 iMac running Monterey and LO 7.2.7.2

The problem is discussed in this bug report: Bug 146598 - Freezing when using cut, copy, or paste on macOS

I've thought of trying to get her to try the 7.3.4 release or perhaps one of the older versions like 7.1.8.1, which some users report doesn't have the bug.

However, before I reinvent the wheel, I wonder if anyone else has solved this problem either by using a different version or with some other solution.
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
4,752
3,044
Have not run into this problem, so sorta "solved"? On 7.3.2.2 (installing 7.3.4 now), primarily Calc use.
 

bogdanw

macrumors 68040
Mar 10, 2009
3,137
1,473
I have LibreOffice 7.2.7.2 on Intel and M1, neither of them with the bug described.
But about a week ago, I got notified that the 7.3.4 update was available. That should’t have happened as I use the stable branch.
 

Buadhai

macrumors 6502a
Original poster
Jan 15, 2018
789
298
Korat, Thailand
It turns out that 7.3.4.n is hopeless. I installed it on a 2017 iMac, a 2017 MBA and a M1 iMac; all running Monterey. It crashes on all three machines (SPOD freeze). It crashes when you print. I crashes when you save. It crashes when you close the "About" dialog box. I guess we'll go back to a 7.2 release. How strange.
 

bbbc

macrumors member
Nov 19, 2012
83
23
I have had to bail on LibreOffice on my Apple silicon machines because of this bug driving me nuts (and erasing work) for months. I am now using NeoOffice, https://www.neooffice.org , since it's a Universal build, a Mac native fork of OpenOffice / LibreOffice and is free now.
 
Last edited:

tahitibub

macrumors newbie
Aug 1, 2010
16
1
France
Hello,
Long time user of LibreOffice, I also faced this bug since mid-2021.
For me, the only way not to have it was to stay on LO 7.1.4.
Since the problem is still not resolved, I recently decided to switch to NeoOffice (which is now a freeware). You can grab it here.
I will however test LO 7.4 which has just been released, and I will give you a feedback here.
Best regards,
 
Last edited:
  • Like
Reactions: bbbc
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.