Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Buadhai

macrumors 6502a
Original poster
Jan 15, 2018
504
109
Korat, Thailand
LibreOffice Version: 6.2.7.1 on a 2017 iMac Running 10.14.16
Display Resolution "Default For Display" (2048x1152)

When working on a Writer document the display develops areas that are completely out of focus. Examples attached at the end of this post.

The same document looks perfectly fine on my wife's MBA running the same version of LibreOffice and MacOS.

I have tried changing the typeface (font) and size. I have tried fiddling with Preferences > LibreOffice > View > Graphics Output.

Nothing works. I see the problem in no other application.

Any ideas?

lo1.jpg


lo2.jpg
 

Buadhai

macrumors 6502a
Original poster
Jan 15, 2018
504
109
Korat, Thailand
I forgot to note that the same documents displays just fine using Open Office.

Screenshot 2019-10-29 14.27.48.jpg


Open Office on the left. Libre Office on the right.
 

CHA05 R31GN5

Suspended
Oct 31, 2019
165
258
United States
I forgot to note that the same documents displays just fine using Open Office.

View attachment 873257

Open Office on the left. Libre Office on the right.
Could be a result of this bug. LibreOffice Prefer SVG Over PNG Icons

Got a link to a file that's an example of this problem being rendered on your display? I'll check it with LibreOffice 6.3.3.2 using a 5K display. As of right now, I do not have this issue on macOS 10.15.1.
 
I don't have this issue either, and yesterday, V6.3.3.2 of LibreOffice was released. I am using it primarily with Mojave (V10.14.6), but have tested it with Catalina, OS 10.15.1, on one of my external SSDs, and it works fine. It's always best to keep your software up to date, especially third party products. One site I use to keep informed about such updates is https://www.macupdate.com/. In fact, that is where I yesterday saw the new version of LibreOffice. And this morning, I saw a newer version of my EMail client, Thunderbird.
 

mj_

macrumors 65816
May 18, 2017
1,483
1,093
Austin, TX
I can confirm that this is a bug on Retina Macs, I can see in on both my Macs (MacBook & iMac). Because of this bug I'm still runninng 6.2.0.3, which was one of the final versions before this bug was introduced. If it'll take the developers as long to fix that as it took them to address LibreOffice's horrific performance on Retina Macs, which they've been successfully ignoring for the past six years with no fix in sight we're in for a real treat :rolleyes:
 

Buadhai

macrumors 6502a
Original poster
Jan 15, 2018
504
109
Korat, Thailand
Maybe the LibreOffice developers ought to ask the Open Office crew how they avoided problems with Retina Macs.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.