libsqlite3.0 is missing

Discussion in 'iOS Programming' started by redrobin, Apr 20, 2012.

  1. redrobin macrumors newbie

    Joined:
    Apr 20, 2012
    #1
    Hi- I've been working with sqlite and suddenly the libsqlite3.0.dylib file is gone from Xcode 4.3.1. When I try to link to it under Target/Build Phases/Link Binary/+ its not there. It just vanished. When I compile my project I get the Apple Mach-O-Linker Error - library not found for -lsqlite3.0 and the file is showing on the left side under the Project navigator, but its highlighted in red.

    Tried creating a brand new project and its still not showing up in the Target/Build Phases/Link Binary With Libraries section. The only thing I've changed was my Bundle ID in my info.plist file, which I had to do in order reserve a name for my app in the app store. Could this have caused the library to disappear, or is something else strange going on?

    thanks!
    Rich
     
  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    You should probably link to libsqlite3.dylib but I think both should be available.

    What are your BaseSDK and iOS Deployment target?
     
  3. redrobin thread starter macrumors newbie

    Joined:
    Apr 20, 2012
    #3
    Base SDK is Latest iOS (iOS 5.1) and Deployment Target is 5.1.

    Neither libsqlite3.dylib nor libsqlite3.0.dylib are displayed for selection. Attached is a screenshot.

    Incidentally, libsqlite3 has never been listed for me in Xcode 4.3.1. I always had libsqlite3.0 until now. I wonder if this has to do with my Architecture settings. Currently its set to "Standard (armv7)" and under Valid Architectures i has "armv6 armv7".

    I also checked my Framework Search Paths since others have reported having them auto-populated with strings that cause problems...however mine are totally blank so that's not causing it.

    Any other ideas?
     

    Attached Files:

  4. redrobin thread starter macrumors newbie

    Joined:
    Apr 20, 2012
    #4
    Fixed it. Turns out I mistakenly deleted it. If anyone has this issue, you can go to the Trash folder on your iMac, right click on the file, and click "Put Back". It will put the libraries back in their proper place.

    ;)
     

Share This Page