libxml for Mavericks 10.9?

Discussion in 'iOS Programming' started by macdonjo, Oct 8, 2014.

  1. macdonjo macrumors newbie

    Joined:
    Apr 30, 2014
    #1
    Does anyone know of a prebuilt solution of libxml?
     
  2. DennisBlah macrumors 6502

    DennisBlah

    Joined:
    Dec 5, 2013
    Location:
    The Netherlands
    #2
    I have libxml2.dylib
    Works for 10.8 and higher

    Am using it for libimobile
     
  3. Madd the Sane macrumors 6502a

    Madd the Sane

    Joined:
    Nov 8, 2010
    Location:
    Utah
    #3
    As far as I know, libxml2 has always been bundled with OS X. You will need to set the additional includes to include, IIRC, /usr/include/libxml
     
  4. PhoneyDeveloper, Oct 14, 2014
    Last edited by a moderator: Oct 15, 2014

    PhoneyDeveloper macrumors 68040

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #4
    'locate livxml' finds a lot of stuff on my machine

    Code:
    /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/lib/libxml2.2.dylib
    
    /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/include/libxml2/libxml
    etc.
     

Share This Page