"lidwake 0" not working; brand new rMPB 13"

Discussion in 'MacBook Pro' started by vexingv, Dec 2, 2013.

  1. vexingv macrumors newbie

    Joined:
    Dec 15, 2008
    #1
    I have a one-week old rMBP 13" 2.6/16bg/256gb. I have previously used the above command to disable lidwake when i was last using a powerbook. I've tried this command (and confirmed that the setting had been changed), however my machine still wakes when the lid is opened. Anyone else having issues with this on the latest version of OSX/Mavericks?
     
  2. durkkin macrumors regular

    Joined:
    Sep 23, 2013
    #2
    Considering you were last using a PowerPC based computer running at least 6 year old software, chances are that command is either deprecated or only one of multiple sleep/wake services. Apple has significantly changed OS X power management and sleep/wake functionality over the years so the fact that command no longer works is not surprising.
     
  3. vexingv thread starter macrumors newbie

    Joined:
    Dec 15, 2008
    #3
    as far as i can tell, this is still a valid command. there are still several hints and people using this command recently (and also some people running into the same issue).

    eg. https://discussions.apple.com/message/23553087#23553087
    http://forums.macrumors.com/showthread.php?t=1233621

    also, the setting appears on the power section of the system profiler. i've attached some screenshots below. however, i did leave out an error/warning message i first received when trying to set this behavior ("Warning: Idle timings for "Battery Power" may not behave as expected. Display sleep should have a lower timeout than system sleep")
     

    Attached Files:

  4. TheEnthusiast, Dec 3, 2013
    Last edited: Dec 3, 2013

    TheEnthusiast macrumors regular

    Joined:
    Aug 22, 2013
    #4
    Try the following.

    Code:
    sudo pmset -a lidwake 0

    Also for the warning about system sleep, for some reason Apple sets the default system sleep as 0/1 and disk sleep as 10, which is why you see that warning message. Correct it with the following:

    Code:
    sudo pmset -a sleep 10
     
  5. durkkin macrumors regular

    Joined:
    Sep 23, 2013
    #5
    Interesting. Considering all I've tried to do is the opposite (accomplished with Caffeine) this is outside of my realm of expertise. Hopefully what TheEnthusiast suggested works for you.
     
  6. vexingv thread starter macrumors newbie

    Joined:
    Dec 15, 2008
    #6
    unfortunately, still not working. i guess not too many people use this feature/command anymore....
     

Share This Page