Lightroom 2.1 and XSi

Discussion in 'Digital Photography' started by zuma022, Jun 15, 2009.

  1. zuma022 macrumors regular

    Joined:
    May 18, 2008
    #1
    Wondering if anyone ran into this problem before. I feel iPhoto is too limiting for my photography and I downloaded the trial for Lightroom. I'm still playing around with it, but I like it a lot.
    Unfortunately it doesn't seem to be able to import my RAW files from the Canon XSi/450 and I get a 'files unsupported or damaged error'. I've tried to update, but it tells me it's all up to date (as I would expect from a trial version).
    I'm still using Photoshop CS2 and I can't open them there either, would that have anything to do with it? Is there a way to have Lightroom import those RAW files?
     
  2. Kebabselector macrumors 68030

    Kebabselector

    Joined:
    May 25, 2007
    Location:
    Birmingham, UK
    #2
  3. Jon-Luke macrumors 6502

    Jon-Luke

    Joined:
    May 22, 2009
    Location:
    Cape Town
    #3
    Another thing you can try is to connect your SD card directly to your computer (Not via the camera but via a USB Card reader) the USB to camera connections are often not USB2.0 and sometimes the camera software can interfere with Lightroom. When working with large RAW files all of these things can cause problems so in the interest of speed and a clean transfer rather use a card reader.

    Another thing you can try is to download Adobe RAW file reader - its a free download and works in conjunction with Photoshop so it may help things. But all in all the Lightroom should work with all RAW and DNG files. You could also search adobe for camera support, there may be a specific patch for your camera.

    Someone mentioned upgrading to Lightroom 2.3, I would recommend this too because if you are going to buy the program this will be the version to try to get. I have been using Lightroom since it was in Beta development and I love it.

    :cool::apple:
     
  4. zuma022 thread starter macrumors regular

    Joined:
    May 18, 2008
    #4
    Thanks for the help! I downloaded LR 2.3 and still had no luck. I don't have a card reader either, but I thought it would make sense that the files could be corrupted somehow on import.
    I finally managed to download the RAW files in Canon's DPP and then import to LR and that worked. So it seems it's something between the camera and Lightroom that's not quite working.
     

Share This Page