Lightroom 2 question

Discussion in 'Digital Photography' started by CrackedButter, Aug 30, 2008.

  1. CrackedButter macrumors 68040

    CrackedButter

    Joined:
    Jan 15, 2003
    Location:
    51st State of America
    #1
    I recently did a shoot and put a load of images in a folder seperate from the one I wanted them to go in. I worked on the images, created virtual copies and when I was done I manually moved them in the Finder to the new folder that Lightroom was accessing.

    Somewhere along the way, LR forgot all the virtual copies I had made and adjustments now I have to start again, what gives? Did I need to export them first and then re-import? Sounds silly to ask but why aren't the originals holding onto the sidecar files (virtual copies), or isn't that the way it works?
     
  2. stevooo macrumors newbie

    Joined:
    Mar 23, 2008
    #2
    i'm no lightroom internal workings expert, but i believe it stores develop data (inc virtual copies) in your catalog database and links it to the file by the files path. when you moved the files in the finder, lightroom wasnt aware of this and needs updating as to where the files are now. never tried this but i assume if you added the files again from a different location then it would see them as new files due to them having different paths. if the old folder they were in is listed in the folders panel on the left you could try right-clicking on it and choose 'update folder location'.

    i always make sure i check the option 'Automatically write changes into XMP' on the Metadata tab under catalog settings (cmd & alt & ,) this forces lightroom to write the develop settings to a sidecar xmp file (stored in the same location as the RAW file) - this is also useful if you also use camera raw as this can read the develop settings from the xmp. I think virtual copies are still stored in the main catalog database however.
     
  3. CrackedButter thread starter macrumors 68040

    CrackedButter

    Joined:
    Jan 15, 2003
    Location:
    51st State of America
  4. stevooo macrumors newbie

    Joined:
    Mar 23, 2008
    #4
    its under Catalog Settings on the Metadata tab, which you can get to by pressing cmd & alt & ,
    ...or you can get it by clicking Lightroom > Catalog Settings
    ...or Lightroom > Preferences > General Tab > Button near bottom marked 'Go to catalog settings'
     

Share This Page