Limewire/Safari

Discussion in 'Mac Basics and Help' started by Andrew83Ga, Oct 8, 2009.

  1. Andrew83Ga macrumors regular

    Joined:
    Sep 27, 2009
    #1
    I've noticed several people with Safari issues. I'm new to mac and love safari, but when I'm downloading anything more the 500 MB on limewire, safari AND firefox grind to a halt. Any other time, the mac is snappy and responsive, but not while DL on limewire. It's a brand new 13" 2.53 ghz uMBP, i thought that multitasking wouldn't be an issue whatsoever

    On windows you could set a bandwidth allocation for things like limewire downloads, but I haven't noticed that on the mac. Still exploring though.
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Limewire is so 90's. It's the worst software ever! I have no problems downloading torrents with Transmission, no matter what I do.
     
  3. Andrew83Ga thread starter macrumors regular

    Joined:
    Sep 27, 2009
    #3
    cool, i'll give it try. On a side note, what does it mean to mount? Sometimes when I DL software, I don't know if I should drag it to applications or MacHD or what.
     
  4. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #4
    If it's an application, drag it to Applications, that's its place.
     
  5. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #5
    For whatever reason my torrents blaze in Limewire, but in other torrent apps like transmission they run slower.
     

Share This Page