Limited mouse & keyboard functionality in Leopard

Discussion in 'macOS' started by ndriver182, Oct 27, 2007.

  1. ndriver182 macrumors 6502a

    Joined:
    Jun 26, 2007
    #1
    I just did a fresh clean install of Leopard last night on my mac pro and everything started out just great. Then I started noticing after I had installed some apps (unfortunately I don't remember which ones exactly) I started to notice that I lost some functionality of the mouse and keyboard.

    Currently I am unable to drag ANY files or icons around anywhere on the computer (desktop, finder, dock, etc.), but yet I can still right click, move the mouse, click buttons, open apps, etc. With the keyboard I've noticed that I have problems with the copy/paste shortcuts. I can use the comm+c to copy, but then nothing at all happens when I do comm+v. Then again, if I try to copy and paste using the "edit" menu I can't do that either. "Paste" is always grayed out.

    My mouse and keyboard are both USB and I've tried unplugging and re-plugging them in, switching ports on my USB hub and even plugging in directly to the Mac itself. No difference. Tried calling tech support, but apparently they're lines are full and aren't accepting other calls.
     
  2. ndriver182 thread starter macrumors 6502a

    Joined:
    Jun 26, 2007
    #2
    Well, just in case anybody else runs into any strange problems like this, it looks like it had something to do with permissions. It appears that at some point when I had been installing applications something got tweaked. As soon as I repaired the permissions everything worked great again.

    Thanks to the Apple tech support guy who helped explain how to do that (it was my first time... still a Mac noob overall).
     

Share This Page