Line spacing in Mail.app

Discussion in 'Mac Apps and Mac App Store' started by Doctor Q, Apr 24, 2008.

  1. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #1
    If I create a new message in Mail.app and start typing, the text is single spaced.

    If I paste in text from a word processor, or quote someone else's message, I sometimes find that my text is 1-1/2 spaced or double-spaced. Can line spacing or leading be set or controlled from within a mail message?
     
  2. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #2
    Nearly a month later wonders if you have found a solution.

    I have tried nearly everything I can think of to get around this but nothing seems to make a difference.

    The one work around I have found to work is to type a small bit of text in a new message window and then use the "Paste and Match Style" (command+opt+shift+v).

    Of course if you found a solution in the mean time I would love to hear it.
     
  3. Doctor Q thread starter Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #3
    Nope, never found one. I have to paste the text unformatted (or "match style") into another window, and abandon the original message.
     
  4. sir42 macrumors 6502

    Joined:
    Sep 16, 2003
    Location:
    NY, NY
  5. mrmma macrumors member

    Joined:
    Dec 27, 2006
    Location:
    Missouri
    #5
    Same Problem

    I'm having the same problem. Fairly frustrating.
     
  6. RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #6
    I'm resurrecting this thread with a solution. After having the same thing happen to me, I did some reading.

    Basically it happens when you cut and paste from a html or webpage or from MS Word into a mail message. It arises from a mixup between html code / MS Word text formatting code and Apple's rich text message code.

    The end result is that anything you type after the cut and paste is also double spaced.

    Workarounds:

    - change message format to plaintext (can't remember if this worked)

    or

    - paste into notepad / text edit and change to plain text then repaste into mail message

    or

    - type a bit more, or press return a couple of times, then paste into the middle of the text block, and continue typing from the end of the previously entered text, not from the end of the material you pasted. This means you are continuing with the original single-spaced format. Any editing of the pasted block will still come out double-spaced though.

    HTH.
     
  7. Doctor Q thread starter Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #7
    It doesn't work, at least for me.

    Sometimes I can't get the other workaround to work either, because the entire message has the bad line-spacing setting. I end up creating a new email message and pasting in the text from TextEdit. That's a pain because I have to copy/paste or retype my Subject line. At least Mail lets you drag TO/CC/BCC names from one mail message to another.
     
  8. RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #8
    You might be right there. Sorry I'm not at my mac to check.
    If the first thing you do with a new message is paste something in, yes the bad spacing will be set for the entire message. You need to type something in first, then paste into the middle of the block, then continue typing from the end of the block that you first typed out. It's more work to describe than to do.

    The best explanation, with code sample, is in this thread:

    http://forums.macosxhints.com/showthread.php?t=67960
     
  9. wdjudd macrumors newbie

    Joined:
    Jul 25, 2009
    #9
    Mac Mail Line Spacing Workarounds

    There is one small workaround that I found for coping from MS Word into Mac Mail so that it does not double space. When creating a message in Word, do NOT use a "hard return", meaning, do NOT just hit the "Return" key to make a line return or a new paragraph. You must use a "Soft Return" to prevent double spacing when pasting text from MS Word into Mac Mail. So what is a "Soft Return" in Word? Hold down the "Shift" key while you hit the "Enter" key to create a soft return. Try this on a couple of paragraphs or better yet . . . several lines with a soft return between them versus a hard return. The result - no double spaces. As for the quoted text having double spaces? Not a clue . . .

    AND

    TextEdit has line spacing control. I have also used TextEdit to copy into, ajuist the line spacing, and then paste into Mac Mail. Good luck, and please post any new workarounds that you have learned since this original post. Apple is the greatest but at times they miss some of the most important simple THINGS WE NEED TO BE MORE PRODUCTIVE!
     
  10. cosmotion macrumors newbie

    Joined:
    Jul 22, 2010
    #10
    same problem, but one workaround WORKS

    I have had the same problem pasting from word and getting double spacing. I tried the soft return (Shift+return) and it didn't work.

    What did work was pasting into a new doc in TextEdit, then selecting Format>Make Plain Text, then cutting and pasting that into Mail. Pastes as single space.

    Thanks for the tip.
     
  11. cascades2004 macrumors newbie

    Joined:
    Sep 10, 2010
    #11
    workaround

    Read that "Control - Return" works to force single spacing. You can even correct text that is buggered that way.

    Before that, I tried to put the text into plain text and it didn't work. I tried to put it in plain text in wordpad and it didn't work when pasting back in. something is whacked with the styling even though the default style is selected with a +1 line feed. Very strange.
     
  12. vague macrumors newbie

    Joined:
    Feb 25, 2007
    #12
    A fix

    Here is a fix for those for whom switching to plain text in Mail doesn't work. As with all fixes, its annoying, and I don't like it. It is just amazing that Apple haven't incorporated a proper text editing system (read Word/Pages) into Mail. Even Entourage is better! Using this fix, all your formatting will disappear, but so will that nasty spacing.

    Copy whatever text you want from Word.
    Go into Text Edit.
    Go to preferences.
    Select plain text.
    Create a new Text Edit window.
    Paste your text from Word.
    Select your text and copy from Text Edit.
    Paste into Mail.
     
  13. Doctor Q thread starter Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #13
    vague,

    You can simplify one step of your workaround. Instead of changing Text Edit preferences you can change the current window to plain text using a key combination. So it becomes:
    1. Copy whatever text you want from Word.
    2. Go into Text Edit.
    3. Create a new Text Edit window.
    4. Paste your text from Word.
    5. Press shift-command-T to make it plain text, if it's not already plain text.
    6. Select your text and copy from Text Edit.
    7. Paste into Mail.
     
  14. CBEtravel macrumors newbie

    Joined:
    Feb 22, 2011
    #14
    I agree with everyone here, this is truly an ANNOYING problem in Mac Mail.

    The soft return is actually control+return.. and i use it religiously.

    I experience the text spacing problem when I cut and paste from say an internet web page or somewhere where there is rich text formatting... and then change the text of other lines. Then when I change my mind again about what to say and hit (return) the annoying double space demon appears.

    There is a feature in Mac Mail called "Substitutions" with a setting of "smart copy/paste". I bring up the menu by right+click. Look under Substitutions.

    So when you copy rich text from somewhere and paste it into a Mac Mail message, it keeps the HTML tags I assume. Say I paste an H2 tag

    Well when you delete text in Mac Mail it doesn't always delete the formatting of that line. So even though your text LOOKS like it is 12pt Helvetica Regular, there is a phantom BOLD H2 tag there. So say you hit backspace when you make a manual bulleted list

    -like
    -this
    -one

    it will change to this on you when you hit the backspace/delete button.

    -like
    -this-one

    This can be solved by reformatting the -one back to -one and then holding down CONTROL and hitting return.

    Hope this helps!
     
  15. svenn macrumors 6502

    Joined:
    Aug 11, 2010
    #15
    I didn't realize others have had problems with this for so long, but I have run into this same issue many times. You would think Apple would make it simple to format email text, but apparently this issue has not been resolved in years. I know Gmail's web interface doesn't have this problem when I have tried to replicate it before.
     
  16. Dal123 macrumors 6502a

    Dal123

    Joined:
    Oct 23, 2008
    Location:
    England
    #16
    I get line spacing problems when from mail alone. Can't believe this problem has not been fixed. I cannot even paste from other previous emails.:mad:

    Did not have this problem in tiger, yet now on my new mac with os x lion I am having this silly problem :mad:.
     
  17. mister-tom macrumors newbie

    Joined:
    Feb 16, 2012
    #17
    Late in the day, but a simple solution

    If you have iWork use Pages instead of Word. You can copy the entire document from Word into Pages and then use the Pages version to copy from.
     
  18. SkyOtter macrumors newbie

    Joined:
    Nov 24, 2007
    #18
    Line spacing in Mail.app

    I've found no way to change the leading (line spacing) in Mac Mail.
    So, I often keep a blank TextEdit file open, into which I can paste any HTML, or Rich Text, or similarly formatted text. Then, I copy the text from TextEdit and paste it back into the e-mail.

    IMPORTANT: In order for this to work, the TextEdit file has to be in Plain Text format.
    Some people have their TextEdit default format (Prefs) set to Rich Text. Others might have it set to Plain Text. Once you've opened a blank TextEdit file, if it's not in Plain Text format, you can change it simply by going to the TextEdit main menu > Format > select "Make Plain Text."
     
  19. chinds1 macrumors newbie

    Joined:
    Feb 9, 2015
    #19
    A possible solution

    It seems that if you either compose the mail in Pages, or paste the text from Word into Pages, and then copy to Mac Mail, the formatting works. I'm using Pages 5.5.2 and finding it overall good for the simple tasks I do. And overall it's a lot less infuriating than Word (and I've been a Word user since Word for Dos 3).
     
  20. jowie macrumors 6502a

    Joined:
    Jun 9, 2004
    Location:
    London ish
    #20
    Great solution. Thanks!
     
  21. emilypollock521 macrumors newbie

    Joined:
    Nov 11, 2015
    #21
    THANK YOU! I'd just about given up finding a solution for this until I saw your post.
     

Share This Page