Links on one specific webpage won't work, regardless of browser

Discussion in 'Mac Basics and Help' started by icebergx, May 15, 2013.

  1. icebergx, May 15, 2013
    Last edited: May 16, 2013

    icebergx macrumors regular

    May 27, 2012
    Copenhagen, Denmark
    Hi all,
    I have a problem with a particular website ( on my rMBP.

    I'm unable to navigate to any pages on the website (apart from the main front page) because, when I click on any of the links on that page, Safari simply doesn't respond. The same happens with Chrome too!
    I haven't had problems on any other web page, so it's really annoying that it occurs on one of the websites I visit the most. I can navigate to links on the page if I right-click on it and 'open link in new tab,' just not with a regular left-click.

    I've tried deleting my cache, dns cache, navigation history, etc, but that hasn't resolved the problem. Any body have any other suggestions?

    Thanks for your help.
  2. GGJstudios macrumors Westmere


    May 16, 2008
    Make sure you don't have any active ad-blockers or JavaScript blockers that could be interfering. Try turning off all your Safari extensions before visiting the site.
  3. icebergx, May 16, 2013
    Last edited: May 16, 2013

    icebergx thread starter macrumors regular

    May 27, 2012
    Copenhagen, Denmark
    Thanks. Unfortunately this didn't do the trick. As I mentioned, I have the same problem on that website, when I use Chrome too, so I don't think it's a problem with the browser. Could it be something to do with the wifi connection?
  4. Fishrrman macrumors G5


    Feb 20, 2009
    Using a 2012 Mac Mini here, 10.8.3.

    I went to the page you specified (a soccer site, right?), tried a few links.
    Worked for me.
  5. Knoodles macrumors 6502


    Feb 2, 2003
    Gone to the Beach
    Not what you want to hear but no problems here either.
    Maybe change your DNS settings to Open DNS or Google DNS?
  6. onerunner2 macrumors newbie

    Apr 27, 2014
    Same issue, different site

    Have you found a fix to this problem?

    I am having the same problem, for me it is when i try to navigate away from via any of it's links. No matter if I'm using safari, chrome or firefox nothing loads. I have restored my browser's to their default setting but this did not solve the issue. I'm thinking it might have something to do with the fact that when you try to navigate away from to a different site, there are a few other websites that are rapidly accessed for advertising/tracking purposes but I can't find a security setting that solves this.

    Maybe related, a few months ago on amazon I was unable to view product images on the same computer, regardless of browser used. This problem "magically" solved itself after manifesting for a few weeks.

Share This Page