Linksys Problem

Discussion in 'iPad' started by dukefan, May 11, 2010.

  1. dukefan macrumors member

    Joined:
    Jul 14, 2008
    #1
    I got my Mom an iPad-16GB-Wifi for Mother's Day.

    We were at a hotel - I activated it with iTunes on her netbook and it connected fine to the hotel WiFi.

    She returned home and has been unable to get it to work on the WiFi at home.

    She has a Linksys WRT54GS router set up to use WEP-128 and a 26-character hex key. We have connected MacBooks, iPhones, and all sorts of Windows hardware to it with no problem using the 26-hex character key as the password

    The iPad connected to the network (e.g. the password was correct) but it would not get a valid DHCP address; the netbook was working fine.

    We then switched the linksys to WPA2 - and the same thing happens. The netbook connects but the iPad will not get an address. Again, note that if the key is wrong, the iPad will tell you that it's wrong.

    We then switched security OFF on the linksys - same thing. It connects, but will not get a DHCP address.

    We then turned WPA2-Personal back on on the linksys. The netbook connects fine. The iPad connects but will not get a valid IP address from the Linksys. So, we tried a static address (192.168.1.2) and it still will not connect to anything on the network.

    Thoughts? Wifi Software issue? Hardware?
     
  2. jimHdk macrumors regular

    Joined:
    May 10, 2010
    #2
    The first thing to do would be to update your Linksys WRT54GS router with the latest firmware. Check here: http://homesupport.cisco.com/en-us/wireless/lbc/WRT54GS/download

    You do not give details on what all your WiFi settings are. Please clarify what each field is set to. Note that a static IP address will not work correctly if it duplicates one in use or if you do not specify a DNS address.
     
  3. iArch macrumors regular

    iArch

    Joined:
    Oct 18, 2008
    Location:
    All Over
    #3
    Yo dukefan,
    I have that very same router and my 64gb 3G connects to it just fine (along with several laptops and two iPhones). Never a single problem. FWIW it's set to use "WPA Personal" and is running firmware v1.52.7. Just thought it worth mentioning...
     
  4. sdsvtdriver macrumors 65816

    Joined:
    Jul 31, 2008
    Location:
    Southern California
    #4
    Stop using WEP, use WPA or WPA2. Move off channel 6. 1 or 11.
     
  5. Battlestar macrumors 6502

    Joined:
    May 9, 2010
    Location:
    Boston
  6. Rob.G macrumors 6502

    Rob.G

    Joined:
    Jan 17, 2010
    Location:
    NW Oregon
    #6
    +1 to drop WEP and use WPA. WEP is notoriously flakey, I have lots of trouble getting anything to connect using WEP. But I have a WRT54GS also and my iPad works fine with it using WPA.

    And do the firmware update on the router too.

    Rob
     
  7. dukefan thread starter macrumors member

    Joined:
    Jul 14, 2008
    #7
    Resolution?

    Note that we started with WEP, had the SAME issue with WPA, and had the SAME issue with NO SECURITY!!

    Just for the record, I would classify my Mom as knowledgeable but not savvy.

    She took her setup into the Genius Bar this morning - had the router, the iPad, and her netbook. The Genius looked at it and told her that most iPads would not work with *most* Linksys routers. I'm not sure of the exact quote, but he basically said 80% of the iPads won't work with Linksys routers. The only way he could guarantee it would work would be to buy an Airport Express and replace the wireless on the Linksys.

    So that's what she did; that's what I figured would happen. Having said that, it really smacks of Microsoft-like behavior. This specific Linksys wireless router has supported iPhones, Macs, Windows, printers, all with no issues. Apple tells her that the only way for the iPad to work is to buy an Apple wireless router? WTF?? That's got to be a lawsuit waiting to happen.

    Assuming she will get the AE up and running and the iPad connecting, I'll fade away while contemplating how Apple really said the only way to connect it is to buy an AE... wow.
     
  8. Aduntu macrumors 6502a

    Aduntu

    Joined:
    Mar 29, 2010
    #8
    You can't expect people to have perfect information all the time just because they work at an Apple store. They choose from the same pool of people as everyone else. You also won't know for sure if they really did tell her the only way her iPad will use wifi is if she buys their product.

    There are multiple things that could be causing the issues. Did she ever try a complete restore of her iPad? Did she ever try updating the router firmware?
     
  9. Bulldog3777 macrumors 6502

    Joined:
    Apr 2, 2009
    #9
    Wireless

    I had the same router set to WEP and the 128 with 26 key code. Both mine and my wife's Ipads connected perfectly. Decided for some strange reason to get the Apple Extreme. Set it up and used WPA 2 and it works they work fine they work great off that. I just don't know about 80% not working with Linksys?????
     
  10. Aduntu macrumors 6502a

    Aduntu

    Joined:
    Mar 29, 2010
    #10
    That's called an idiot talking out of his ass. He's completely making that up. If 80% of iPads didn't work with Linksys routers, there would be an unstoppable uproar.
     
  11. GamecockMac macrumors 6502a

    GamecockMac

    Joined:
    Oct 20, 2005
    Location:
    Columbia, SC
    #11
    Apparently, not all "Geniuses" are created equal.
     
  12. Hammie macrumors 65816

    Hammie

    Joined:
    Mar 17, 2009
    Location:
    Wash, DC Metro
    #12
    You also need to make sure you have enough IP addresses in the DHCP pool. As mentioned, if you use a static IP address (which is outside of your DHCP pool), you wil also need to add the DNS Server(s). You also do not mention whether you are using MAC address filtering. This could also be a possible issue.

    BTW, WPA is better than WEP, but both should let you connect if you abide to the above information.
     
  13. Aduntu macrumors 6502a

    Aduntu

    Joined:
    Mar 29, 2010
    #13
    That's an understatement.

    WEP only keeps honest people honest. It shouldn't even be an option.
     
  14. ChrisJSNh macrumors regular

    Joined:
    Jun 22, 2009
    #14
    Well not sure if this is of any help. But i have a linksys wireless router.

    I use static here at home so i had dhcp disabled. And since if you set up the ipad to static it works fine. But when i turned wifi off on the ipad, it remembered the password etc for the network, but deleted the static ip settings.
    I turn the wifi off and turn on the 3g when i bring the ipad to work. And visa versa.

    So after getting tired of reentering the static ip on the ipad when i got home, i turned on the DHCP on the router. And set the starting address to .100, but the thing was i forgot that my vonage adapter (router) was set to 100. And the ipad wouldn't work on it. i then noticed the conflict.

    But my linksys is a year old and i never updated the firmware. and it works fine. I am pissed that the ipad remembers the network and password, but deletes the static ip info when you toggle wifi on and off. It had me going for a while, until i realized it did that
     
  15. dukefan thread starter macrumors member

    Joined:
    Jul 14, 2008
    #15
    To answer some of the questions...

    The DHCP pool was set to 50 and was increased to 150. There are only 4 devices on the network.

    Yes to broadcasting SSID.

    Was on channel 6; tried 11.

    This is a VERY old WRT54GS - I think it's version 1 running Ver.4.71.4.

    Again, I will repeat, everything works fine with an iPhone, Mac, Printer, or even a Windows Netbook. The iPad is the ONLY device experiencing the problem. It is joining to the network (e.g. password is correct when security is on; joins when no password) fine. It can't get an IP address from the DHCP server on the linksys. If I change it to get a static IP (yes, a valid unused IP and set the DNS server, netmask, gateway correctly), it just does nothing.
     
  16. dukefan thread starter macrumors member

    Joined:
    Jul 14, 2008
    #16
    And in the final update... of course, the iPad connects perfectly to the Airport Express the Genius told her to buy.
     

Share This Page