Linksys Router w/ New iMac

Discussion in 'Mac Accessories' started by orangeguy81, Dec 25, 2008.

  1. orangeguy81 macrumors newbie

    Joined:
    Dec 11, 2008
    Location:
    USA
    #1
    My parents were kind enough to buy me a new 20" iMac to upgrade from my old eMac 700MHz. I brought it up to my room set it up, but once I got it setup I noticed my wireless internet was really flaky and was dropping out.

    My router is a WRT54GS with DD-WRT firmware. It works fine with my old eMac (w/ original airport) and every PC in my house, but not with my new iMac (w/ airport extreme).

    At first I thought I might need to power cycle it, but it didn't work. Then I thought it might be conflicting with something, but that wasn't the problem. On a side note, I also have a WRTU54G-TM for VOiP phone. It works with both Macs equally, unlike the GS. The only problem with that one is it will randomly kick my Macs off the network and I end up turning off airport and turning it back on when that happens.

    I tried pinging to google and, on the GS, it varies from no connection to 50ms to 1000ms. Thats not right. On the TM, it varies from no connection to 50ms to 75ms. Thats more like it, but it still drops out.

    If someone could help me I would really appreciate it! Any questions please ask me.

    Thanks,
    Joe

    EDIT: One more thing...If you know of a good wireless router which works well with Mac, please tell me.
     
  2. Solemony macrumors 6502

    Solemony

    Joined:
    Nov 26, 2008
    Location:
    Wonderland
    #2
    I believe I have the same router as yours. Maybe try unplugging both your modem's and your router's power cord from the outlet and wait a few second and re-plug it back in. It should fix the problem b/c it happened to me once when I was trying to change my surge protector to a different one and the connection on my iMac G5 was lagging so I unplug both the power cord and it fixes the problem :).
     
  3. orangeguy81 thread starter macrumors newbie

    Joined:
    Dec 11, 2008
    Location:
    USA
  4. ziggurat macrumors newbie

    Joined:
    Dec 26, 2008
    #4
    Well good wireless router that works good with iMac and any mac ? airport express ? :p .

    Or looking for something cheaper ?
     
  5. Solemony macrumors 6502

    Solemony

    Joined:
    Nov 26, 2008
    Location:
    Wonderland
    #5
    Did you configure your router?...If you did you may have gotten a bad router...
     
  6. bearcatrp macrumors 68000

    Joined:
    Sep 24, 2008
    Location:
    Boon Docks USA
    #6
    what type of encryption are you using? WPA, WEP. etc.? Have found using WPA1 personal has problems so switched to WPA2 personal and works fine. Works better under WEP but wouldn't recommend using WEP.
     
  7. orangeguy81 thread starter macrumors newbie

    Joined:
    Dec 11, 2008
    Location:
    USA
    #7
    Thanks for everyones help...I brought it to the apple store and it has airport problems! They are going to replace the whole machine for free! They emailed me a shipping label and i am going to ship it out on monday!!

    Thanks again,
    Joe
     

Share This Page