Linux on a G5

Discussion in 'PowerPC Macs' started by newmacchick, Dec 5, 2008.

  1. newmacchick macrumors member

    Jul 10, 2007
    Hi guys,

    I recently acquired a 1.6 GHz G5 PPC, and I'd like to install Linux on it. I had to put in a new hard drive, so I put in a Seagate, 7200 RPM, 3.0 gb/s, 250 GB (just came yesterday). I'm not having any luck getting it to boot from a Linux disc though; my friend gave me a version of Feisty Fawn, no luck. I tried burning a copy of ubuntu, version 7.10 for PPC, from Apple's native utility but that didn't work either. I know that the super drive is reading, though, because if I put in my Macbook Pro copy of OS X it gives me angry messages. When I press the option button on restart, I get a blue screen with two buttons; a return button and a forward arrow button. Any ideas?

    Also, what's the right way to burn Ubuntu to a disc; I tried using FireStarter FX but it kept on telling me that burning could not be completed.

  2. Yaris macrumors regular

    Jul 26, 2007
    An easy way to burn a disk in os x is to use disk utility. Drag the .iso or whatever into the side column. Once you're there, click on the file in the side bar and click burn at the top.

  3. MacsRgr8 macrumors 604


    Sep 8, 2002
    The Netherlands
    Tried Yellow Dog Linux?
    I don't use it much, but I have it installed on a G5 Quad for fun... ;)
  4. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    I never tried Ubuntu on my G5 (iMac), because I do not have a wired keyboard for it (and Ubuntu doesn't really support a Bluetooth only input device environment), but I got Feisty (probably the last time I tried it) to boot just fine on my iBook G4.

    However, just how far are you getting? If you're not even starting the boot process -- the Mac isn't even trying to bring up Ubuntu off the CD -- then distribution has nothing to do with it. You're either burning wrong or somehow your Mac isn't set up to boot off that drive.

    Hmmm... let's check a couple things.

    You said that when you try option at boot, you just see the return and forward buttons... wait for a while (it doesn't show the available volumes immediately). Your system at least has an OS X volume still, right? At least that should show up in the available volumes once it does its scan.

    You should be fine with burning the ISO to a disc using Disk Utility. This is how I did it. Make sure that once you've burnt the disc, it has sensible looking Ubuntu live CD stuff in the root of the drive, and you haven't somehow done something like just burning a copy of the image file onto the disc as a single file on the disc.
  5. newmacchick thread starter macrumors member

    Jul 10, 2007
    Hi there,

    I will try what you've suggested tomorrow. However, I do not have an OS X partition; I bought an entirely new hard drive and chucked it in there. (I don't have a copy of OS X and would like to not have to buy one, which is why I'm installing Linux). One of my coworkers mentioned that it might be that the Mac might not recognize the 3.0 GB/s hard drive? Also, the hard drive has not been formatted in any way...should I do this before I try to install Linux? If so, how would I do that? (I have access to whatever I would need at my workplace.)

    Also, is it alright to open the disc on my Macbook Pro? I keep on getting messages such as, "this may destroy your system if mounted".

    I burned a copy of Ubuntu 7.10 "alternate" version to the CD. I'll try Yellow Dog.

    Here's the hard drive I bought: It does spin when the Mac is powered up.

    Thanks for your help!
  6. jodelli macrumors 65816


    Jan 6, 2008
    Windsor, ON, Canada
    Normally a 3.0 drive will run at 1.5 on a 1.5 controller, which is the one on the G5. Check for a jumper setting on the drive that might enable this.

    Ubuntu should partition and format the the drive as part of its normal setup procedure.

    Not with a PPC version of the Ubuntu live CD.
  7. sysiphus macrumors 6502a


    May 7, 2006
    Make sure when you burn the .iso in Disk Utility that if you see two listings for the iso in the sidebar, do NOT pick the one that is lower/inset--that looks like a mounted disk.
  8. Earl Urly macrumors regular

    Jul 11, 2004
    You should try to get a cheap copy at some point, sells some older copies of OS X, 10.4 should be as low as you go though

    You could download a Knoppix CD and see if you can format from there, or use one of the OS X discs if you can get one.

    FYI, as was mentioned before, just step down the drive to SATA I.. Seagate drives do have that jumper, I have a 500 GB SATA II Seagate running inside an iMac G5 (they share the same type of SATA I controller as the PowerMac G5s) with no problems at 150 speed.
  9. newmacchick thread starter macrumors member

    Jul 10, 2007
    Hey all, I have an update. So, I burned the CD image of Debian Linux for PowerPC, inserted it into the PPC and gave it a booted, I typed 'install', but then I got a white screen about "Invalid memory access at". It said I could type shutdown or mac boot, but it was frozen. (It said something about needing to release the keys). Any ideas?
  10. newmacchick thread starter macrumors member

    Jul 10, 2007
    Another update: I decided to install the 64 bit version and that went fine. However, it can't get past the second stage bootstrap. It looks like this:

    First Stage GNU/Linux Bootstrap

    Press l for GNU/Linux,
    c for CDROM.

    Stage 1 Boot:
    Loading second stage bootstrap..._

    Then I get the Mac icon which switches between a Finder face and a question mark. I am not all that familiar with Linux, so if anyone could provide instructions in laymen's terms...I did find these instructions:

    But I'm not sure how to apply them to this distro.

Share This Page