linux on macbook air rev B

Discussion in 'MacBook Air' started by icleary, Dec 11, 2008.

  1. icleary macrumors newbie

    Dec 11, 2008
    We wanted to try running linux on a macbook air rev B using an open suse 11.1 RC1 live CD and the macbook air external drive. The system appeared to hang partway through the startup so we rebooted in Mac OS where something odd happened. Now the USB port no longer worked. It had power (the optical mouse lit up) but no device would work, nor would any kind of external drive mount. Other USB internal devices functioned normally (iSight, keyboard, trackpad, bluetooth) but the port was non-functional. We tried several diagnostics/repairs (fsck, PRAM flashing, repairing disk permissions, hardware check) but nothing worked, nor did installing the EFI firmware update (released earlier this week). Eventually we installed several other available updates, including the SMC Firmware update released this week, and suddenly the USB port was functioning normally again. Not sure exactly what went wrong or exactly what fixed the problem, but glad it's working again. Just wanted to pass on this info in case anyone else runs into similar problems or before anyone tries the same thing.
  2. 4np macrumors 6502a


    Feb 23, 2005
    The Netherlands
    I can recall hearing / reading a similar story with a MBP or MB some time ago as well... Weird problem though?
  3. macbook123 macrumors 68000

    Feb 11, 2006
    Very interesting, so are you saying you're now successfully dual-booting into OS X and Linux, with everything working in the latter?
  4. icleary thread starter macrumors newbie

    Dec 11, 2008
    We stopped trying to run linux once the usb port was working again in Mac OS. Still curious as to whether this or another form of linux will work off the live cd, but without knowing exactly what the fix was we're not quite ready to try again yet and lose communication with the only port without a sure-fire way to get it working again.

Share This Page