[Linux] Unsupported drive - OCZ firmware

Discussion in 'MacBook Pro' started by DustinT, May 18, 2011.

  1. DustinT macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #1
    I'm looking for specific information on how you managed to overcome this error running LINUX fwupd 1.15 with the SSD installed in a Macbook. I've tried hdparm to force sleep\standby mode with no success. The drive I'm using to test wouldn't mount so that wasn't the problem. I'd like to be able to test it with the drive mounted but from some reason Ubuntu 11.04 live cd doesn't read the file system on the Vertex 3 I'm using.

    I've got a nice how-to guide for using a Ubuntu 11.04 live cd to update the firmware but without a reliable fix for this error I'm reluctant to publish it. Any help would be appreciated.
     
  2. getz76 macrumors 6502a

    getz76

    Joined:
    Jun 15, 2009
    Location:
    Hell, AL
    #2
    I tried everything and never got it to work, and I know enough to know how to do it. I spent several hours.

    I finally installed Windows via Bootcamp on the system with the drive and it took less than a minute to update my Vertex 2.
     
  3. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #3
    lol good ol windooze!

    can you update the f/w when running from the ssd! i thought tony and praz over at the ocz forums said the os (linux/win) should not be running from the ssd when flashing it for f/w update?
     
  4. DustinT thread starter macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #4
    I have heard reports of this working but I have not been able to confirm it. When I try I get the message the updating is not supported on the primary drive.
     

    Attached Files:

Share This Page