Lion 10.7.3 external hdmi tv issue (come on apple!)

Discussion in 'Mac OS X Lion (10.7)' started by D-a-a-n, Feb 7, 2012.

  1. D-a-a-n macrumors regular

    Joined:
    Mar 22, 2010
    #1
    Hi all,

    I'm having this annoying problem:

    When I connect my external tv on my mid 2010 15" mbp using a hdmi to minidisplayport, all goes well, I even get sound through it :eek::D

    Ever since I upgraded to 10.7.3, my screen goes black, but when I move my mouse I can see some GUI elements appearing though...really strange ..something is not being redrawn correctly I guess

    Is anybody experiencing the same problem?

    Btw: my tv is a 1080p LG
     
  2. noah123 macrumors newbie

    Joined:
    Sep 2, 2009
    #2
    I have a white MacBook late 2009 and the update to 10.7.3 definitely broke the mini displayport -> HDMI output for me.

    The graphics gets all messed upp on both the computer and the TV as soon as I connect the adapter. After connecting the mini displayport adapter I'll have to reboot on the button to get the normal graphics back. Needless to say, I'm not impressed.

    By messed up graphics I mean like this. I can only access a portition of the screen, the mouse pointer isn't activating things that are directly under it, tiles of background vs foreground are messed up and some pieces are missing etc.
    http://imgur.com/a/HyxCd#0

    Everything works OK if I use a mini displayport cable to hook it up to my iMac 27", so I don't believe this is a hardware problem on my end. I've tried everything from deleting prefereces, creating new user administrator accounts to reinstalling Mac OS X 10.7.3 from both the recovery partition (Cmd-R) and from scratch to no avail.
     

    Attached Files:

  3. D-a-a-n thread starter macrumors regular

    Joined:
    Mar 22, 2010
    #3
    Indeed these are the problems I'm also facing. I even tried rebooting but that didn't work :(.
     

Share This Page