Lion and Firewire

Discussion in 'Mac OS X Lion (10.7)' started by MBPi7, Jul 21, 2011.

  1. MBPi7 macrumors member

    Joined:
    Jan 20, 2010
    #1
    Enjoying the new OS.
    Unfortunately I seem to have no firewire. My audio interface no longer seems visible to OSX or Logic.
    Anybody else having this problem?
     
  2. kuebby macrumors 68000

    kuebby

    Joined:
    Jan 18, 2007
    Location:
    SFV
    #2
    I don't have an audio device but after installing Lion I tried connecting my FW800 RAID enclosure and it worked just fine (and the software RAID was recognized as it should).
     
  3. polkunus macrumors member

    Joined:
    Feb 15, 2011
    #3
    Lion kept on crashing with my firewire solo. I installed beta drivers and it worked fine.
     
  4. MBPi7 thread starter macrumors member

    Joined:
    Jan 20, 2010
    #4
    Thanks, that's encouraging. Still no luck here. Anyone else using an FW1884?
     
  5. Enlightenme1127 macrumors newbie

    Joined:
    Jul 22, 2011
    #5
    Kernel Panic !!

    Since Lion, every time I turn on my firewire 400 MAudio pro fire 2626 I Kernel Panic and crash.
    And then if I attempt to boot and the audio interface is turned on, I kernel panic before I even get passed spinning gear.

    I also have a LaCie FW800 drive attached that is working fine.
     
  6. Paulywauly macrumors 6502a

    Paulywauly

    Joined:
    Sep 26, 2009
    Location:
    Durham, UK
    #6
    running a Drobo v2 over here over FW800 on a late 2009 iMac, no problems at all
     
  7. Enlightenme1127 macrumors newbie

    Joined:
    Jul 22, 2011
    #7
    It seems to be audio interfaces, not hard drives that are having problems.

    Just came from m-audio site, there was an update promising this:

    "
    2.3.2
    ● Fixed a problem that caused a crash on Mac OS X version 10.7. "

    Let's see what happens.
     
  8. Steve686 macrumors 68030

    Steve686

    Joined:
    Nov 13, 2007
    Location:
    US>FL>Miami/Dade>Sunny Isles Beach>Condo
    #9
    just for audio reference, USB seems ok with a Fender G-DEC amp. no crashes or panics yet.
     
  9. Ukdeluded macrumors newbie

    Joined:
    Jul 24, 2011
    #10
    Fw-1884

    @MPBi7 - I've got the FW-1884 and I can confirm it does not work with Lion. I've spoken to Tascam and they will not be developing a 64-bit version version of the driver so it's a dead duck.

    I have asked Tascam if I can get the code for their 32-bit driver so I can make a 64-bit one, but I have no idea if they'll help or not. If they do I'll let you know.
     
  10. appahappa macrumors member

    Joined:
    Nov 29, 2010
    #11


    I've got the same problem. Really annoying. The FW-1884 is a nice product but the driver situation always been a mess. Only the last driver version 1.7 was really stable. Won't buy anything from Tascam! A buddy of mine has the Mackie Onyx 1640i Mixer it doesn't even need a driver under Mac OS X. Works out of the box!
     
  11. Ukdeluded macrumors newbie

    Joined:
    Jul 24, 2011
    #12
    FW-1884 on Lion WORKING!!!!!!!

    If anyone is still reading this, then here is the fix. For the FW-1884 to work with lion, you have to put Lion into 32 bit mode. After a lot of testing I've found no problems with this and both Logic and FW-1884 work perfectly, faster I'd say than Snow Leopard still.

    Open up terminal and type this in:

    sudo systemsetup -setkernelbootarchitecture i386

    Put in your password and then reboot.

    When you want to go back to 64bit for whatever reason, open terminal, type:

    sudo systemsetup -setkernelbootarchitecture x86_64

    Password, reboot.

    Hope this helps some of you FW-1884 users!
     
  12. Adampeters841 macrumors newbie

    Joined:
    Jul 26, 2012
    #13
    FW1884 in Lion w. Ivybridge Processor

    Hi Ukdeluded,

    Have you had any joy with Tascam giving you access to the code to try and write a firmware update to the 1884 to run in 64bit mode. It seems like Apple are no longer support the 32-bit kernel since they shifted over to the Ivybridge Processors, however they neglected to inform people of this at all.

    If you've got the code I'd be willing to pay for it as well.

    Thanks,

    Adam
     
  13. nutotech macrumors newbie

    Joined:
    Dec 23, 2012
    Location:
    Dallas-Ft. Worth
    #14
    FW-1884 driver to 64 bit

    Count me in as well if you can find someone who will have the code written. Will gladly chip in to defray the cost.
     
  14. spoonie1972 macrumors 6502a

    Joined:
    Aug 17, 2012
    Location:
    Toronto
    #15
    no issues with FW800>400 adapter and two different Motu products.

    could just be bad driver writing, or a 32/64 bit driver thing.
     
  15. scenicview macrumors newbie

    Joined:
    Jan 8, 2013
    Location:
    Provo, UT
    #16
    Mac Pro with LION and FW-1884?

    Just curious Ukdeluded... what computer were you using? I know this is an old post, but I've just set up a Mac Pro with LION and can't get the FW-1884 to work, even when booting up in 32-bit mode. In a post on another forum, someone was saying its an actual hardware incompatibility between the 2009 Mac Pro's firewire ports and the Tascam FW-1884. Were you by chance using a Mac Pro? If so, or if you know that 2009 Mac Pros will work somehow, this would be great. If not, it'd be nice to know if you DIDN'T use a Mac Pro just so I can be sure it won't work and revert to Snow Leopard. Thanks!
     
  16. mzb macrumors newbie

    Joined:
    Jan 7, 2014
    #17
    Hey scenicview, I know this is an old post ;) and you've probably moved on, but for the record my FW-1884 works fine on my 2009 MacPro 4,1 with 32-bit Lion. It sometimes takes a reboot or two before the Mac recognizes the FW connection to the Tascam. Only other weirdness I've noticed is that the Play transport button doesn't work with Garageband ... but everything else seems to be fine.

    Now, if someone could just figure out a way to make the FW-1884 run in 64-bit mode, my life would be complete!
     

Share This Page