Lion and rEFIt

Discussion in 'Windows, Linux & Others on the Mac' started by gnhaku, Jul 22, 2011.

  1. gnhaku macrumors newbie


    Jul 22, 2011
    I have Lion clean install and rEFIt on it. rEFIt menu doesn't appear. Any suggestions why so?

    Or maybe is there any alternative to rEFIt?
  2. costabunny macrumors 68020


    May 15, 2008
    Weymouth, UK
    I had to reinstall rEFIt after Lion on mine (am tripple booting for now until I'm happy with it).

    2 reboots later and rEFIt showed its familiar face with my SnowLeo, LionTest and Winslowz volumes.
  3. gnhaku thread starter macrumors newbie


    Jul 22, 2011
  4. Nopstnz8 macrumors member


    Mar 22, 2010
  5. joec1101 macrumors 6502a

    Jun 29, 2010
    So Cal, USA
    I can't get it to work at all. Tried reinstalling, rebooting several times and still nothing. Hopefully an update will be available soon.

    Now I hold down the option key on restart to get the Apple boot selector and "Macintosh HD" shows up twice along with the Windows icon. I thought maybe one icon was for the Lion Recovery partition, but both Macintosh HD icons boot into Lion. :confused:

    Anyone else run across this? Solutions?
  6. brutuspa macrumors newbie

    Jul 28, 2011
    reFit working - no problem

    This worked for me on the first try:

    sudo /efi/refit/

    I'm really glad this didn't break.
  7. seong macrumors 65816


    Feb 11, 2010
    That's the terminal code, right?
  8. seong, Jul 30, 2011
    Last edited: Jul 30, 2011

    seong macrumors 65816


    Feb 11, 2010
    Where, exactly, did you get the code brutuspa? If you are going to post a command that screws ppl's computer, don't post it. I don't know how you got it to work, but all of my machines are stuck in loading screen, thanks to you. why did I try it on almost all macs? Because I wanted to see if my MacBook Pro was the one causing the problem. Now, booting into safe mode won't even let me log in.

    I had to boot into the small partition created once Lion is installed, load Disk Utility, and repair disk and repair disk permission to get my computer working again. I found some sources about the command "sudo /efi/refit/" but I don't think it will work on Lion? No idea how all of my machines just froze up even after restarting 5 times.
  9. mrf macrumors newbie

    Jan 9, 2009
    Worked for me

    Thanks for the pointer to brutuspa that finally got refit showing up for me again.

    Seong any file that ends in .sh is most likely a shell script which means it is probably going to run a succession of commands in your terminal.

    Open the file, take a look at what its doing, if you don't understand or don't trust the source of the file then don't run it.
  10. scottd70192 macrumors newbie

    Dec 7, 2011
    Another solution...

    After trying all the above mentioned methods, I tried something a little different. I read somewhere that the auto install pkg from refit also installs startup items as well as the efi folder in the / directory. Apparently, this can cause an issue. So, I booted into an install disk of Lion (not the recover drive, but a custom install disk) and repaired the disk and disk permissions. Then, I removed the efi folder, and the start up items. (they are in a folder that is like /Library/Startup Items/refit or something like that...) Then I shut down the computer for the night and waited until the next day to try the following... and I do not know if the waiting overnight actually did anything, but just wanted to through it out there... So the next morning, I installed refit manually exactly by the directions on the refit site. Worked like a charm! When I shut down the computer and turned it back on, low and behold refit popped up! I have been working on this for a couple weeks now, and out of everything, this is the only thing that has given me consistent results, it boots to refit every time now.
    Let me know if this works for anyone else!
  11. opelfahrer79 macrumors newbie

    Dec 16, 2011
    works great! thanks a lot man...


    just wanted to confirm that your method works great. I did exactly follow your procedure (with the exception that I just shutdown and restarted instead of give it a whole night cool-down) and it works right from the start.

    Great work and thanks again!
    Cheers :):):):):)
  12. pier macrumors 6502a


    Feb 7, 2009
    I have Lion and Bootcamp with Win 7.

    Not only rEFIt broke my Bootcamp, it also broke my mac os installation.

    Uninstalling rEFIt was a pain, and now I'm left with an unusable Bootcamp partition, and a broke Lion partition. I can't repair my Lion disk with Disk Utility, and I can't install Lion to a USB key (something I have done many times before).

    Seriously, keep away from rEFIt... IME it's a POS. YMMV.
  13. MakkerM macrumors newbie

    Jan 16, 2012
    Yes Scott, it works perfect. I have been struggling the last weeks to install rEFIt and the standard installation method did not work and the manual install by the terminal give me just one good EFI boot and the next time it was gone again. I followed your method by the letter and now it works every time. I even see my usb/firewire disk at (after) startup. Thank you very much for this simple method.

    I have only one comment. I suppose that a lot of people like myself try to install EFI by rEFIt-0.14.dmg. That did not work with me. But doing this has the consequence that the rEFItBlesser will be installed also. This could be the problem. As you mentioned in your text to remove in the folder /Library/Startup Items/ the map -> rEFItBlesser (it was the only one in my case) is probably the solution.

    In that case the only thing to do is:

    remove rEFItBlesser in /libary/Startup Items/
    Restart computer or shut down and open
    Open Terminal

    cd /efi/refit


    fill in your (computer login) password....


    And it works.

    I did not test this without the repairing disk and disk permissions with a install CD. I am so glad it works now finally.

  14. patrocle25 macrumors newbie

    Jan 27, 2012
    hello, do I know if your install of refit works well on new macbook pro 2011 please? I'm afraid to broke my current install of os x lion.

  15. phaedarus macrumors regular

    Dec 27, 2008
    I just recently installed refit myself using the provided installer package and what a disaster it's turned out to be for my late 2011 MBP with Lion.

    Not only does the Refit menu not appear, but my system hangs at every second reboot; which can only be solved with a hard boot (forcefully powering off the system) - and that doesn't help in any way with the longevity of my MBP!

    I now want to uninstall refit which requires that i either delete or rename the EFI folder. Except that I can't. Any attempt to either rename the folder or move it to the trash results in "Operating Cannot be Completed. An unknown error occurred" after keying in my account password.

    Great! So not only is refit royally screwing up my OSX partition, but I can't even uninstall it!

    Any help would be greatly appreciated.
  16. aummac macrumors newbie

    Aug 10, 2011
    Yes Refit is working for us with Lion 10.7.2 and Windows 7 SP1. I installed it performed 2 reboots then ran the command:
    sudo /efi/refit/

    Refit appears to be stable and a good solution for us since bootpicker has ended support. We will use in our labs this week. Thanks!
  17. joec1101 macrumors 6502a

    Jun 29, 2010
    So Cal, USA
    It seems to have broke with 10.7.3

    I have tried everything and it just won't work. If anyone has any suggestions/solutions, please chime in here... thanks
  18. danj111 macrumors newbie

    Mar 1, 2012
    rEFIt -

    How can I prevent rEFIt from starting up automatically after I have run the sudo
  19. BlackF macrumors newbie

    Feb 11, 2012

    Same here!
    I can't get it work on my MBP with Mac OS X 10.7.3. After the installation, the rEFIT menu didn't appear at startup and after the second reboot I wasn't able to boot to Mac OS X!
    I had to start from the recovery partition and run the disk utility to "repair" the disk. After that it was possible to boot Mac OS X again (but still without any appearance of the rEFIT menu).

    All the methods from above didn't work!!

    Does someone has a solution for that???
  20. AirThis, Mar 6, 2012
    Last edited: Mar 7, 2012

    AirThis macrumors 6502a

    Mar 6, 2012
    I've got rEFIt to work with 10.7.3. I'm multibooting with Ubuntu at the moment. My receipe is given below. You need to install rEFIT manually. Otherwise it won't work.

    Disclaimer: Use the following instructions at your own risk. I'm not responsible if you lose any data or if something goes wrong with your Mac. A backup is strongly recommended before starting. These are not step by step instructions which you can follow blindly. You will need to adapt this method to suit your particular configuration. I suggest you read thru the instructions from A to Z before deciding if you want to try this or not. I have a Mac Mini 2009 edition. I only tested this with Ubuntu 11.10 and have no idea whether it will work with Windows or not.

    Preliminary Note: there is a bug in the Disk Utility program shipped with some versions of Lion which prevents partitions from being resized properly. The method given below requires Disk Utility version 12.1 rev 348 (or higher). This can be obtained by creating a bootable drive using these instructions (from MacWorld):

    A manual method to get rEFIt working with 10.7.3

    To install Linux, I decided not to use Boot Camp. Instead, I shrunk my existing OSX partition using Disk Utility. With the disk space gained, I created a Linux partition and a small Refit partition.

    After repartitionning my disk with the Lion bootable thumb drive (made using the link given above), I ended up with this:

    diskutil list /dev/disk0
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *320.1 GB   disk0
       1:                        EFI                         209.7 MB   disk0s1
    [COLOR="Red"]   2:                  Apple_HFS Macintosh HD            265.6 GB   disk0s2[/COLOR]
       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
    [COLOR="Purple"]   4:                  Apple_HFS rEFIt                   939.5 MB   disk0s5[/COLOR]
      [COLOR="DarkGreen"] 5:                        EFI                         52.4 GB    disk0s6[/COLOR]
    [COLOR="Red"]Red = Mac paritition[/COLOR]
    [COLOR="Purple"]Purple = rEFIt partition[/COLOR]
    [COLOR="DarkGreen"]Green = Linux partition[/COLOR]
    All other partitions = danger don't touch !
    I installed rEFIt manually on the small partition I created above (disk0s5), following the instructions provided on the rEFIt web site. Basically you need to copy the rEFIt folder onto the desired partition and then run ./ in that folder:

    cd /Volumes/rEFIt/efi/refit
    sudo ./ 
    Because I installed rEFIt on a separate partition, it was necessary for me to bless that partition like this:

    sudo bless –device /dev/disk0s5 –setBoot
    After I had done all this, I rebooted and saw the rEFIt menu. Then I installed Linux onto the paritition I created specifically for that (disk0s6). Note/edit: when you install your OS, make sure you don't overwrite your MBR. With Ubuntu there's an option to install the boot loader on your partition (rather than over the MBR), but in Windows I'm not really sure how that works. Proceed with caution... In Linux I installed the boot loader on /dev/sda6 (my partition) rather than on /dev/sda (the MBR) as shown below.


    How to disable rEFIt using this method

    To disable refit and have my Mac boot normally, all I need to do is to "move the blessing" from disk0s5 (my rEFIt partition) to disk0s2 (my regular Mac partition). This is done with these two commands:

    sudo bless -folder /System/Library/CoreServices/
    sudo bless -device /dev/disk0s2 -setBoot
  21. BlackF macrumors newbie

    Feb 11, 2012
    Thanks, AirThis!

    That sounds good. I will try this out as soon as I have time for that. ;-)

    But I think the partitioning is also possible if you boot in safe mode (hold down the shift key at startup).
  22. AirThis macrumors 6502a

    Mar 6, 2012
    Disk Utility 12.1 rev 346 came with my Lion install and it has a bug: you can't resize partitions properly. The reason I created the bootable thumb drive was to get Disk Utility 12.1 rev 348 (which doesn't have the bug).

    Getting rEFIt installed is actually the easy part. It's when you install your OS that things get tricky because you have to make sure you don't overwrite the MBR. With Unbuntu I had the option to install the boot loader on the newly created partition (and not overwrite the MBR). With Windows, I imagine you can do the same, but I'm not sure how. So a good backup is definitely needed...
  23. kkrull macrumors regular


    Dec 19, 2006
    Most Helpful \ Least Helpful \ Thoughts on rEFIt

    I would like to nominate AirThis for the most helpful post...

    and pier for least helpful...

    I have installed rEFIt on no fewer than a dozen machines and although I don't completely understand the EFI boot chain, with the help of the author or these forums I always manage to get a beautiful interface that provides functionality I can't get anywhere else.

    Christoph Pfisterer, the rEFIt author, is an excellent coder and a great person. When the first Macbook Air was released I sent him some reports from my machine and he built a new verision of rEFIt without even seeing a Macbook Air.

    Yeah, I would love to have a utility to install and configure rEFIt as a general purpose UEFI multiboot tool without MBR support, maybe even one that manages partitions, but I am not going to disparage anyone's genuine efforts in this forum.
  24. mac-hacks macrumors regular

    Jan 14, 2011
    Swimming In Tsunami
  25. BlackF, Apr 16, 2012
    Last edited: Apr 27, 2012

    BlackF macrumors newbie

    Feb 11, 2012
    It's possible to install Windows the normal way on a Mac.

    If someone is interested in setting up a triple-boot Mac with Mac OS X 10.7, Windows 7 and Ubuntu 11.10 using rEFIt, I wrote a small how-to about it.
    It's available here:

Share This Page