Lion Broke wi-fi

Discussion in 'Mac OS X Lion (10.7)' started by theking79, Jul 22, 2011.

  1. theking79 macrumors 6502

    Joined:
    Apr 28, 2009
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    After installing lion my wi-fi connection is constantly dropping out, and sometimes when it is connected, web pages don't load.

    Anyone else got this problem? This needs to be addressed urgently by apple as having the Internet is one of the most basic needs when having a computer.
     
  2. johnyd123 macrumors newbie

    Joined:
    Jul 22, 2011
    #2
    Yes I have the same problem! I have to keep refreshing pages because they dont load the first time. Does your safari take up to a 100% CPU as well? I had to change back to Chrome which is a shame because I really like the new features of Safari. Safari just really slows down my 2011 macbook pro.
     
  3. Ramunas macrumors member

    Joined:
    Feb 17, 2010
    #3
    I am experiencing the same problem with the Wifi. But safari does not cause my cpu to be at 100%. Although, my laptop does tend to run a bit hotter than it used to do on Snow Leopard.
     
  4. Salukipilot4590 macrumors 6502

    Salukipilot4590

    Joined:
    Mar 17, 2009
    Location:
    Los Angeles, CA
    #4
    I had this problem as well but after turning off airport then turning it back on, and a restart....I don't seem to have as many issues.
     
  5. chalkie macrumors newbie

    Joined:
    Jul 21, 2011
    #5
    I had similar, except my entire net connection wouldn't work. Everything apart form MSN Messenger refused to connect to the net. Spent an hour on the phone to Apple and eventually worked out Avast was the issue. It doen't like Lion, so if you've got it, uninstall it, empty Trash, and restart. That cured it for me. I don't know if any other anti-virus software is causing issues, but if you've got it installed it might be worth doing as I described above.
     
  6. zedtech78 macrumors newbie

    Joined:
    Mar 30, 2011
    Location:
    Toronto, Canada
    #6
    I've found a workaround for this that seems to be working on my 2011 MBP.

    1. Systems Preferences -> Network
    2. Under "Wi-Fi", click on the "Advanced" button.
    3. Under the "DNS" tab, add the Google Public DNS - 8.8.8.8
    4. Click OK, then click Apply.
    5. Turn WiFi OFF, then turn it back ON again.

    Hopefully there's a fix for this soon but so far, this works like a charm on my MBP. Way better than manually having to turn wifi off and back on again every time I wake the laptop from sleep.

    Good luck!
     
  7. couto27 macrumors 6502

    Joined:
    Nov 10, 2008
    Location:
    lisboa,portugal
    #7
    the problem is between the chair and the desk.
     
  8. HawaiiMacAddict macrumors 6502a

    Joined:
    Dec 28, 2006
    Location:
    On one of my Macs of course
    #8
    Actually, the official term is PEBKAC - Problem Exists Between Keyboard And Chair, courtesy User Friendly
     
  9. Teyla macrumors newbie

    Teyla

    Joined:
    Jun 15, 2010
    #9
    Actually it's PICNIC, Problem In Chair Not In Computer
     
  10. Jony Mac macrumors 6502

    Jony Mac

    Joined:
    Oct 27, 2010
    Location:
    Pittsburgh, PA
    #10
    I noticed with Lion, if I put my MacBook to sleep (close the lid) and re open it, the wireless gets dropped. In SL it would automatically join back to the wifi.

    The only way I can fix this in Lion is to goto the Wireless icon in the task tray and manually select my hot spot.
     
  11. couto27 macrumors 6502

    Joined:
    Nov 10, 2008
    Location:
    lisboa,portugal
    #11
    no lion or wifi issues here(router smc) + (router aebs)

    mbp13 late 2009
    mb air original
     

Share This Page