Lion broken @ my university wifi, widespread problem!

Discussion in 'Mac OS X Lion (10.7)' started by iRCL, Nov 2, 2011.

  1. iRCL, Nov 2, 2011
    Last edited: Nov 2, 2011

    iRCL macrumors 6502

    Joined:
    Nov 2, 2011
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Here at George Mason University about 2 weeks ago my MBP running 10.7.2 mysteriously started failing to work with the campus wifi. I submitted a ticket and learned that this is widespread and totally unresolved.

    I find this pretty strange. It isn't an issue with Safari or anything. I grab a DHCP address and get just incredible packet loss, but packets that get through are normal latency.

    Anyone else experiencing this? We use a log-in server thing for wifi. Could just be idiot admins messing up the settings but it's very strange to only affect lion. My iPhone 4 iOS 5 is fine

    ------

    EDIT:

    And to make things more weird, when I get home on to my wifi, my networking refuses to work until I reboot my machine. Turning on/off wifi doesn't help, closing all my apps doesn't help.. it's strange, I can `dig` hosts and get their ip's, that's about it.

    It almost appears to be a vulnerability in OS X 10.7.2 considering that something can have such a significant effect.
     
  2. iRCL thread starter macrumors 6502

    Joined:
    Nov 2, 2011
    #2
    To add more comments to this -

    I'm still noticing it on my freshly formatted nothing-installed Air 10.7.2. The very recent Safari update did nothing. Sometimes using firefox helps, but sometimes it doesn't. I'm almost certain it has to do with the higher level network APIs because everything Apple makes seems to cause the problems, and they'd for sure be using that stuff (as everyone ought to)

    Last night I was very frustrated, rebooted several times to get things to work, restarted WiFi over and over, etc. Finally I quit screwing with it b/c I was discussing a project with someone, and when I started using my computer again everything worked fine (flawlessly for the next 3 hours)..

    I've seen some anecdotal evidence of the same problems from people on the net but nothing clear. Anyone with any ideas???
     
  3. mspy macrumors member

    Joined:
    Apr 30, 2005
    Location:
    Northern Virginia
  4. iRCL thread starter macrumors 6502

    Joined:
    Nov 2, 2011
    #5
    I refuse to screw with kernel drivers on my Mac, so I have not and will not try it
     
  5. numitor macrumors newbie

    Joined:
    Mar 11, 2011
    #6
    I'm at GMU, too, having problems at the Arlington Campus, same as OP describes. ping'ing yahoo.com shows 40-50% packet loss; ping'ing gmu.edu 100% packet loss...

    I tried the kernel extension described by the above-mentioned link, about a week ago. Thought it made things somewhat better, but turns out I'm still having the same problems...

    One thing that seems to work (not sure that's this is what's making things work, though...) is going into Network Preferences, deleting the WiFi entry in the left column, then re-adding it. Have to do it each time the problem occurs, though, which is a pain.

    Hope someone can find a real solution...
     
  6. numitor macrumors newbie

    Joined:
    Mar 11, 2011
    #7
    Anyone know if this has been fixed with the new Lion release (10.7.3)?
     
  7. Ayemerica macrumors 65816

    Ayemerica

    Joined:
    Oct 18, 2011
    Location:
    Atlantis but in space
    #8
    having the same problem at my local community college
     
  8. SDub90 macrumors 6502a

    Joined:
    Nov 9, 2009
    Location:
    Long Island
    #9
    Try using chrome or firefox to connect to the wifi with SNAP, then you can minimize the browser and continue with Safari.
     
  9. iRCL thread starter macrumors 6502

    Joined:
    Nov 2, 2011
    #10
    This is what I do

    I found information that detailed this issue and it has to do with a (buggy?) way that Lion handles SSL certificates. Someone created an application to basically auto-login to GMU's SNAP here: http://code.google.com/p/gilgamesh-applet/ and it discusses the issue

    I just open Firefox, browse to the uacwireless.gmu.edu, wait, and then log in and minimize Firefox. Just be patient but it does take 60-90 seconds and is a pain yes.

    No idea if 10.7.3 fixes this but I'm going to investigate soon. Not holding my breath
     
  10. numitor macrumors newbie

    Joined:
    Mar 11, 2011
    #11
    So do you guys at GMU also get timed out maddeningly frequently???
     

Share This Page