Lion Can't See Files on External Hard Drive

Discussion in 'Mac Basics and Help' started by kimkg, Nov 23, 2011.

  1. kimkg macrumors newbie

    Joined:
    Nov 23, 2011
    #1
    Hi,

    I'm having some trouble with my iMac today. It can't see any files on my NTFS External Hard Drive.

    Yesterday evening I tried to share the drive over my network by clicking System Preferences / Sharing / File Sharing and then adding the drive as a shared folder. It is since doing this that I cannot see my files on this external HD. I have a second NTFS HD here which I connected and I can see the files on that drive so I don't think it's a software issue.

    I have tried a few things to try and fix it but to no avail.

    1. I have tried removing it from the shared folder list but that hasn't solved the problem. I tried adding it a second time just in case but that didn't do anything either.

    2. I have repaired the disk permissions via disk utility

    3. I have tried "defaults write com.apple.finder AppleShowAllFiles TRUE
    killall Finder" to show hidden files but they still don't appear. I have reversed this so hidden files are no longer visible.

    If I connect the drive to my Windows 7 laptop I can see and access all of the files.

    I hope someone can help out with this issue. If you need any other information just let me know.

    Kind regards,
    Kim

    System Details

    iMac 24" Early 2008 Model
    Core 2 Duo - 3.06Ghz
    4GB RAM
    OSX 10.7.2

    iomega 1TB External Hard Drive
    Formatted NTFS

    Paragon NTFS for Mac OSX v8.0.0
     
  2. harlex macrumors member

    Joined:
    Nov 23, 2011
    #2
    Lion can't see HDD

    The NTFS file system on your hard drive cannot be read by Lion because it is not in a file structure that OX 10 can read. If you search the internet there is a piece of software that you can download onto OX10 (Lion) and it will read it. The software I really can't remember what it is but I have used it.

    Search for how can I read NTFS on Lion or iMac.
     
  3. kimkg thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #3
    Hi,

    Thanks for your reply but I'm already using Paragon NTFS for Mac OSX v8.0.0 I've been using this NTFS HD for 9 months with this mac, The problems only began when I changed the sharing settings last night.

    Kind regards,
    Kim
     
  4. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #4
    This is incorrect information. Lion can read NTFS, it cannot write to NTFS natively. For writing you need special software.

    To read files from an NTFS formatted drive you should not need special software.
     
  5. kimkg thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #5
    Thanks for your reply but I think we're missing the issue here.

    I've been using this NTFS formatted hard drive with this iMac for 9 months. I have Paragon NTFS for Mac OSX installed and was able to read and write to the hard drive. I am still able to write new files to the hard drive but Finder is not showing any of the existing files that are on the drive. All of the Folders are there but there are no files visable.

    Thanks
    Kim
     
  6. xdefx macrumors newbie

    Joined:
    Jul 22, 2009
    #6
    Hello

    Have you tried right clicking in the hard drive folder and go to "Clean Up By" "Name"?

    It should move any files to the top of the folder if your in Icon view.

    Dan
     
  7. kimkg thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #7
    Hey,

    No it's not a simple problem like that.

    Cheers
    Kim
     
  8. xdefx, Nov 24, 2011
    Last edited: Nov 24, 2011

    xdefx macrumors newbie

    Joined:
    Jul 22, 2009
    #8
    Hiya

    Well my other suggestion would be to copy your data from your hard drive onto your windows computer and then format the hard drive and then copy it back.

    If you cannot do that because you don't have enough hard drive space then the problem is beyond my knowledge.

    It might be a bug with the paragon software you have.

    I myself just use parallels with XP so I cannot be of any further help.

    I hope you get it sorted though

    Dan

    ---------
    Or you could try and turn off the paragon software

    I have just been reading and it is recommended that users on v8.0 upgrade to v9.0

    So I think you may need to upgrade from what I have read
     
  9. boch82 macrumors 6502

    Joined:
    Apr 14, 2008
    #9
    In the sharing settings make sure to apply to all sub folders.

    On the Mac if permissions (access settings) are incorrect you can open a drive/folder but it will be empty.
     
  10. kimkg thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #10
    Thanks Boch82

    Sounds like we're getting closer to the problem, I'll check the sharing settings when I get back home.
     
  11. kimkg thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #11
    Hi,

    I'm still unable to see any of the files on the drive and I have full read and write permission for the drive.

    Am I missing something or is there something else I can try.

    Thanks
    Kim
     
  12. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #12
    I think an external drive should be set to 'Ignore Permissions' anyway, but you may check that to make sure it wasn't toggled off.
     
  13. tdotto macrumors member

    Joined:
    Nov 7, 2007
    Location:
    Toronto
    #13
    I am having similar issues. I read somewhere that "With Apple's release of OS X Lion, you can no longer share from your Mac using an external drive if it is formatted with FAT32 or NTFS."

    Is that true?
     
  14. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #14
    When you say share from, do you mean write to...because if that's the case then no...that's not correct for FAT32, because most thumb drives are formatted FAT32 because of the need for them to work on anything you plug them into. I have some new 8GB flash drives that work on my Mac, Windows, and Linux PCs with no issue.
     
  15. kimkg thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #15
    I did manage to solve this and below is the solution if anyone else experiences the same issues.

    1. Remove Paragon NTFS completely

    2. Install - MacFUSE 2.2 Tuxera - http://www.tuxera.com/mac/macfuse/MacFUSE-Tuxera-2.2.dmg

    3. Install - NTFS 3G 2010.5.22 http://download.cnet.com/NTFS-3G/3000-2094_4-10913782.html - When you install this make sure you click customise and remove the option to install MacFUSE as it uses an older version.

    My NTFS drive now works perfectly again, I can read/write and see all the files that disappeared when using Paragon.

    Kim
     
  16. gouac macrumors newbie

    Joined:
    Oct 24, 2011
    #16
    Got the same problem and tried your solution.

    Worked ok, but Macfuse and NTFS 3G is sloooow.
    Slower that Paragon ntfs anyway.


    So I searched for the real cause of this problem.


    Actually when I shared my folders on my mac from this ntfs drive, all files got tagged as "chmod 777" (wich is "file privileges").
    In a way, all your files became fully readable, writable, and EXECUTABLE.
    It F/&% up there identity in a way.

    You don't want that, your files should be "chmod 644"


    So for the solution :

    - Do not remove Paragon NTFS, or re-install it (uninstall MacFuse and NTFS-3G first, those are old discontinued crap)
    - Get : FileXaminer (shareware for 15 days, enough to solve your problem)
    http://www.gideonsoftworks.com/filexaminer.html

    - Launch FileXaminer and right clilc on the app in the dock
    - chose "Batch FileXamine"

    Choose your drive or the folder where your files are.--> ok
    (you can add/remove folder by clicking on +/- in the bottom after that step)

    - on the right pannel chose "privileges"
    - chose "preset" --> "public share"
    (wich is chmod 755 for folders and does a chmod 644 on files)
    - Check "apply to enclosed.."

    - Apply Permissions

    This will revert back your files permissions to their default, functioning, visible state.

    (you can change privileges on files too, you just have to choose a different preset : "public read only")



    If FileXaminer can't see or change your files permissions on the mac where the files are invisible, you must plug your drive on an other mac with paragon installed, there you will see your files, all wrongly showed as EXEC files.

    You can use FileXaminer there.

    Good luck to all those who encountered this problem, I guess there is a lot because having this king of glitch by sharing folders from a ntfs drive on a mac is relatively common.

    Gouac
     

Share This Page