Lion + Firefox + Youtube

Discussion in 'Mac Apps and Mac App Store' started by patrikkoo, Aug 19, 2011.

  1. patrikkoo macrumors newbie

    Joined:
    Aug 19, 2011
    #1
    For some reason, my Firefox did not 'cache' (don't know if i use the right term) the video i load on youtube.

    This happened since i upgraded to Lion.

    This is the screenshot when i tried to load youtube videos with Firefox:

    [​IMG]

    and this is with Safari:

    [​IMG]

    Notice that in Safari, it loads the video and i can freely jump to any part of the loaded part anytime. In Firefox, it doesn't do that.

    I tried moving the cursor backward on Firefox, and it had to 'buffer' (spinning dots appear) the video again (in Safari, it'd be playing the part right a way). I'm pretty sure that this is not an internet speed issue.

    Anyone having this issue? All suggestions are accepted!

    Thanks!
     
  2. Aronnax macrumors regular

    Joined:
    Feb 18, 2008
  3. iphonsteve4ajob macrumors regular

    Joined:
    Aug 6, 2011
    #3
    My issue is similar to yours. I agree Firefox sucks at loading Flash on YouTube. It doesn't seem to buffer far enough ahead to allow me to watch anything above 480P video.

    Chrome works the best. Don't know if this is because Chrome incorporates Flash in the browser itself, but I'm sure they have a better relationship with Adobe than Apple. Or not...who knows, either way it works.

    As for Safari, I'd say it's close to Firefox in flash video buffering on Youtube. However, I recently upgraded my Flash player with a minor update. I'm pretty sure it was probably a security update, nothing to do with our issue of Safari buffering and voila, I am playing 1080P video as well as Chrome. Almost seems to good to be true, but I've been testing it for the last 30 minutes on videos I know NEVER to buffer properly. And now they do!? Fortuitous to say the least.
     

Share This Page