Lion install fail

Discussion in 'Mac OS X Lion (10.7)' started by Mikeoley, Jul 21, 2011.

  1. Mikeoley macrumors newbie

    Joined:
    Jul 21, 2011
    #1
    Ok this has been a nightmare. Going to try and be as thorough as possible.

    I was running the lastest version of snow leopard. Downloaded lion last night to install. Tried to install and got an error saying "mac os x lion couldnt be installed, because the disk is damaged and cant be repaired"

    So i restarted my computer to run the disk utility. I tried first aid on my internal hd, ran verify disk and got several missing thread record errors. It then said the disk needs to be repaired. Problem is the repair disk button is grayed out.

    Figuring I have everything backed up on an external hd from time machine, I thought I would go ahead and erase the drive. Start from scratch. But when I try this I get an Volume Erase Error. Couldn't unmount disk.

    Tried restore, couldn't get anywhere in there.

    Tried rebooting from an install snow leopard 10.6.3 DVD by holding down C and it ignores that and goes right back into Lion install hell.

    Basically that's the vicious cycle where I'm at. I have the first aluminum iMac g5 with a 250gb hd. I have no clue what else to do short off taking it to the genius bar. Any ideas?
     
  2. qCzar macrumors regular

    Joined:
    Feb 27, 2011
    Location:
    SFBA, CA
    #2
    C isn't the correct key. Try holding Option/Alt. And select the OS X Snow Leopard DVD from that screen.

    I remember getting such errors after erasing my Windows XP Partition. Unfortunately, Disk Utility on the SL Install DVD didn't help resolve the errors. I haven't clean installed since removing the partition. So, maybe that has something to do with it.

    Best of luck to you.
     
  3. Mikeoley thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #3
    Thanks for the reply. Holding option didn't work either. It's like this lion installer has totally hi jacked my Mac and there's no way out of this. I've even tried to do a time machine restore. No luck there. Wouldn't let me select my hd.

    I tried quitting the installer which brought me to Choose Statup Disk. When I select my hd it gives me an error of You can't chane the startup disk to the selected disk. Startup disk could jot gather enough info on the selected disk.
     
  4. Comeagain? macrumors 68020

    Comeagain?

    Joined:
    Feb 17, 2011
    Location:
    Spokane, WA
    #4
    did you make sure your Mac can run Lion?

     
  5. Mikeoley thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #5
    Wow that might be the issue. If this is a first gen aluminum intel iMac it may not not be a core 2 duo.

    Unreal. It sucks it won't let me go back to snow leopard though. I mean nothing has installed yet. Guess I'll just have to take it in. Thanks for the heads up.
     

Share This Page