Lion Keeps Asking For Password When Deleting Items?

Discussion in 'Mac OS X Lion (10.7)' started by Bazzy, Dec 17, 2012.

  1. Bazzy macrumors regular

    Joined:
    Jun 8, 2009
    #1
    Hi All,

    Strange thing happened today on my Late 2011 17" UMBP - I was going through some photos in my pictures folder & when selecting & trying delete any of them ( or anything come to that), I get a pop up message which states:

    "Finder wants to make changes. Type your password to allow this."

    It get annoying as hell & I do not know why it just started happening all of a sudden? What is causing it & how can I put things back to normal? My level is that of novice!

    Thank You!
    Bazzy!
     
  2. -Concept- macrumors member

    Joined:
    Dec 11, 2012
    Location:
    In front of a computer. Any computer.
    #2
    Sounds like a permissions error... Assuming you're an administrator on the computer, make sure that the admin usergroup has permission to write to the specified file. If yes, Finder shouldn't prompt you for your password.
     
  3. Bazzy thread starter macrumors regular

    Joined:
    Jun 8, 2009
    #3
    Hi,

    Thanks for the help - it is on an admin account that has never had this issue before! I have also noticed that many folders have an issue where by under "Get Info" panes, my account name is greyed out in the "Name & Extension Box" & under "Sharing & Permissions" there is one called "Fetching"?

    Whenever one tried to delete anything, in addition to Finder asking for more info & authentication, nothing ever ends up in the trash, it just disappears without the usual paper crunching sounds.

    I have tried repairing permissions, relaunching Finder & multiple restarts but to no avail! See below example of my Home Folder "Get Info" Pane:

    Bazzy!
     

    Attached Files:

  4. -Concept-, Dec 18, 2012
    Last edited: Dec 18, 2012

    -Concept- macrumors member

    Joined:
    Dec 11, 2012
    Location:
    In front of a computer. Any computer.
    #4
    Fetching should be wheel.. I have no idea why that may be taking so long, but maybe you accidentally deleted a core list? If so the computer would have problems booting form that drive though. What you can do is hit the plus sign and add 'admin' to the group of people who can read or write to the file. Tell me if that works.

    (Btw, if you want to black out the name of the file, remember that it's at the top of the get info window too, next to the icon)
     
  5. Bazzy thread starter macrumors regular

    Joined:
    Jun 8, 2009
    #5
    Hi,

    Yes, I forgot about the file name nest to the icon in my haste - my apologies!

    I did what you said & sadly no difference - still showing "Fetching" in the "Get Info" pane & same issues with deleting stuff.

    Also, I can change all settings with the padlock locked but if I do click on it, it asks me for authentication.

    Bazzy!
     
  6. -Concept-, Dec 18, 2012
    Last edited: Dec 19, 2012

    -Concept- macrumors member

    Joined:
    Dec 11, 2012
    Location:
    In front of a computer. Any computer.
    #6
    Hmm.. did you make sure to "apply to enclosed items" when adding the admin usergroup as a group that can read/write to the folder? This tells it to apply to all of the folders within that group, might fix your problem.. also, try to boot into the recovery partition and repair the disk and permissions again.. just to be sure.

    Other thing to do would be to repair the user permissions themselves; boot into recovery mode and select the drive and user account, hit 'Reset Home Directory Permissions and ACLs'.

    The last resort would be to create another admin account and see if that one has problems moving files, and if not, copy your files and to that account and delete the first one.

    Other than that, I have no idea. It seems like a common glitch though from what I've read on Apple's forums.

    EDIT* - Fetching should be admin, not wheel. So Finder's having problems loading the admin usergroup permission list... which could be causing your problem. Still try the stuff I wrote above though which should repair the permissions. :)
     

Share This Page