Lion keyboard characters

Discussion in 'Mac OS X Lion (10.7)' started by miknos, Jul 8, 2011.

  1. miknos, Jul 8, 2011
    Last edited: Jul 8, 2011

    miknos macrumors 6502a

    miknos

    Joined:
    Mar 14, 2008
    #1
    I realized something yesterday. While typing I wanted to use a bunch of O's (i.e WooHooooo). I saw a new Lion feature.

    Since english is not my primary language, I'm already used to shortcuts for specific characters. Now it is easier to find harder ones. Just press and hold a key to see a list of options (and press the corresponding number).

    Little details make a great OS :)
     

    Attached Files:

  2. markrox7 macrumors 6502

    Joined:
    Apr 17, 2011
    #2
    Yup, I was excited for this feature too. It's really helpful and useful.
     
  3. illest813 macrumors member

    Joined:
    Oct 5, 2006
    #3
    Do any of you know how to remove this feature? I have been searching the keyboard preferences but can't seem how to remove it...

    Didn't want to make a new thread so figured i'd bump this old one to see if anyone knew the remedy

    Thanks
     
  4. Lazlow macrumors member

    Joined:
    Sep 6, 2007
    #4
    This is literally annoying the crap out of me. I want to be able to hold down a letter and repeat it, for pete's sake! Inserting accents was already easy in OS X; I don't get why they had to make it even easier.

    Someone please let us know if you find a way to disable this stupid thing.
     
  5. illest813 macrumors member

    Joined:
    Oct 5, 2006
    #5
    Bump for info.. suprised noone knows how to disable this feature.
     
  6. miknos thread starter macrumors 6502a

    miknos

    Joined:
    Mar 14, 2008
    #6
    It's faster to type if you already know the shortcuts but makes the life easier for the ones who don't use your computer often.

    More people need to find special characters than people need to write WoooHooooo, yeeeeeeah, LOOOOOL among others. :)

    Should have an option to disable it tough.
     
  7. red-angelz macrumors newbie

    Joined:
    Jul 26, 2011
    Location:
    Jakarta, Indonesia
    #7
    i know this is stupid.. just small things but it annoys me too..

    as for turning off the special character while typing, i found a solutions from googling..

    just type :
    defaults write -g ApplePressAndHoldEnabled -bool false

    in terminal.. it should fix the problem
    although i haven't found the solution to make it 'shorter and faster delay' like in SL :mad:
     
  8. illest813 macrumors member

    Joined:
    Oct 5, 2006
    #8
    just tried copying literally word for word in terminal, but didn't work -- is there something i may be doing wrong?

    appreciate the response
     
  9. Gemütlichkeit macrumors 65816

    Gemütlichkeit

    Joined:
    Nov 17, 2010
    #9
    I'm learning German right now so this instead of Command + U + u to get ü is a little better.

    People that want to type out a scream "aaaah" will just have to hit the keys over and over now. big deal

    or turn it off via the terminal
     
  10. red-angelz macrumors newbie

    Joined:
    Jul 26, 2011
    Location:
    Jakarta, Indonesia
    #10
    really? i have no idea why it doesnt work with you

    i fixed the problem on my 2011 MBP, 2009 iMac and my sister 13" MBP

    and i found another fix for the 'delay repeative keystrokes'

    Go to Universal Access in System Preferences, and TURN OFF "Slow Keys"
    it sould be work perfectly like SL experience.
     
  11. SerrQ macrumors member

    SerrQ

    Joined:
    Jan 10, 2011
    Location:
    Iceland, Reykjavík
    #11
    Really useful feature but can be annoying when you're trying to write wooohoo like you said.

    I still love it because I'm learning danish and german.. Now I can do letters like ø å ü easily! loving it
     
  12. red-angelz macrumors newbie

    Joined:
    Jul 26, 2011
    Location:
    Jakarta, Indonesia
    #12
    yes.. i agreed it will be very helpful for lots of people but not everyone. i think apple should put this in a feature and an easy on-off feature.

    terminal language isn't easy for some people too :(
     
  13. handel30 macrumors member

    Joined:
    Jul 25, 2011
    Location:
    Miami, Florida
    #13
    Those who want to write woooohooo can go back to kindergarten. Anyhow, you can still do it by pressing the key the normal way. Thanks for bringing such a great feature to my attention. It's great for those of us who are learning or who write in a foreign language. I write in Spanish and German, and it's great how easily I can type an ü or ñ with this great feature. Shortcuts everywhere! I love Lion.
     
  14. kgreger macrumors newbie

    Joined:
    Dec 8, 2011
    #14
    Problem activating this feature

    Not sure what's wrong on my system, but I can't seem to make the popup window come up!? I tried the aforementioned terminal command, both using "false" (apparently to disable the feature) and "true" (hopefully to enable it?) as flags, but to no success...

    Anybody experiencing the same or have any hints on how to explicitly enable this feature?

    <rant>While it doesn't belong to a rather technical thread, I agree that the usefulness of this feature by far outweighs the possibility of being annoyed by not being able to type childish stuff as shown in the aforementioned examples. No character needs to be typed more than twice in a row in any language (including Finnish, to my best knowledge!), and in the end this can prevent you from "typing" hundreds of pages of "bbb"s after falling asleep on the keyboard. </rant>
     
  15. catroom, Dec 9, 2011
    Last edited: Dec 9, 2011

    catroom macrumors newbie

    Joined:
    Nov 28, 2007
    #15
    Accented characters

    Note: This feature only works if the Input Source is changed to one of the ‘major’ keyboards like, US, Australian, British. For example, I use the app, Spell Catcher, which operates via an input source, but when the input source is set to SpellCatcher, the accent picker doesn’t work.

    Accent Picker Settings

    In the Keyboard pane in System Preferences:

    Key Repeat -- In the Off position NEITHER the accent picker nor key repeat work. Set to reasonably fast

    Delay Until Repeat -- With Lion this setting is equivalent to the old setting for ‘Delay until repeat’ but you are essentially now setting a delay until the accent picker shows. I have this set to short.

    To disable the accent picker, in Terminal Type:

    defaults write -g ApplePressAndHoldEnabled -bool false

    Change that to true to re-enable the setting. Each time a restart is needed for the change to take effect.
     
  16. kgreger macrumors newbie

    Joined:
    Dec 8, 2011
    #16
    catroom, thank you very much for your quick reply and for pointing that out!

    So apparently Apple is also one of those "global" companies that are still betting all their money on English being the most important language in the world... Sad but true, this useful feature seems only to be available to people using on of the keyboard settings you mentioned. Sure, why would anyone from another country want to type a special character...? :mad:
     

Share This Page