Lion login failing

Discussion in 'Mac OS X Lion (10.7)' started by binarymelon, Aug 10, 2011.

  1. binarymelon macrumors member

    Joined:
    Jul 27, 2007
    #1
    I'm hitting an issue where my login attempts just kick me back to the login screen after attempting to load my desktop. Another user works fine, but this one user repeatedly fails to login. Something possibly related is that immediately before I started hitting this issue the Mac crashed while logged into the account. I'm assuming there's some corrupt data to do with the window restore that is causing the issue, but that's just a stab in the dark. Any help would be appreciated.
     
  2. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #2
    Perhaps delete the Application State data for the finder. Not sure if that will help.
    ~/Library/Saved Application State/


    http://osxdaily.com/2011/07/17/dele...-saved-states-from-mac-os-x-10-7-lion-resume/
     
  3. binarymelon thread starter macrumors member

    Joined:
    Jul 27, 2007
  4. binarymelon thread starter macrumors member

    Joined:
    Jul 27, 2007
    #4
    I seem to have got it working. Found an old thread in the apple support forums that suggested holding down shift during restart to disable extensions(?) and login items. This got me in and I cleaned up some non-existent login items (no idea if this actually did anything because they weren't causing issues before) and on the next restart everything seemed to be working again.
     
  5. remerolle macrumors newbie

    Joined:
    Jun 9, 2009
    #5
    I am having the same problem.

    I have done several clean installs.

    The shift to "safe mode" work around does not let me login either. I just keep getting kicked back to login in a few seconds before the desktop can even load.
     

Share This Page