Lion Mail not syncing gmail inbox

Discussion in 'Mac Apps and Mac App Store' started by QCassidy352, Oct 24, 2011.

  1. QCassidy352 macrumors G3

    QCassidy352

    Joined:
    Mar 20, 2003
    Location:
    Bay Area
    #1
    I've searched but can't find this exact problem. I have OS X Mail (Lion) for a gmail account and an iCloud account. The latter works perfectly.

    For the gmail, I am using all of google's recommended settings, and it works great, except that if I archive or delete items out of the Mail inbox, those changes are not reflected in the gmail web interface or iOS mail app. Any change to any other folder updates properly, and if I make a change to the inbox on the web or on my iPhone, that change does show up in the Mail inbox. It's just changes to the Mail inbox not showing up elsewhere.

    Any help much appreciated!
     
  2. QCassidy352 thread starter macrumors G3

    QCassidy352

    Joined:
    Mar 20, 2003
    Location:
    Bay Area
    #2
    So nobody else has this problem? It's just me? I don't understand what's going on at all. Everything else syncs just fine. I even tried deleting the account and re-adding it.

    Any help greatly appreciated.
     
  3. waynep macrumors 6502

    Joined:
    Dec 31, 2009
    #3
  4. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #4
    If you're using POP for Gmail in Mail then, no, it doesn't sync & you have to manually delete the mail from the Gmail web interface. If you set up Gmail as IMAP in Mail it will sync. I find I only need to go to the Gmail web interface to delete items in the Spam folder.
     
  5. QCassidy352, Nov 17, 2011
    Last edited: Nov 17, 2011

    QCassidy352 thread starter macrumors G3

    QCassidy352

    Joined:
    Mar 20, 2003
    Location:
    Bay Area
    #5
    Thanks. I'll try it and see, but I had it working fine under snow leopard, so I don't know what changed.

    Edit: those are pre-lion instructions. Don't have those options in lion anymore. :(

    Thanks. It's IMAP.
     
  6. QCassidy352 thread starter macrumors G3

    QCassidy352

    Joined:
    Mar 20, 2003
    Location:
    Bay Area
    #6
    In case anyone else runs into this -- finally figured it out. There's a setting in the gmail web interface under Forwarding and POP/IMAP. Auto-expunge has to be *on.* Dunno how it got turned off, but that's the answer.
     

Share This Page