Lion Mail On Snow Leopard

Discussion in 'iMac' started by DisneyRicky, Aug 25, 2011.

  1. DisneyRicky macrumors regular

    DisneyRicky

    Joined:
    Jun 5, 2010
    Location:
    Northern California
    #1
    Hello Everyone,

    I was wondering if anyone knew if I took the Mail.app from my MBP running Lion, and put it on my iMac running Snow Leopard. My iMac has the correct specifications to run Lion, but keeps getting an error telling my some files cannot be downloaded when I try to run the update (any ideas on that? [It's an iMac from 2008]).

    Besides all the background changes with Lion, I am really starting to like the design of the Mail program updates involved it in. So I was wondering if I went to finder, copied it to a flash drive, then replaced my mail program I have on the Snow Leopard computer, would it corrupt the program? Or would it just look the same as what I already have?

    Thanks,
    DisneyRicky
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    Lion's Mail will not work on Snow Leopard. Snow Leopard doesn't have the necessary frameworks and program calls to allow it to run.
     
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #3
    Mail could be depending on new calls only present in Lion. It might or might not work. I wouldn't take a chance just for some visual stuff. edit...looks like Intell beat me to it.
     
  4. DisneyRicky thread starter macrumors regular

    DisneyRicky

    Joined:
    Jun 5, 2010
    Location:
    Northern California
    #4
    Okay, so, any ideas why "The necessary files can not be downloaded?"
     
  5. reclusive46 macrumors 65816

    reclusive46

    Joined:
    Apr 14, 2011
    Location:
    Canada
    #5
    The framework can't really be changed. Its not a matter of simple files.
     

Share This Page