Lion mail server and iPhone/iPad on same LAN

Discussion in 'Mac OS X Server, Xserve, and Networking' started by einarso, Apr 3, 2012.

  1. einarso, Apr 3, 2012
    Last edited: Apr 6, 2012

    einarso macrumors newbie

    Joined:
    Nov 6, 2011
    Location:
    Norway
    #1
    Hi,
    I am struggling here - I have set up mail for my main domain. Webmail works, I have managed to set up my account on my MacBook Pro, but I get an error message when I try to set up the account on iPad and iPhone. I also tried to set the mail account up in Outlook, but that didn't work either. So I removed the account from my Mac and tried installing again and it went smoothly!

    My set up. I am using Lion Server, and I have installed the server using example.com. I have external DNS hosting, and DNS has the following setup:
    example.com - MX - mail.example.com
    mail.example.com - A - <my IP address>

    In the server admin app, I have my server running with Mail and DNS services running. Under the general tab in Mail I have example.com as Domain name and mail.example.com as Host name.

    When I set up the account on my mac, I only used example.com when asked for smtp- and incomming mail server (not mail.example.com). I got a warning regarding my SSL as I am just using the self signed certificate. This made me think that the problem was with the use of SSL. So I tried to disable SSL on my server, but still was not able to set up my e-mail on my iOS devices.

    Does anyone have any tips on what I might be doing wrong or how I can make use of my Lion Mail server?
     
  2. einarso thread starter macrumors newbie

    Joined:
    Nov 6, 2011
    Location:
    Norway
    #2
    I can´t belive that no one here is running a Mail server on Lion server that is accessable with imap using iOS devices! Is mail server on Lion really that bad?
     
  3. Gnuff macrumors newbie

    Gnuff

    Joined:
    May 26, 2008
    Location:
    Norway
    #3
    I have a lion mail server running successfully and I'm very happy with it. One question though, did you set up your server with the example.com address. Or are you just using it here in place of your real address?
     
  4. einarso thread starter macrumors newbie

    Joined:
    Nov 6, 2011
    Location:
    Norway
    #4
    Hi - really appriciate your answer! I am just using "example.com" as an example. Everywhere I write example.com I am really just using my own domain. I see people usually doing this - maybe to prevent people from using forums like this for hidden advertising of their website? :p

    I too am mostly happy with the mail server - if only I could access it with imap on my iPhone and iPad. I find it confusing that I can set up an imap account on my macbook pro, but not on my iOS devices using the same imap information. Made me think my problem was the certificates since my mac allows me to trust the selfsigned certificate, while the iOS devices do not give me that opition.

    Are you using a certificate for your imap and smtp services? If so - have you purchased a certificate, or are you using the default self-signed certificate?

    Again - thank you for your reply!
     
  5. Gnuff, Apr 6, 2012
    Last edited: Apr 6, 2012

    Gnuff macrumors newbie

    Gnuff

    Joined:
    May 26, 2008
    Location:
    Norway
    #5
    Ok, thats good then.
    Are you able to connect to your server in other ways through your domain? i.e if you enable the webserver? Just so you know that the dns is set up in the correct way.

    Also, I use a purchased certificate, but when I set it up I used a self signed one, so that shouldn't be the problem. One problem I did run into though, is that I "required" users to use SSL on STMP and IMAP, and thats a problem as many clients etc don't support that. You can choose between the different settings witch are "Don't use" - "Use" and "Require". I have it set at "Use".

    Btw, do you have server admin installed? Not just Server.app, if you don't it's a good idea to download it to be able to do some detailed configuration. Server Admin download

    When you go into mail settings and under the "advanced"-tab and then security, there is authentication options, you should have CRAM-MD5 enabled for both SMTP and IMAP to connect in the default way with your Open Directory account.

    And are you able to recive email on your server from other emailservices?
     
  6. einarso thread starter macrumors newbie

    Joined:
    Nov 6, 2011
    Location:
    Norway
    #6
    Thank you - beeing able to communicate about my problem really has helped me. My first mistake was that I had the certificates on "require". My second - and this I really should hav thought of myself (but didn´t think of it before you had helped me eliminating other alternative faults) - I was trying to set up the accounts while beeing on the same network as my server. When I marked the certificates to "use" and switched wifi off my iPhone I was able to set up the account on my iPhone. I did not have this problem on my mac because there I had edited my hosts.ini file :)

    I can´t edit any hosts files on my iOS devices, so now I wonder - does this simply mean that I am not able to access e-mail on my iOS devices while beeing connected to the same router/network as my server?
     
  7. Gnuff macrumors newbie

    Gnuff

    Joined:
    May 26, 2008
    Location:
    Norway
    #7
    It's my pleasure, happy to help out. Despite all the hate Lion Server is getting around the community, I'm pretty happy with it, and it fits my needs. So I'm just happy someone else gets to benefit from it as well.

    Did you change it over to "use" _and_ switch of wifi before you tried again? Because I use all of my stuff on the same local network all the time, and I don't have anny problems.

    If you turn on wifi now and check for new emails, are you able to recive? As long as you point to your domain in the account settings to your iOS-device, it shouldn't matter if you're on the same local network as the server or not.

    btw, on a side note. If you go into Server.app then under "Hardware", select your server machine, choose the "settings"-tab, you can enable Apple push notification. And you'll get push to iOS that actually works without having to be exchange. But you might already know this for all I know.
     
  8. einarso thread starter macrumors newbie

    Joined:
    Nov 6, 2011
    Location:
    Norway
    #8
    Hi again,
    e-mail works as a charm, except as soon as I turn on my wirless, I do get a message informing me that the server doesn´t respond :mad:

    As soon as I turn my wifi off, it works again.

    ...not startet thinking about push - but happy to see it is that simple :)
     
  9. Gnuff macrumors newbie

    Gnuff

    Joined:
    May 26, 2008
    Location:
    Norway
    #9
    Do you use your server for DHCP as well, or do you use a router for that?
     
  10. einarso thread starter macrumors newbie

    Joined:
    Nov 6, 2011
    Location:
    Norway
    #10
    I use a router that I have limited access to for DHCP. I see you are from Norway - it is from Altibox.
     
  11. Gnuff macrumors newbie

    Gnuff

    Joined:
    May 26, 2008
    Location:
    Norway
    #11
    Guess thats not the problem then.

    Could you possibly post a screen of the "Zones" pan under DNS in Server Admin?
     
  12. einarso, Apr 6, 2012
    Last edited: Apr 7, 2012

    einarso thread starter macrumors newbie

    Joined:
    Nov 6, 2011
    Location:
    Norway
    #12
    Here is a screenshot of zones... I have not done anything here. It is just the default settings after setting up the server.

    If it helps, when I am on my LAN and I try to access one of my domains via http - I just get a login-window for the router. I have edited the hosts-file on all pc´s, but that is something I am not able to do with the iOS devices. Perhaps you have som dns/routing options on your router that tells the router how to handle internal traffic? (just taking a wild guess here - brainstorming :p )
     
  13. Gnuff macrumors newbie

    Gnuff

    Joined:
    May 26, 2008
    Location:
    Norway
    #13
    Your zones look fine to me, so I think I'm at the end of my knowledge I think. Not really sure why are you are getting these strange problems locally. Maby it's a quirk with how Altibox handles the network. Is it possible to put the altiboxrouter in a bridgemode and to use another one instead?

    I use the Airport Extreme, Server.app can autoconfigure NAT for all your services automatically.

    And why do you have do manually edit all your computers host files? I've not had any need to do that.

    As far as I know, you should be fine if you've configured your DNS-forwarding correctly, and forwarded ports: 25,110,143,587,993,995 for email, and 80,443 for web services to your server. Thats all the ports you need to run your services normally and with SSL.

    If nothing of this work, I'm afraid there's not much more I can help with I guess. If no ones else here can contribute to this issue, you could allways post a question on Apple Communities Lots of people there with really deep technical knowledge. Good luck.
     
  14. einarso thread starter macrumors newbie

    Joined:
    Nov 6, 2011
    Location:
    Norway
    #14
    The router is in DMZ-mode so as we speak all ports are forwarded to the server. Since you do not have to change your hosts.ini files, I guess the difference between our setups is how the router handles internal traffic. But at least the e-mail problem is solved - just have to find a way to rout my internal traffic to my server instead of try to sign in to my router.

    Thank you for your help and input :)
     
  15. etchtech09 macrumors member

    Joined:
    Jun 25, 2010
    #15
    Check out Split-Horizon DNS, wikipedia has a good article on it.

    Basically what needs to happen is that your DNS server needs to tell the devices that are internal to the network that the IP address is your private address (ie 192.168.1.2 or whatever the private IP to your Lion Server is) and return your public IP to external traffic.

    This setup requires that you do the CLI for your DNS server and that you won't be able to use the GUI interface anymore, it also isn't a recommended setup.
     
  16. einarso thread starter macrumors newbie

    Joined:
    Nov 6, 2011
    Location:
    Norway
    #16
    I have been in contact with my ISP and the simplest way to solve this is to set their router to bridge mode and buy and use a private router for my LAN.
     

Share This Page