Lion: Major issues with VMWARE, Disk Space, Shut Down, etc

Discussion in 'Mac OS X Lion (10.7)' started by mikefla, Feb 27, 2011.

  1. mikefla, Feb 27, 2011
    Last edited: Feb 28, 2011

    mikefla macrumors 6502

    Feb 27, 2011
    Thought I'd share the issues I have experienced so far with Lion.

    1.) When I shutdown the computer if I uncheck the option "Reopen windows when logging back in" the computer takes a very long time to shutdown and simply reboots instead of shutting down. I can reproduce this behavior all the time. I have also experienced several times a severe error during shutdown where I get the black screen with a message in various languages (this only happened I believe whenever I did not have the mentioned option checked during shutdown).

    2.) Prior to installing Lion I had over 250GB free which included a 100GB+ VMWARE virtual machine. I have removed the 100GB+ virtual machine and I now still have less than 100GB free. I cannot account for over 200GB of free space that I should have. I have even download an application that interprets hard disk space and I cannot figure out what has happened to all the space. I also notice when I delete something that is over a GB in size and then look at disk space available, the available disk space is not accounting for the extra space that I just freed up.

    3.) After installing Lion I could no longer open either of my two vmware fusion virtual machines. I ended up damaging one virtual machine trying to get it working so I just deleted it. My other virtual machine works but there appears to be serious issues with Lion and vmware fusion. For example if I shutdown my computer, turn it back on and open vmware and then open my vm, it will take about 15 minutes or longer for the virtual machine to resume from suspend! During this process the hour glass shows constantly under the virtual machine but I am able to run other applications on the MAC fine while I wait. Also as soon as I start to load the vm I notice a ton of free space disappears from the hard drive (like 40GB+). The size of my vm is 40 GB and the size of the actual folder that holds the vm is around 45GB. Once the vm successfully loads (after the huge delay) the space taken returns to the drive. If I don't shutdown the computer but simply put it to sleep I am able to resume the vm very quickly or normally. Actually I just noticed that if I close the VMWARE application and then later open it again (without shutting down or rebooting the computer) I also experience the long delay in resuming my VM.

    Just noticed another VMWARE issue, if my VM is open but left unused for some time and I return to use it, I get the hour glass and it becomes non-response and un-useable and eventually it just suspends itself and gives me this error "Cannot find a valid peer process to connect to". Now when I click "ok" on the error I then get "Internal error, an uncaught exception was raised" and usually I click on crash and send in the report. Now I have to manually kill the "vmware-vmx" process" and then I can open vmware again and startup the vm. Eventually the vm loads but acts as if windows was not properly shutdown, I select to start normally and the vm is fine again. I never had any issue with my vm's under Leopard and they always loaded very quickly.

    4.) I use gmail. For some reason the new version of Safari in Lion keeps disconnecting me constantly from Safari. I have to keep login constantly.

    5.) In FireFox the Sling Player plugin no longer works. I believe this has to do with the sling media web site that somehow detects the OS being used and then just refuses to load the plugin. The good thing is that I still have the old Sling Player application and surprisingly it works fine with the Lion.

    My machine specs: 8GB RAM, 2.66 i7, 500GB 7200RPM 32MB CACHE 4GB Solid State Memory Seagate Hard Drive, 64 Bit Kernel (always running 64 bit even before Lion install). I upgraded to Lion from Leopard 10.6.7 Build 10J860 64 Bit Kernel.

  2. lucas300 macrumors newbie

    Feb 28, 2011
    disc space

    I do have the same problem and noticed the space on the disc is not regulated as normal - even if you trash or remove files. However - I did reinstalled Lion today the second time and now I do have the actual size of the disc like it should be but still the same problem occurs when dealing with large files.
  3. mikefla thread starter macrumors 6502

    Feb 27, 2011
    I have resolved some of my issues already. I am going to post an update later. But as far as the disk space it has to do with Time Machine. Even though I don't use it and had it turned off it was constantly creating local snapshots looks like. Simply go to System Preferences > Time Machine > Options and remove the check from "Create local snapshots" and right after that you should see your missing free space show up. Another user on the forum mentioned this so credit goes to him. I'm just sharing.

  4. Michaelgtrusa macrumors 604

    Oct 13, 2008
    What about just creating a second partition on you're hd an installing lion to it?
  5. Nobita macrumors 6502

    Oct 5, 2008
    La la land
    Can I ask one unrelated question? Is cmd-tab still works? What about cmd-tab when you don't enable dock lights on?
  6. mikefla thread starter macrumors 6502

    Feb 27, 2011
    cmd-tab works as far as switching between running apps. Not sure what you mean by "dock lights on".

  7. Nobita macrumors 6502

    Oct 5, 2008
    La la land
    Thanks for the answer! If you notice the dock lights that were used to indicate that the app is running is present by default in Snow Leopard, and in Lion it's off by default? When it's disabled, does cmd-tab work?

    Thank you so much!
  8. lucas300 macrumors newbie

    Feb 28, 2011
    That works perfect Mike - thanks for that idea! it was really getting on my nerves
  9. timothy632 macrumors member

    Feb 17, 2009
    thank you

    thank you so much for the help. That was driving me crazy. I have a 320gb hd and i woke up this morning and it was down to 120gb. This fixed the problem.
  10. metrica macrumors newbie

    Feb 4, 2010
    Similar problem, some difference with VM

    Got similar problems.

    - The extra space was taken by a hidden folder ".mobileBackup". I actually manage to delete it manually and the recovered the space (over 100G) -- of course, I also turned off the Time Machine local snapshot.

    - My VMware Fusion behaved very strangely. I cannot open my previous virtual machines stored on my local drive, but I can start them when they are copied to a USB external hard disk. I have tried to install a new virtual machine. The installation was successful but when I tried to load some software it crashed and damaged. So far it seems launching VMs from external hard disk is the only stable solution to me.
  11. tbisaacs macrumors newbie

    Mar 1, 2011
  12. metrica macrumors newbie

    Feb 4, 2010
    In the Terminal, type

    defaults write AppleShowAllFiles -bool true

    Then restart the Finder and you will see it at the root of your hard disc.
  13. simonshek macrumors member

    Jun 15, 2009
    It takes forever to shut down the computer. :|
  14. Shorties macrumors 6502a

    Jul 22, 2007
    Southern California
    What does that do? Will I lose that really cool feature that allows you to see the previous page when you two finger right scroll?
  15. mikefla thread starter macrumors 6502

    Feb 27, 2011

    My VM's are now working fine and so is VMWARE! Seems the issue had to do with a heavily fragmented hard drive after I disabled the Time Machine local snapshots. Once I got all my free space back I defragmented my hard drive using iDefrag (just a quick on-line defrag) which took a long time to run. After that all was back to normal with VMWARE, no more issues at all.

    I still have issues with Safari, it keeps kicking me out of various sites and I have to keep logging back on. Like Gmail, this forum, etc. The "logmein" plugin which I use allot does not work with this new version of Safari. I did not try to install it again. But it does work with FireFox so i'm just using it there. The "sling player" plugin no longer works with FireFox so i'm just using the Sling Player software on the Mac and that still works fine.

    Seems to be working a little better now. I can now shutdown quickly and properly even if I uncheck the new shutdown option "Reopen windows when logging back in". So far i'm not having any issues but need to test a little more.

  16. dejo Moderator


    Staff Member

    Sep 2, 2004
    The Centennial State
  17. font9a macrumors newbie

    May 31, 2008
    I had some trouble, too after I deleted Parallels and the associated virtual machines. I lost about 100 GiB space — and it was also due to Time Machine. However, I was able to reclaim all the missing space by simply turning Time Machine *off*.

    I suspect things will get a little smoother once July rolls around.
  18. tommasomac macrumors newbie

    Jul 1, 2008
    Hi, are you sure that slingplayer application work on Lion? That would be great, but here it doens't seem so…
    what slingplayer version are you using, and what slingbox?
  19. MacBookPro13" macrumors 6502a


    Jan 25, 2011
    Mine takes a good 20 seconds to shut down where it was almost instant on SL.
  20. crcc23 macrumors newbie

    Jul 22, 2011
    Create local Snapshots dosnt exist for me!

    Im having the same free space problem but I can't even see the "Create Local Snapthots" option in my preference pane.

    Is not there!

    System Preferences > Time Machine > Options and remove the check from "Create local snapshots"
  21. parish macrumors 65816


    Apr 14, 2009
    Wilts., UK
    Thanks for the headsup.

    I found (by accident) .mobileBackup but on mine it is reported as the same size as my HDD - 160GB - yet Finder shows the correct amount of free space :confused: :confused:

    I do use TM but i'm not sure about the local snapshot setting, I'll check tonight.
  22. Dr Tom Servo macrumors newbie

    Mar 19, 2013
    Is this dead?

    I have been having this same disk space, slow computer trouble as well. There are no pictures, music or videos taking up space. I am running Lion with Fusion 4. This may not be the same issues since i bought the computer with this iOS and didn't load it. I looked in the time machine options and i didn't see the check box that has been described. Any help would be appreciated.

Share This Page