Lion mouse pointer jumps

Discussion in 'iMac' started by orionlogic, Jul 20, 2011.

  1. orionlogic macrumors newbie

    Nov 4, 2007
    Here fresh install of Lion, my mouse pointer jumps to the location when i move the mouse harshly. Like sudden move and stop it jumps to the direction.

    Could not find this in system preferences any idea?
  2. piddonkadonk macrumors newbie


    Jul 20, 2011
    Boulder, CO
    same thing

    Having same issue. Using external Samsung monitor as my second screen w/ wireless Magic Mouse. My mouse pointer is jumping across to the opposite screen it seems.
  3. go.mouse macrumors newbie

    Aug 10, 2007
    Vancouver, BC
  4. TimmyDee macrumors member

    Feb 20, 2007
    Same here. I thought it was my mouse pad, but I wasn't having problems before the upgrade. Hopefully this gets fixed soon.
  5. Jawcl, Jul 21, 2011
    Last edited by a moderator: Jul 21, 2011

    Jawcl macrumors newbie

    Mar 22, 2011
    I'm glad to hear that others are having this issue and it wasn't just me. I'm using an Acer P216HV and am experiencing the exact same thing. I thought that there may be some interference so I turned off WiFi and did a bunch of other stuff to no avail.

    Does anyone have a solution? Its getting rather annoying.
  6. Zeiss macrumors member

    Dec 18, 2006
    yeah, did my head in at first, but i think it is a feature, not a bug.... On my 30" screen, if I am at the bottom right, and move the mouse like a 'gesture' it jumps to the top left... But I would turn it off if I knew how. Must really suck on duel screen setup.
  7. bumzo1 macrumors 6502a

    Jan 31, 2009
    Dallas, TX
    I have the same setup and its also jumping :/
  8. chrono1081 macrumors 604


    Jan 26, 2008
    Isla Nublar
    Oh geeze I used to have this in Snow Leopard when it first came out and it made selecting vertices in Maya a horrendous experience.

    Make sure to go to and mention it. I mentioned it a bunch of time (and so must have others because it was fixed in Snow Leopard).

    I haven't noticed it in Lion yet.
  9. cocky jeremy macrumors 601

    cocky jeremy

    Jul 12, 2008
    Columbus, OH
    I'm not having problems with my cursor, but i am having problems with having to click things multiple times to get it to work.
  10. Kevenly macrumors regular


    Nov 22, 2008
    The wrong planet.
    I thought this was my mouse! Glad to hear it's in the system. My mouse pointer seems to randomly disappear and appear on the other side of the screen with no rhyme or reason or repeatability so far.

    I also have the Targus Bluetooth Mouse for Mac which has sort of a small round touch pad in the middle, and it has always worked perfectly. Now with Lion on certain screens like Launchpad, it doesn't matter if I swipe left or right it always goes to the right. But in the regular finder it responds appropriately to the direction I swipe.
  11. ycwee37 macrumors member

    Oct 4, 2010
    i have the same problem as well!!
    and thencomp freezed for the first tim just now and i have to forcefully shut it down....
  12. KyleGP macrumors member

    May 3, 2011
    Same. No cursor problems though.

    I think the having to click things multiple times is because Lion is sluggish.
  13. Bassdust macrumors newbie

    Mar 21, 2008
    Me too!

    Same issue, as above looks like it is jumping to my randomly second monitor plugged into my iMac.

    I have noticed a couple of other "glitches" re second monitor.

    Including but not limited to: one particular desktop background image went spaz, but only when in tile mode!
  14. keysersoze macrumors 68000


    Jan 6, 2004

    Same here.

    10.7.1 come soon!
  15. cocky jeremy macrumors 601

    cocky jeremy

    Jul 12, 2008
    Columbus, OH
    I don't think that's the issue. Not for me, at least. Lion seems to run much smoother than Leopard/Snow Leopard did for me. Uses a lot less RAM now too. Safari used to routinely hit 600 MB or more, now it rarely hits 200 MB on Lion.. and that's after longer usage than what got me to 600 MB on Snow Leopard.
  16. apfhex macrumors 68030


    Aug 8, 2006
    Northern California
    Same here with Magic mouse and upgrade from Snow Leopard. Never anything like this before Lion. I thought it was BTT or a bluetooth issue but I guess it's really a bug. REALLY annoying if you like to use hotcorners, keep activating them accidentally. :(
  17. CWallace macrumors 603


    Aug 17, 2007
    Seattle, WA
    Ditto with my Magic Mouse. It often flies off to my second monitor (which I normally leave off) so I have to make large sweeps to bring it back into view.
  18. Roy G Biv macrumors 6502

    Roy G Biv

    Dec 26, 2010
    No problem here. If this were OSX Elephant, the screen would be jumping.
  19. bumzo1 macrumors 6502a

    Jan 31, 2009
    Dallas, TX
    ugh its still doing it, this is the most annoying bug I've encountered in Lion. 10.7.1 PLEASE COME SOON!
  20. onthecouchagain macrumors 604


    Mar 29, 2011
    Has anyone also experienced when waking up from sleep, the mouse doesn't adjust to the user's settings right away; meaning the track speed, scroll speed, etc.? It takes a good, I don't know, 20 seconds before the mouse finally adopts the preferred speed. It's a bit frustrating.

    However, I am not experiencing the random mouse cursor jumping issue. Hm.
  21. Spanky O'Toole macrumors newbie

    Jul 28, 2011
    Update / Possible Work Around?

    After getting frustrated this morning I tried a few things. For those of you who don't use Mission Control, I went in and turned off the three "check mark boxes" at the top. I haven't had the mouse jump since. I didn't try one choice at at time to try to narrow it down.

    Hopefully this helps others or maybe points to a solution. It was driving me nuts in InDesign CS5.5 and Photoshop. My settings for MC are attached (I hope)...

    I'll keep you posted if it starts getting eratic again.

    Attached Files:

  22. CWallace macrumors 603


    Aug 17, 2007
    Seattle, WA
    Unchecking all three boxes seems to have fixed it for me.

    Thank you.
  23. Ian James macrumors newbie

    Jan 15, 2012
    Thank you

    That also did the trick for me, thank you so much, it was driving me bonkers !
  24. flyxwire macrumors newbie

    Aug 3, 2008
    Cursor jumps around Lion 10.7.2 - AppleCare Fix!

    About a week ago my cursor started going nuts jumping around all over. Made no difference if I used magic mouse, external trackpad or laptop track pad.

    Troubleshooting took some time but solution was fast.

    The Tech Specialist had me create another user account. When I went to that account, everything worked normally.

    ROOT CAUSE: Some program had altered a preference setting and culprit was somewhere in preferences list folder.


    1) Open Finder
    2) Make folder on Desktop called OLD PREFERENCES
    3) On finder click GO
    4) hold option key and LIBRARY will appear
    6) Click CMD-A and move all files to "Old Preferences" folder on desktop
    7) Reboot and Clear PRAM -
    How to do that: Turn on your Mac and hold down the Command, Option,
    P, and R keys all at the same time (all four keys). Keep holding down all
    four keys until you hear the startup sound for a second time.
    8) Start normally - Log in
    9) Problem should be gone.

    You will need to set your preferences all over again for each program OR if you understand what you are doing, you can take the preferences for whatever program from OLD Preference folder on desktop and place them back in preferences folder in Library.

    Be forewarned, doing that may bring problem back if that set of preferences was the cause of problem in first place.

    It worked for me and machine is running much faster and flawlessly.

    Re-installing LION was not recommended as it "lays" a new copy of Lion over old one. A re-install does not touch your preferences, so the problem will still exist unless you wiped your drive clean.

    Hope this helps those that were as frustrated as I was.

  25. theanimaster macrumors 6502


    Oct 7, 2005
    Automatic Graphic Switching

    I was getting the same thing... but only for a short time, then it sorted itself out. Could this be related to automatic graphic switching (from the intel graphics to the dedicated graphics) I wonder?

Share This Page