LION on MBP 13" - Volume greyed out.

RWil85

macrumors 6502a
Original poster
Aug 2, 2010
560
130
I installed Lion on my 13" MBP yesterday - all seems to have gone well..

except for the fact that, upon a reset or shutdown/startup, the volume hardware buttons will not work..they will flash the command on the screen, but will not truly function..also, the volume icon in the top bar is greyed out.

i saw a workaround in another thread - plugging in headphones and pulling them out - that actually worked; however, i do not want to have to do that every time.

has anyone else come across this/found a fix?

thanks for the help!
 

ourfoz

macrumors newbie
Jul 21, 2011
2
0
I've got the same problem and currently using the headphone in - out as a fix. Mine was a fresh install, not an upgrade. I doubt we're alone.
 

ourfoz

macrumors newbie
Jul 21, 2011
2
0
Go into disk utility, verify disk permissions then repair disk permissions. It fixed my problem.
 

LAS.mac

macrumors 6502
May 6, 2009
363
0
Mexico
well, you aren't actually alone. I got the same problem. I'll try the headphones trick, and repair permissions as well.
 

aasaeedi

macrumors newbie
Jul 16, 2010
8
0
I have the same problem. Updated from snow leopard to lion two days ago. Fixing the permissions didn't help me.

Once I booted into the safe mode and restarted my computer. It fixed the problem for a while. I booted into the safe mode once again and the issue came back when I restarted my MBP. Now the safe mode trick doesn't help anymore.
 

LAS.mac

macrumors 6502
May 6, 2009
363
0
Mexico
using an external headphone made the trick for me.
Quite annoying, though. Anyway, let's patiently wait for the first update, 10.7.1...
 

RWil85

macrumors 6502a
Original poster
Aug 2, 2010
560
130
using an external headphone made the trick for me.
Quite annoying, though. Anyway, let's patiently wait for the first update, 10.7.1...
Seemingly, it must be a bug if users who have installed using different methods are experiencing the same problem..hopefully, it'll be fixed in a future build.
 

John Wilkie

macrumors newbie
Sep 17, 2011
2
0
Fix

There is a wee latch at the back of the port that flips it from analogue to digital. If you look in and see red it is stuck on digital. Ramming a mini jack or mini tos-link in and out usually frees it.
 

Cougarcat

macrumors 604
Sep 19, 2003
7,766
2,551
A mod should sticky this thread, as this bug gets posted here frequently

Attached is the best workaround I've found (kudos to whoever posted it before, sorry I don't remember who you are). It's an Applescript that will restart CoreAudio. Just install it in Login Items.

Anyone with 10.7.2 installed know if Apple fixed it yet?
 

Attachments

dsciel

macrumors regular
Jul 13, 2011
148
0
A mod should sticky this thread, as this bug gets posted here frequently

Attached is the best workaround I've found (kudos to whoever posted it before, sorry I don't remember who you are). It's an Applescript that will restart CoreAudio. Just install it in Login Items.

Anyone with 10.7.2 installed know if Apple fixed it yet?
I have downgraded back to SL because of this problem.....the headphone trick does work but it is annoying that you have to do it everytime after restart.....
 

Similar threads

  • CharCat
1
Replies
1
Views
128
  • wisevot1900
8
Replies
8
Views
1K
  • lokilaufey
0
Replies
0
Views
346
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.