Lion on RAID: no way?

Discussion in 'Mac OS X Lion (10.7)' started by dp84, Jul 21, 2011.

  1. dp84 macrumors member

    Joined:
    Aug 14, 2010
    #1
    Is it really possible that Apple has decided people can no more install OSX on volume RAID (software) because of FileVault and I don't konw what else? :mad::mad:
     
  2. Izlib macrumors member

    Izlib

    Joined:
    Apr 24, 2008
    #2
    I have it installed on a software RAID just fine. The FileVault encryption and recovery partitions are not supported on RAIDs, but otherwise it works just fine.
     
  3. dp84 thread starter macrumors member

    Joined:
    Aug 14, 2010
    #3
    really?

    can you be so kind to explain me the precise procedure you used?

    I tried clean install from a DVD, i get a message that advise "FileVault and recovery partition will not be available", then I got an "install error" and a dead loop of the screen "installing"
     
  4. yezza macrumors regular

    Joined:
    Mar 12, 2008
    #4
    I have the same issue (damn it!) and am looking for a solution.

    Used the SL install disk to repair and have my 10.6.8 back for now.

    Btw, I have 2x OWC SSD's in software raid 0 in a 2008 Mac Pro. I haven't tried installing from a DVD or USB, just the app store download.
     
  5. dp84 thread starter macrumors member

    Joined:
    Aug 14, 2010
    #5

    I did it!!

    The steps are:

    1. Burn a Lion DVD from the .app
    2. Put in the DVD, reboot, keep pressed C, wait
    3. Create your Raid Volume, format it and close Disk Utility
    4. Install into the Raid Volume (warning message will be prompt for FileVault and recovery partition)
    5. Wait... wait... wait.. error message will be prompt "unable to crerate recovery partition, restart to install" --> CONFIRM RESTART
    6. wait, wait, wait and at the end every thing will be ok :D
     
  6. saxofunk macrumors member

    saxofunk

    Joined:
    Jul 19, 2006
    Location:
    Denver, CO
    #6
    same issue here

    Installing 10.7 to OWC 100GB SSDs in software RAID 0. Tried upgrade from 10.6.8, failed miserably (same issues as above posts). Trying a clean install. Made it through the initial "cannot create recovery partition...blah blah" and restarted, after the 4th attempt failure I'm going to try re-creating the RAID from the installer boot disk and then install, I'll repost with the result
     
  7. jp266 macrumors newbie

    Joined:
    Oct 25, 2008
    #7
    this worked for me after the 3rd restart. I am using a stripped soft raid with two intel 80gb ssds. The problem now is that Lion doesn't see my time machine backup in a WD external usb drive.
     
  8. saxofunk macrumors member

    saxofunk

    Joined:
    Jul 19, 2006
    Location:
    Denver, CO
    #8
    Didn't work after 4 tries

    I think this install has some other issue keeping it from working. Trying another idea I had:

    Installed 10.7 (clean) to another external partition using a MacBook Pro
    Then doing a restore of that disk from the 10.6 installer's disk utility to the RAID on the Mac Pro (2008).

    This will keep 10.7 from trying to make a recovery partition, which is where mine fails out completely. I'll know tomorrow or Monday if this worked. My only concern is that kext files will be installed properly going from one model to another - but I think all of them are installed since the switch to Intel.
     
  9. yezza macrumors regular

    Joined:
    Mar 12, 2008
    #9
    Working now

    I now have Lion up and running with seemingly no issues.

    I'm not sure if this was just purely coincidental or not, but the only thing I did different to get it to install was to remove my dedicated windows SSD drive in HD bay 3. Thought it was worth a shot after reading about people getting the install failed error/loop due to a bootcamp partition.

    I had 5-6 failed attempts before removing the windows drive - worked first pop after that. I even have my home folder on a separate raid 0 set to Lion and everything is humming along nicely so far :)
     
  10. Schismz macrumors regular

    Joined:
    Sep 4, 2010
    #10
    Had a lotta similar issues. You can just copy the InstallESD.dmg out of the lion package, onto a hard disk partition (no DVD needed), boot it, then do a clean install onto another partition (or drive). You've now got a clean install of Lion on a regular hard drive.

    Clone it to your RAID, run Migration assistant from another backup, and you're good to go. I tried Disk utility for this purpose but just got broken pipe -32 errors on it. used CCC, no problems, been booting from 2-drive SSD RAID0 and using a 4-drive 3TB RAID0 stripe for the past few days. No further issues.

    Disk Utility is totally hosed tho. The GUI part. diskutil from command line continues to work as expected.

    I'm guessing it a combination of:

    FileVault
    Recovery Partition
    and
    coreStorage

    Really kind of pissed they didn't catch something so basic though. It's 2011, RAID is not uncommon.
     
  11. saxofunk macrumors member

    saxofunk

    Joined:
    Jul 19, 2006
    Location:
    Denver, CO
    #11
    +1

    They seem to be continually turning off the professional user and/or serious gamer.
     
  12. dp84 thread starter macrumors member

    Joined:
    Aug 14, 2010
    #12

    for what i saw, we have to thanks they haven't yet completely removed the RAID support :rolleyes::mad:
     

Share This Page