Lion - Printing to shared Windows 7 Printer

Discussion in 'Mac OS X Lion (10.7)' started by P0stalTek, Aug 1, 2011.

  1. P0stalTek, Aug 1, 2011
    Last edited by a moderator: Aug 1, 2011

    P0stalTek macrumors 6502


    Feb 25, 2011
    Hi all.

    I'm a brand new Mac user who is well-versed in PC's and Windows. I have no problems hooking up my shared Printer (connected to Win 7 Home Premium machine) to other Windows machines.

    However, when I connect it via Lion, it connects fine and shows up as my default printer. However, when I actually try to print something, the job hangs in the queue and errors something about authentication. I assume this is because of the Login information on the Win 7 box. Where can I enter the login information within Mac OSX Lion so that I can print on this network printer?

    Any direction would be great. I'm starting classes this week, and not being able to print from what is now my main school machine is kind of a bummer. I can print out via the Win 7 box, but that's kind of a pain to constantly go back and forth as that machine sits in my office while I'm usually in another room with the laptop.

    Thanks ahead for any help! And sorry for the noob question :(

  2. rwilliams macrumors 68040


    Apr 8, 2009
    Raleigh, NC
    I had to fix this kind of problem using CUPS.

    1. To get to CUPS, open a browser and type in http://localhost:631.
    2. Click on the Printers tab across the top, and find the printer that's giving you problems.
    3. Click on that printer, and in the dropdown that says "Administration", select "Delete Printer".
    4. Once you have deleted the printer, click on the Administration tab across the top of the page, and click the "Add Printer" button.
    5. Check the button next to "Windows printer via spoolss", and then click Continue.
    6. In the connection box, enter the following (filling in the appropriate information for username, password, host, and shared printer name):

    smb://username: password@<PRINTER HOST MACHINE NAME>/<PRINTER SHARE NAME>

    *remove the space between the colon and the password. I put it in there because without the space, it shows up on this forum as a smiley face.
    *If there are spaces in the host machine or shared printer name, you must use '%20' (without the quotes) in place of the spaces.

    7. On the next screen, enter a Name, Description, Location, etc. for the printer. Click Continue.
    8. On the next screen, select the make of your printer and click Continue. Find the appropriate model of printer, and click Add Printer.

    That should finish the process. You can now go back to the Printers tab across the top of the screen, click on the printer you just added, and in the dropdown that reads "Maintenance", print a test page to see if everything is working.
  3. P0stalTek, Aug 1, 2011
    Last edited: Aug 1, 2011

    P0stalTek thread starter macrumors 6502


    Feb 25, 2011
    What exactly is CUPS? When I went under Administration, it asked for a Username and Password and I have no idea what one it is looking for.

    Thanks for the info! I'm trying to work it through now. If I could figure out that login info anyways.
  4. rwilliams macrumors 68040


    Apr 8, 2009
    Raleigh, NC
    CUPS is the standards-based, open source printing system developed by Apple Inc. for Mac OS® X and other UNIX®-like operating systems.

    The username and password it asks for should be an administrator account on your Mac, be it your own or another admin account.
  5. P0stalTek, Aug 1, 2011
    Last edited: Aug 1, 2011

    P0stalTek thread starter macrumors 6502


    Feb 25, 2011
    I got past that point, and got CUPS to install the printer just as you stated. When I sent the test page from CUPS though it just hangs saying "Processing - Sending Print Data".

    Any ideas?

    EDIT: Could it be that the Win 7 machine with the printer installed/shared needs to be on Pro or Ultimate instead of just Home Premium?
  6. P0stalTek thread starter macrumors 6502


    Feb 25, 2011
    Under "Show Completed Jobs", I'm showing:

    Lexmark-10 Unknown Withheld 1k Unknown canceled at
    Mon Aug 1 12:47:51 2011
    "Unable to read CUPS raster data "
  7. rwilliams macrumors 68040


    Apr 8, 2009
    Raleigh, NC
    I can't say for sure if the version of Windows 7 is the problem, because the machine that my printer is connected to is a Windows XP computer. Let me try to connect the printer here at work to my Windows 7 machine and see if I can get it to work.
  8. P0stalTek thread starter macrumors 6502


    Feb 25, 2011
  9. jman240, Aug 1, 2011
    Last edited: Aug 1, 2011

    jman240 macrumors 6502a

    May 26, 2009
    Hey, I'm having the exact same issue as OP.

    I am running windows 7 64 bit pro with a usb connected HP Laserjet P1006 printer. I previously installed the AirPrint Hack found on this site and that was working great with Snow Leopard and it still works great with my iPad on iOS 4 and iPhone on iOS 5 beta 4.

    Since upgrading to Lion however... I can no longer print from any macs. The printer still shows up in the list as it did before and is very easy to add but I get the same (waiting for authentication) message. I haven't tried the CUPs thing you mentioned earlier. Just thought I'd comment. The only variable that changed for me was going from SL to Lion :rolleyes:

    Ok, so now I've tried the CUPs instructions as well and that didn't work for me. It didn't ask for authentication but it also didn't print and just sat there saying it was working.
  10. rwilliams macrumors 68040


    Apr 8, 2009
    Raleigh, NC
    Are your machines part of a workgroup? If so, see if this works:


    I just got this to work from a Windows 7 Professional machine that's on a domain.
  11. P0stalTek thread starter macrumors 6502


    Feb 25, 2011
    I'm in the process of reinstalling to Windows 7 Ultimate that I had laying around. Not sure why it wasn't already installed on my server. Thanks, I'll try that as soon as I'm back up and running.
  12. P0stalTek thread starter macrumors 6502


    Feb 25, 2011
    That didn't seem to work either..

    smb://WORKGROUP;Media: password@<SERVER>/<Lexmark>

    Server being the name of the Windows 7 machine, and Lexmark is the share name of the printer. Both the Mac and the Win7 machine are on WORKGROUP for their workgroup.

    In CUPs it just seems to hang sending data over. I don't even get the authentication error there. I'm at a loss and really am pretty disappointed since I thought my Mac would just work :(

    EDIT: Just to clarify, I did not enter the space in the address, I just added it so I could post ;)
  13. retro486, Aug 9, 2011
    Last edited: Aug 9, 2011

    retro486 macrumors newbie

    Aug 9, 2011
    I noticed in your original post you mention running Lion. If that's the case...

    Unfortunately for a lot of people, OS X 10.7 Lion dropped a LOT of support for various things, like PPC emulation (required by quite a few Adobe products) and SAMBA.

    Instead of SAMBA, OS X 10.7 uses a subset called "spoolss" which doesn't appear to function at all.

    We were able to print once by adding the printer by browsing for it in the "Windows" section of the "Add Printer" dialog in System Preferences, but we haven't been able to get it to work since.

    If you install the LPD printer service on your Windows machine, you can add your printer under the "IP" section, but it won't check your credentials and apparently just sends the print job straight through to the printer. There may be a way to fix this; we're still investigating.

    So: 1) SAMBA is dead on OS X 10.7, and 2) Use LPD instead unless you need access control, in which case you're out of luck, for now.


    You could also "just" compile SAMBA back into OS X, if you're into that kind of thing:

    EDIT: Here is some info on getting LPD going on your Windows box:
  14. jman240 macrumors 6502a

    May 26, 2009
    Got mine working now. Its slow but it works.

    Downloaded the latest driver pack for printers from the apple website.

    I happen to have an hp but there are other packs.

    I have the printer shared on a Win7 64 bit machine in the workgroup: workgroup.

    I clicked the + on printers and selected add a new printer (running Lion here) and then selected windows printer from the 4 options at the top. It came up with my workgroup name (after a few seconds) then my windows machine name then the shared printer. I added it then applied the correct driver from the list (after downloading and installing the KB update from Apple) and added it.

    It works fine. Didn't have to do anything special except download that driver pack and add it. There seems to be a minute or 2 delay between clicking print and having it actually print but I'll take slow over not working.
  15. donh macrumors newbie

    Sep 29, 2011
    finally working thanks to all you guys

    I had the same experience. The HP driver pack is humongous but it was what I needed; the driver for the P1006 printer wasn't included in Lion. Thanks rwilliams for the detailed instructions!

  16. Guardsix macrumors member


    Jun 16, 2011
    San Antonio, TX
    I'm trying to print to my wife's Windows 7 PC which has her listed as the Administrator. I do not believe she has a password set up since I normally don't put them on my Windows PC.

    So, what is am I supposed to provide when I'm asked for "Authentication required" or when I'm supposed to provide any kind of password?
  17. reguardsix macrumors newbie

    Feb 20, 2012
    authentication win 7

    Hi gaurdsix,

    Give your wife a password then

    in the Run Cmd box
    control userpasswords2

    then set it so it automagically logs her in

    then you should be able to deal with the other permissions stuff from the mac.

    hope it helps,
  18. Erik von Reis macrumors newbie

    Feb 25, 2012
    Cups! Huge help

    I had no idea Mac printing was on Cups. This was a huge help.
  19. MisterMe macrumors G4


    Jul 17, 2002
    Apple has owned CUPS since 2007 and employs its chief developer, Michael Sweet.
  20. stevenlawton macrumors newbie

    Mar 10, 2013
  21. Sonz macrumors newbie

    Jan 24, 2014
    Rwilliams please help


    I followed your advice but my computer says forbidden when I try delete printer for change back to admin

    please help

Share This Page