Lion Privileges Problem

Discussion in 'Mac OS X Lion (10.7)' started by drsarg, Apr 3, 2012.

  1. drsarg macrumors newbie

    Joined:
    Nov 13, 2010
    #1
    Hello, I have been looking at various forums as a solution to my problem, but none of it seems to work. Therefore I have created this forum in hope that somebody does know the solution to my problem.

    Basically I have a problem on my MacBook Pro with Lion and saving/deleting files. I first of all noticed it when I tried to put a file in the Trash, it asked me for my password. I asks me for my password when deleting a file from Documents, Desktop, Pictures, Music etc.

    There are some strange details about this problem though. First of all, I created a TextWrangler document and saved in Documents. It saved fine and I was able to move it to the Trash without asking for a password. However, if I edit a TextWrangler document that was created before the problem and try to save it, I get a message saying that "This operation couldn't be completed, because an error occurred" and that "You do not have sufficient privileges to perform this operation (MacOS Error code: -5000)". Even though this application is not an Apple one, I think that it is under the same problem.

    So here is what I have done to try and fix it. I started by changing "Sharing & Permissions" for my home folder, by read and write set with "Apply to enclosed items". I then tried the Disk Utility on Macintosh HD, by Repair Disk Permissions. This also did not work, so Verify Disk Permissions and Verify Disk were tried. I then restarted the PC and ran the Command + R menu, "resetpassword" was typed in Terminal. I chose my username and hard drive, then clicked on the Reset Home Directory Permissions and ACLs button, again on restart the problem stayed.

    I have now created a new user account as an attempt to fix it. This account is part success, part failure. For example, if I created a new file and put it in Trash, it does not ask for password. However, I transferred the files to my new user account by the old users shared folder, I have now dragged files in the Documents folder but whenever deleting one it still asks for my password :(

    So how do I fix this!? The only thing I can think of is to reapply the priveleges in the new user account, as maybe there is a way to delete properties on the files so that it resets the privileges?? But I don't know how this would be possible.

    One other thing that may help. I use Parallels Desktop 7. The other day I was trying to save a file using my Windows 7 virtual machine, but it failed due to Privileges so I guess this is part of the same problem. As well as this, Safari has not been saving history or bookmarks I add - although this could be different, it might be the same problem. However, on the new account Safari saves bookmarks and history fine.

    Thanks
     
  2. drsarg thread starter macrumors newbie

    Joined:
    Nov 13, 2010
    #2
    I was just wondering if anyone knows a solution without reinstalling the whole operating system. Maybe somebody has a suggestion that I missed while completing the steps above?
     
  3. blatopilot macrumors regular

    Joined:
    Sep 24, 2011
    #3
    Try holding SHIFT before boot up to get into safe mode. Same issue?

    Tried re installing with CMD+R? I have little experience with parallels so hopefully someone else can help.
     
  4. drsarg thread starter macrumors newbie

    Joined:
    Nov 13, 2010
    #4
    I know this is a very late reply but is useful for others with the program. What I did is move my files to my shared folder and then copy them from that shared folder to another username. I then changed the privileges of all the files so that I was the owner and I therefore no longer have a problem. However, I still cannot access one of my external hard drives.
     

Share This Page