Lion Probs:Java/Sotware Updates/Safari

Discussion in 'Mac OS X Lion (10.7)' started by MattBGB, Jul 20, 2011.

  1. MattBGB macrumors newbie

    Joined:
    Oct 22, 2009
    #1
    Hello all,

    I've just installed Lion on my MacPro as it was released here today in the UK, and it seems alright except for 2 or 3 really bad probs.

    Firstly, upon restarting, it tells me that it can't run Photoshop CS5 without the Java Runtime and offers to let me install it.

    Clicking ok makes it start downloading or installing but it always stops part way through and never restarts again.

    Force-quitting that and trying it again doesn't work at all and it doesn't even begin to d/l, requiring another force quit.

    Also, trying to update iTunes in Software Update only gets part pay along the progress bar before that stalls as well.

    And thirdly, Safari connects to a web page ok, but opening other tabs and trying to connect to other sites fails and the window stays blank while the radar wheel spins.

    Quitting and trying to restart Safari usually results in the dock icon bouncing endlessly and Safari not launching.

    Firefox works fine so I know it's not my connection.

    Also, turning off the Firewall, Little Snitch and restarting don't help at all either.

    It's really annoying!

    Any help would be much appreciated, thanks.

    M :mad:
     
  2. bolen macrumors 6502

    bolen

    Joined:
    Jul 22, 2008
    Location:
    Sweden
    #2
    I have the same problem. I've even re-installed Lion from a self-created USB drive and gets the same behavior (used migration assistant though).

    How did you upgrade to Lion? App Store?
     
  3. Chupa Chupa macrumors G5

    Chupa Chupa

    Joined:
    Jul 16, 2002
    #3
    I had a slightly different problem w/ Java and Software Update, but equally maddening. I'll have to wait for the next Apple update round to see if it repeats or was a one off. I did d/l Java though, not stop/start like you were having.
     
  4. MattBGB thread starter macrumors newbie

    Joined:
    Oct 22, 2009
    #4

    Yes, via the App Store.

    I've just restarted again and same probs. Safari will only connect to about 1 page in 10, doesn't relaunch, and the Java download has stopped again, with the progress bar nearly halfway, but the info underneath saying that it's downloaded 14Mb of 65.3Mb, which doesn't really make sense.

    Wondering if I could/should use TimeMachine to go back to Snow Leopard.... :mad:
     
  5. bolen macrumors 6502

    bolen

    Joined:
    Jul 22, 2008
    Location:
    Sweden
    #5
    The annoying thing is that I was running Lion DP4 before, upgraded to the retail and started to experience this.. I then thought that I messed up my installation because I upgraded a developer preview. But guess not since you have the same issue going from SL->Lion..

    It's kinda' annoying because I actually had no issues what so ever on Lion DP4.. upgraded for the heck off it.

    Will try to find a solution/hammer through the updates, if it doesn't work I will have to restore my SuperDuper! clone.
     
  6. Phil Lee macrumors 6502

    Joined:
    Mar 19, 2008
    Location:
    Manchester, UK
    #6
    I had the same thing happen with Java. I restarted my computer, left it for an hour or so and the update downloaded successfully. I think it's down to the Apple servers getting a hammering.
     
  7. darkerside macrumors member

    Joined:
    Jul 11, 2007
    #7
    I installed Lion, afterwards I launched a Java app which prompted me to install Java, I clicked install and it downloaded and installed no issue. I assume if your having a problem it might be apples servers as the poster above mentioned. Again this did work for me without issue.
     
  8. trufaith macrumors newbie

    Joined:
    Mar 10, 2009
    #8
    ********* Lion

    Having the exact same issues as you (Safari, iTunes won't open and Installer is F**cked) so i can't use my Mac for much at all. I am more than P*SSED OFF with this.
     
  9. RogersDA macrumors 6502

    Joined:
    Aug 19, 2009
    #9
    Yeah - Java Runtime hangs during installation. :mad: :mad: :mad:
     
  10. MattBGB thread starter macrumors newbie

    Joined:
    Oct 22, 2009
    #10
    Well, I just restarted my Mac, holding down the Shift key to put it into Safe mode (?) and the Java download & install worked fine, as did the iTunes one, and Safari worked fine too.

    So, I assume it must be something to do with an app or plugin or something I have, that's interfering with it?

    I remember back in the days of OS9, there was a utility called Conflict Catcher that could narrow down and identify extentions/plugins etc that were causing probs.

    Is there anything similar of OSX?
     
  11. trufaith macrumors newbie

    Joined:
    Mar 10, 2009
    #11
    Its working

    Ive not done anything at all not even restarted my Mac but I just tried Software Update again and Java and all is working (DL & INSTALL). Must have been a server problem with Apple (everyone trying to update at the same time. However my iTunes still doesn't work but I'm guessing thats because its Beta and I can't downgrade (Wish I never paid for the development programme).
     
  12. mumbles macrumors newbie

    Joined:
    Jun 12, 2009
    Location:
    UK
    #12
    I was having the same problems, shut my machine down for while and tried again, everything seems to be ok now :)
     
  13. RogersDA macrumors 6502

    Joined:
    Aug 19, 2009
    #13
    Thanks - worked.
     

Share This Page