Lion Safari Little Annoying Bug

Discussion in 'Mac OS X Lion (10.7)' started by Henry Li, Jul 21, 2011.

  1. Henry Li macrumors member

    Joined:
    Mar 24, 2009
    #1
    Sometimes, when I have several tabs in my safari windows, I cannot close the existing tab, since the little cross doesn't appear. WTF! What Lion is doing to Safari!!! :mad:
     
  2. Drunken Master macrumors 65816

    Drunken Master

    Joined:
    Jul 19, 2011
    #2
    Was doing that to me yesterday but it seems to have stopped today...dunno.

    They'll fix it soon enough, but I've had to resort to click on another tab and then on tab I want to close again to get the X to pop up.
     
  3. Henry Li thread starter macrumors member

    Joined:
    Mar 24, 2009
    #3
    Hey~ I did the same as you! But, it is really annoying :confused::confused:
     
  4. deannnnn macrumors 68000

    deannnnn

    Joined:
    Jun 4, 2007
    Location:
    New York City & South Florida
    #4
    The title of this thread makes me think of small insect annoying you while you're at a lion safari in like Africa or something.
     
  5. Guini macrumors newbie

    Joined:
    May 17, 2011
    #5
    I've noticed the same little bug, think you're slightly over exaggerating though..
     
  6. paulold macrumors 6502

    Joined:
    Mar 3, 2008
    Location:
    Washington, DC
    #6
    I've noticed the same issue. It seems to be related to full-screen mode of Safari and tabs that open when you click on links in a webpage that used to open into new windows. Full-screen mode forces these new windows into tabs and these tabs don't come with the little close x's. You can right click them and say close tab. Or if you end up opening a few of them, you can right-click the main tab and choose close all other tabs. Clearly a bug. Getting sloppy, Apple...
     
  7. Drunken Master macrumors 65816

    Drunken Master

    Joined:
    Jul 19, 2011
    #7
    We've identified the problem TS, don't worry, a Genius is on the way. He may still be in high school and thinks a nose piercing is a great idea but he's a genius, I'll tell ya what pardner.

    [​IMG]
     
  8. paulold macrumors 6502

    Joined:
    Mar 3, 2008
    Location:
    Washington, DC
    #8
    I think I came up with a possible fix. I remembered that Safari has the option of opening any link into a new tab. I had mine set to Never. The other choices are Automatically and Always. I set mine to Automatically and now the tabs are behaving properly. I haven't had trouble closing any yet. Seems to make sense that the Never setting would interfere.

    Not sure if it made any difference, but I stepped out of full-screen mode, set the preferences for the tabs to Automatically, and then returned to full-screen mode.
     

Share This Page