Lion Server AFP fileshare disappointing

Discussion in 'Mac OS X Server, Xserve, and Networking' started by jimmueller, Mar 26, 2012.

  1. jimmueller macrumors newbie


    Jul 25, 2002
    We recently upgraded our home file server from a 1st gen PowerMac G5 2x2 (2003) running Leopard to a 2011 MacMini preconfigured with Lion Server (2GHz quarcore) as we were never heavily loading the G5 with fileserving duties (it was originally our video editing box) and were tired of it acting as the room's combination space heater and white-noise generator.

    We copied the files from the G5's internals to an external FW800/eSATA RAID1 unit and hooked it up to the Mini's FW800 port (while we wait for a ThunderBolt eSATA adapter) to resume duties as our network data drive.

    1 - All appeared well when I mounted the data drive on my MacBook Pro and MacPro running SnowLeopard. When my wife mounted the same drive on her MacBook Pro (identical to mine) it took over ten minutes for the contents of each level of folders to appear - completely unusable.
    The only difference between her machine and the others is that it is networked via an AirPort Extreme (running solely 5Ghz 802.11n) and all the other machines are on Gigabit ethernet (including the NetGear switch). I unmounted the data drive, turned on my MBP's AirPort, logged in, unplugged my Ethernet and remounted the data drive. Now it took mine ten minutes to show the contents of a folder.
    When the drive was shared on the old G5 Leopard, folders opened and populated in a few seconds, even over WiFi.
    My wife is now stuck with putting her MBP on wired Ethernet if she wants to access any of the files we share on the network data drive.

    2 - When I went to move a gig or so of image files from my MBP to the data drive on the Mini I got an error after a few minutes that file blah-blah.jpg could not be copied because I did not have permission and it threw the same error for every subsequent file. The source folder was on my Desktop, fully owned by me, and the data drive was mounted as a Server admin (our normal mode of operation since the turn of the century - it's only my wife & I using it). I dragged the folder's contents over a few files at a time and had no problems. I tried the same with a different folder of about the same size and it moved with no errors. I tried a much smaller folder - about 70 images totaling hundred meg - and got the same sort of error. Trial & error showed the error was not dependent on how many files, how large the folder, how busy the network or whether the files were being moved or copied, though more likely when moving multi-GB folders. As a test I mounted a folder shared on the MacPro running SnowLeopard (the Mini is the only Mac we have running Lion) and tried moving and copying files to it. Not only did they transfer much faster to the MacPro but I never once saw that "you do not have permission..." error even after moving almost 150 Gig of images in several dozen folders.

    So, all in all, I am seriously considering adding file-serving duties to our video-editor MacPro and selling off the Lion Server MacMini.

    Could the FW800 connection be the bottleneck? In the G5 the drives were SATA2, but the machine itself had half the horsepower, half the RAM and was running Leopard.
  2. macrumors newbie

    Mar 27, 2009
    Nagoya, Japan
    I can confirm permission errors on Lion

    I can confirm permission errors on Lion, when moving folders of large files.

    Seems to be less errors if you copy the files and not the folders, but I have to deal with folders of 50,000 plus images, so that's not going to work for me.

    I have to make a ZIP file and then UNZIP on Lion to get it copy files.
    It's a pain but it works.
  3. mike693 macrumors member

    Jun 24, 2011
  4. jimmueller thread starter macrumors newbie


    Jul 25, 2002
  5. bernuli macrumors 6502

    Oct 10, 2011
    I bought a new mini in December and set it up with Lion Server. One thing I noted, that file copy throughput put was much faster if logged on locally to the mini. You don't need a monitor hooked up, but if you screen share in, and log on for some reason AFS is faster. Locking the screen or starting up a light weight screen saver slowed the file copy speeds over network, so have to leave it open.

    Also, if you just copied a bunch of files, might be best to waif for spotlight to finish indexing. Then should be faster.

    Firewire should not be the bottleneck.

    As far as permissions, you might need to use ACLs, though for a home server, that seems unnecessarily complex. Maybe select "ignore ownership" on the raid volume get info?



Share This Page