Lion Server rejecting Windows 7 PC Log-in

Discussion in 'Mac OS X Server, Xserve, and Networking' started by keithm1985, Jun 24, 2014.

  1. keithm1985, Jun 24, 2014
    Last edited: Jun 24, 2014

    keithm1985 macrumors newbie

    Joined:
    Jun 24, 2014
    #1
    Hi there,

    After searching Google for hours I'm hoping that someone on this forum can help me. Many of the solutions I've found online haven't gotten me any closer to figuring out why our server is rejecting our PC users' log-in credentials. I'm running Lion Server at our office. We're primarily Mac users so most people here have no problem connecting to our server.

    Our PCs running Windows 7 have a different experience. Most of the time it works well enough and we connect via SMB (which is enabled currently). But often I run into problems like my current one - I can see the server in our Network from the PC. When I click to join it, I'm prompted for a username and password but when I enter the info I'm told "Logon failure: unknown username or bad password."

    Most days simply entering the username and password just work. And I've read enough about this to know that in addition to just entering the username and password I should try and enter "SERVER\user" as the user to set the domain to my server and then use the correct password. But this doesn't work either.

    Then I tried connecting to the server by mapping a network drive (\\SERVER\share) but once again - it brings me to the log-in screen and then rejects the login info in all forms.

    I double checked and all login info is correct. I've also tried restarting the server, the PCs, and unchecking and rechecking SMB sharing to no avail.

    Is there something I'm missing here? Why are Lion Server and Windows 7 randomly incompatible over my network?

    Any help would be very much appreciated! Thanks in advance! And I'd be happy to provide any additional info that may be needed to understand the problem.
     
  2. keithm1985 thread starter macrumors newbie

    Joined:
    Jun 24, 2014
    #2
    Might have found a fix

    I might have found a solution to the problem and I'll post it here in case it helps anyone else. Once I made this small change all of the PCs on my network were able to log in to the server. In fact, the connections were immediate and no credentials were ever requested, just as it is on the days when things work smoothly.

    I used the short checklist guide written by user "abwc" found here: https://discussions.apple.com/thread/3878980

    Specifically his or her step 3 made the fix for me: The WORKGROUP setting in Network Preferences/Advanced/WINS must match the name of the workgroup to which the Windows machine belongs. The workgroup name does NOT have to be "WORKGROUP", but it does need to match the Window's machine's workgroup name. NOTE: it is easy to omit the "Apply" step when making this change, but unless you hit "Apply" you will find that your changes do not stick."
     

Share This Page