Lion Sever SMTP Relay to ISP, DYNdns

Discussion in 'Mac OS X Lion (10.7)' started by McShrek, Jul 28, 2011.

  1. McShrek, Jul 28, 2011
    Last edited: Jul 28, 2011

    McShrek macrumors newbie

    Jul 28, 2011
    I have Lion Server running as a web, mail and other apps. Everything works fine, yet I do not have a static IP nor does my wonderful provider allow for that service (Time Warner). So I use DYNdns to maintain a fake static ip.

    The Lion Server is also my Firewall, all incoming requests forward directly to the Server (active DMZ Zone).

    Anyway, after setting everything up, which was a bit of a miracle since I have no such experience, Mail works fine with the exception of the bounce backs from mail providers like gMail that verify the IPs and if the domain ip is different than then sending ip, the mail server will not accept the mail.

    I am sure many are aware of the issue, so I will not spend much time explaining. So I signed up for the STMP routing with DYNdns, thus requiring the outbound relay to be set within the Lion Server Mail Setup. As outlined in their support page:

    Long story short, if I use the relay option as specified by DYNdns:
    Relay to ISP = Checked
    Server Name:
    Login/password as provided by DYNdns
    Auth type: login/password
    Verify in the firewall that the smtp ports are open

    The deal is, that I can receive yet mail will not send, actually it sends but is not delivered and I get no error or returned mail. I have contacted DYNdns support, who were much less than helpful, yet they did look at the logs and showed that the emails went to the mail hop, the user name was correct, but password failed. After checking things out the best I could, I am leaning towards the fact that Lion Mail Sever is encrypting the password when it sends the mail to the mail hop. DYNdns believed the same.

    So does anyone know how to ensure that the password is sent correctly on lion server, when using the stmp relay to ISP configuration.

    I know the STMP is working outside using the server to relay the msg., because if I configure mail clients to use the DYNdns STMP outgoing server settings: the clients work fine. In very short terms the relay ti ISP option in Lion Seever does not work
  2. wildwilliy macrumors newbie

    Jul 28, 2011
    Same Problem

    I have the exact same problem. However, my mail log message indicates that a response timed out while waiting to connect to the dyndns mailhop server.

    If I setup the outbound mail hop smtp server directly into the mail client or mobile client it works fine.

    I agree with you that the problem is with the relay feature of Lion Server. I even tried putting the port number after the server as follows:

    There does not appear to be any other way to configure port settings either under the server app or server admin tools.

    There is a relay setting in the Server Admin tools where you can tell Lion to relay on mail submitted by the local server IP addresses. I am wondering if this needs to be turned for the mail to actually relay.

    I do not recall having this problem with Snow Leopard Server.
  3. McShrek thread starter macrumors newbie

    Jul 28, 2011

    I had the same question about the relay setting. Just not sure what to put in there. I am planning to call Apple or go into a store, my guess they will be no help. I also have a friend who is an Linux expert that will look at my config file this week. Let me know if any of your trouble shooting works and I will do the same. Guess it is not a big deal since the client works, but I would like all mail to come to my server first and then relay.
  4. raymanster macrumors 6502


    Feb 13, 2008
    I have exactly the same problem, has anyone found a workaround yet?
  5. raymanster macrumors 6502


    Feb 13, 2008
    I think I've found a fix:

    1. After a lot of Googling I stumbled across something called Server Admin which is provded free by Apple:

    2. Installed this on my Macbook which also has server installed, ran it, selected Mail in the left column, click on the Logs tab, under View selected SMTP and found this error:

    "Aug 18 11:21:47 macbook postfix/smtp[62259]: warning: SASL authentication failure: No worthy mechs found"

    3. Googling that error found this which applies to the previous version of Server:

    4. Following that post I stopped Mail, opened Terminal and entered:

    sudo -s -H
    cd /etc/postfix
    cp -p

    5. As per the link above, I entered one line at the bottom of the file:

    smtpsasl_securityoptions =


    It looks like the way lines are entered in Lion is different, that didn't work so I modified and entered:

    smtpsasl_security_options =

    That's an extra _ between security and options.

    6. In Server Admin I started Mail again. Sent a test email from the Mail client and seems to work now.

    Hope this is of some use to people here.

    I learnt Vi is a standard Unix editor, commands on how to use it can be found here:
  6. boltman519 macrumors newbie

    Dec 28, 2011
    Hey just found this and was wondering if it was still working for you. Plan on buying lion server this weekend and want to run a personal email server for my wife and I with our own domain.
  7. raymanster macrumors 6502


    Feb 13, 2008

    It was working up until just before Christmas. And now I can no longer check my mail outside of my local LAN. Not really too sure what the problem is as I've not had time to investigate properly. Luckily I don't use it as my main mail address.

    I run Lion Server on my Macbook. But funnily enough my 2005 Intel Mac Mini's HD decided to die around this time as well!
  8. toyflish macrumors newbie


    Mar 5, 2012
    thanks but actually from the manpage it is with another underscore smtp_sasl_security_options=

    I wonder that it differs from version to version or from docs to docs

Share This Page