Lion slow to pickup wifi from sleep

Discussion in 'MacBook Pro' started by kappaknight, Jul 23, 2011.

  1. kappaknight macrumors 68000


    Mar 5, 2009
    Has anyone else noticed this? Now that I'm running Lion, when I wake the MBP it will not be able to find the wifi connection before an error pops up. I've noticed this especially when Time Machine failed to finish the last backup before I put it to sleep.
  2. rdowty macrumors 6502a


    Oct 5, 2008
    I have. I usually turn it off then back on again.
  3. WickedPuddin macrumors member

    Jun 15, 2011
    Honestly, Lion has been glitchy since its release and apple will probably addressing those issues through updates and such. Best thing to do now is wait.
  4. kappaknight thread starter macrumors 68000


    Mar 5, 2009
    Yeah, I'm doing this too but really shouldn't have to. Just trying to pinpoint odd behaviors so they can hopefully address it.
  5. Kauai macrumors 6502a

    Oct 13, 2010
    Same. But at least I know now it's not just me. Been having to turn it off and on to get it to work.
  6. vbui26 macrumors newbie

    Dec 9, 2008
    Same problem is happening with me since I upgraded to lion... Hopefully they will address the problem soon!
  7. jabbawok macrumors regular


    Sep 30, 2004
    My 11' Air used to wake from sleep in a second with 10.6 and wifi would pick up a second or two later. now its taking 10 or 15 seconds for it to become responsive and connect to wifi with 10.7.
    Hope it's sorted, I may swell shut it down now, as it boots in 10 or 15 seconds.
  8. BowyerM macrumors newbie

    Aug 1, 2011
    I have the same issue on a Mid-2010 Macbook Pro - I find turning the Wi-Fi off and back on fixes the issue. Saves rebooting your Mac.

    You can add your Wi-Fi status to your menu bar using an option in the 'network' system preference panel so it's a simple click to do.

    Just waiting now for the update from Apple that will fix it properly.
  9. maril1111 macrumors 68000


    Mar 14, 2010
    Restarting WIFI usually helps, but what I find strange is that I get fullbars with Lion even though I only had 2/5 bars in snow leopard on the same network :/ anybody else?
  10. BAC5.2 macrumors regular

    May 16, 2011
    I just did a full reboot (first time in a while), and noticed that WiFi didn't re-enable. Had to turn it off, then back on.

    So far, Lion seems a little buggy. Hopefully the issues get addressed quickly.
  11. eattherich macrumors 6502


    Jul 8, 2011
    I've noticed this a couple of times too. I also noticed it dropping the Wi-Fi connection a couple of times. I've seen these issues reported on a number of forums so I'm guessing that Apple will be addressing this soon.
  12. sturdenator macrumors newbie

    Jan 8, 2011
    I've also been experiencing this since upgrading to Lion (mid 2010 Mac Mini). I just open Safari and when it says you have no internet connection, I click the Network Diagnostic and it works its magic.
  13. jpcarro macrumors 6502


    Mar 13, 2009
    On your nine
    Same here. And if Time Machine is trying to backup (to network storage) as the MBP is coming out of sleep and WiFi hasn't connected yet, I have to manually stop Time Machine. Otherwise, WiFi won't connect until Time Machine gives up trying to find the network storage. Strange chicken/egg problem. Very annoying.
  14. starworshipper macrumors newbie

    Sep 29, 2011
    Happen to me as well. And I got an almost brand new MBP.

    This also happened with alot of other pre-lion-installed programs, for example my bluetooth audio transmitter. Used to pop up in a second, now I have to search actively for available bluetooths to make it even noticable.

    Apple better be doing something..
  15. Redsand187 macrumors member

    Jan 4, 2008
    Central Washington State
    I too have still been experiencing this with my 2011 15" 2.ghz i7. I thought 10.7.1 was supposed to fix it, but I have noticed no difference. My 09 13" MBP and 09 27" iMac do not have any problems, all running 10.7.2 and connected to the same Airport Extreme network.

Share This Page