lion, system preferences freeze

oginome

macrumors newbie
Original poster
Jul 21, 2011
17
0
HK
after installed lion on mba 2010, I've changed the wallpaper by "desktop and screen saver".
but during to select the different wallpaper several times, "desktop and screen saver" to be freeze (beach ball), so I need to force quit.

then I try to start "system preferences" again. It's startup page is "desktop and screen saver" and it freezes (beach ball) everytime then need to force quit.

don't know related to lion or not. any hint? thx.
 

dman1001

macrumors newbie
Jul 23, 2011
1
0
I was getting exactly the same problem and so were a lot of other people.

This is how to fix it - and it worked for me along with others:

1) Apple have hidden the Library folder by default in Lion. To permaently unhide it, open the Terminal utility and run the following command:

chflags nohidden ~/Library

After running this command the Library should become immediately available, without the need to reboot the system or log out and log back in.

2) Open Finder and drill down to MacPro HD/Users/Your Username/Library/Preferences and then send the following file to the trash: com.apple.desktop.plist

3) Reboot your mac (this may not be needed but I prefered it this way) after reboot should work for you :)

The com.apple.desktop.plist gets recreated in Finder so if you are satisfied it has work, you can now delete this file from the trash.

It'll be great to hear if it works for others.

Cheers
Sam
 

Ropie

macrumors regular
Aug 6, 2007
184
0
England
I had the same problem but the fix was different. I had to uncheck 'open in 32 bit mode' in the 'get info' window for the System Preferences app.
 

jace88

macrumors regular
Jan 3, 2011
207
13
Sydney, Australia
I was getting exactly the same problem and so were a lot of other people.

This is how to fix it - and it worked for me along with others:

1) Apple have hidden the Library folder by default in Lion. To permaently unhide it, open the Terminal utility and run the following command:

chflags nohidden ~/Library

After running this command the Library should become immediately available, without the need to reboot the system or log out and log back in.

2) Open Finder and drill down to MacPro HD/Users/Your Username/Library/Preferences and then send the following file to the trash: com.apple.desktop.plist

3) Reboot your mac (this may not be needed but I prefered it this way) after reboot should work for you :)

The com.apple.desktop.plist gets recreated in Finder so if you are satisfied it has work, you can now delete this file from the trash.

It'll be great to hear if it works for others.

Cheers
Sam
Thanks very much Sam. Worked well for me and I didn't need to restart. Surprisingly it also retained my wallpapers :S On another note, I could've sworn the Library folder was there in Leopard/Snow Leopard and only became hidden in Lion? *scratches head*
 

BL4zD

macrumors 6502
Sep 22, 2010
273
6
Thank you, this worked for me as well. I noticed the problem when I went into the apple store for an unrelated issue. The genius started banging on my keyboard but couldn't get system preferences to respond so he eventually gave up :| I wish I'd known what the issue was then.
 

Simplicated

macrumors 65816
Sep 20, 2008
1,423
252
Waterloo, Ontario, Canada
I was getting exactly the same problem and so were a lot of other people.

This is how to fix it - and it worked for me along with others:

1) Apple have hidden the Library folder by default in Lion. To permaently unhide it, open the Terminal utility and run the following command:

chflags nohidden ~/Library

After running this command the Library should become immediately available, without the need to reboot the system or log out and log back in.

2) Open Finder and drill down to MacPro HD/Users/Your Username/Library/Preferences and then send the following file to the trash: com.apple.desktop.plist

3) Reboot your mac (this may not be needed but I prefered it this way) after reboot should work for you :)

The com.apple.desktop.plist gets recreated in Finder so if you are satisfied it has work, you can now delete this file from the trash.

It'll be great to hear if it works for others.

Cheers
Sam
Here's an even quicker way without even having to go to Finder:

Type rm ~/Library/Preferences/com.apple.desktop.plist in Terminal, then logout and log back in and voila!
 
Last edited:

Morpheus1

macrumors newbie
Oct 24, 2011
1
0
On iMac with OSX Lion "System Preferences" freeze after desktop update

I was getting exactly the same problem and so were a lot of other people.

This is how to fix it - and it worked for me along with others:

1) Apple have hidden the Library folder by default in Lion. To permaently unhide it, open the Terminal utility and run the following command:

chflags nohidden ~/Library

After running this command the Library should become immediately available, without the need to reboot the system or log out and log back in.

2) Open Finder and drill down to MacPro HD/Users/Your Username/Library/Preferences and then send the following file to the trash: com.apple.desktop.plist

3) Reboot your mac (this may not be needed but I prefered it this way) after reboot should work for you :)

The com.apple.desktop.plist gets recreated in Finder so if you are satisfied it has work, you can now delete this file from the trash.

It'll be great to hear if it works for others.

Cheers
Sam
Thanks, dman1001, it worked just fine as described! I have pretty new iMac with OSX Lion and after changing background on the 1st monitor, while I was trying to do the same on 2nd "System Preferences" became freezing on ANY component from them. I didn't touch lock file with the same name plus ".lockfile" and YES, after reboot I got new com.apple.desktop.plist of 2KB, AND EVERYTHING WORKS as before this incident. Best. Morpheus1
 

alaphridus

macrumors newbie
Oct 27, 2011
1
0
com.apple.desktop.plist.

I was getting exactly the same problem and so were a lot of other people.

This is how to fix it - and it worked for me along with others:

1) Apple have hidden the Library folder by default in Lion. To permaently unhide it, open the Terminal utility and run the following command:

chflags nohidden ~/Library

After running this command the Library should become immediately available, without the need to reboot the system or log out and log back in.

2) Open Finder and drill down to MacPro HD/Users/Your Username/Library/Preferences and then send the following file to the trash: com.apple.desktop.plist

3) Reboot your mac (this may not be needed but I prefered it this way) after reboot should work for you :)

The com.apple.desktop.plist gets recreated in Finder so if you are satisfied it has work, you can now delete this file from the trash.

It'll be great to hear if it works for others.

Cheers
Sam
Hi,
I did steps 2 and 3 but the com.apple.desktop.plist did not get recreated in Finder. Should I brings the file back from trash?
Thank,s
 

rutroh50

macrumors newbie
Feb 9, 2012
3
0
thanks for the tip......

I followed the directions to the detail and it is back up and running......first issue I have had with my iMac in almost a year but a quick fix.....thanks again:)
 

jtab1972

macrumors newbie
Feb 1, 2011
3
0
It worked for me too

I lost all my pretty screens I set up on Lion, but at least it's functional again. Does anyone understand why it hung up like that in system preferences? Is it a software glitch by Apple?
 

Christianwyant

macrumors newbie
Jul 26, 2012
1
0
This is a life saver!

I was getting exactly the same problem and so were a lot of other people.

This is how to fix it - and it worked for me along with others:

1) Apple have hidden the Library folder by default in Lion. To permaently unhide it, open the Terminal utility and run the following command:

chflags nohidden ~/Library

After running this command the Library should become immediately available, without the need to reboot the system or log out and log back in.

2) Open Finder and drill down to MacPro HD/Users/Your Username/Library/Preferences and then send the following file to the trash: com.apple.desktop.plist

3) Reboot your mac (this may not be needed but I prefered it this way) after reboot should work for you :)

The com.apple.desktop.plist gets recreated in Finder so if you are satisfied it has work, you can now delete this file from the trash.

It'll be great to hear if it works for others.

Cheers
Sam
I am not kidding untill i read this i was about to reboot my computer. Now im going to save this in a word document for my future reference. the only reson i made an account on macrumors was to give this one some props it was alot of help!!!
 

tkr96

macrumors newbie
Aug 7, 2012
1
0
Joined to reply to this solution.

I just wanted to say thank you to the original poster. I had searched for over two weeks for a solution to this problem and found very similar solutions all over the web. They all pointed to the wrong files and the problem simply immediately happened again. I decided to search this morning on a whim. Removing this file and its lock file cleared my problem. I did follow the reboot suggestion and when I arrived at a default apple background I knew that this solution was different ... in a good way. Thanks again for the post.
 

Similar threads

  • CharCat
1
Replies
1
Views
144
  • wisevot1900
8
Replies
8
Views
1K
  • lokilaufey
0
Replies
0
Views
356
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.