Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Lion - unable to scan Resource Busy

WebMystic

macrumors newbie
Original poster
Aug 11, 2010
1
0
Jersey
MacBook Pro 15-inch, Mid 2009 (FRESH BUILD)

Newly installed Snow Leopard from apple restoration disk. Then installed Lion from app store. Restored apps from TimeMachine backup.

Trying to created a Hackintosh USB drive. (Please don't sway from topic - important fact is I can no longer create a USB image using Disk Utility)

Let me also say that I've created plenty of USB disk in the past SO I KNOW HOW DISK UTILITY WORKS.

Steps to create USB image:
  1. Partitioning the USB drive.
  2. Drag the .dmg file to the Source
  3. Drag the USB drive to the Destination
The Lion Disk Utility wants to then scan the Source before making the image. After I type my admin password I continue to get a message, "Unable to scan [volume Media]." (Resource busy)
 

autotom

macrumors newbie
Sep 4, 2011
1
0
I Had the same problem

Exact same issue.. something must have been holding onto the USB..

format it as 'free space' with a GUID partition table

physically remove USB

plug back in

( hopefully ) it will say 'disk could not be initialized' click IGNORE

proceed with restore.
 
Comment

alfa147x

macrumors newbie
Jul 29, 2007
3
0
I figured out a fix. Click the partition under the usb drive you want to restore the image on to. Then click File then Unmount.

Then re-do the restore. Worked for me.
 
Comment

rchang

macrumors newbie
May 15, 2012
1
0
move image drive to another location...

i tried restoring a .dmg of a USB flash drive with Lion Disk Utility.

Disk Utility was giving the "unable to scan" resource error when the .dmg I was trying to restore from was an external usb hard drive. This error occurred with both my MBPro4,1 and my MBAir3,1.

I ended up copying the dmg file from the external drive onto the internal HD of my laptop and the scan completed successfully... it's now copying blocks, fingers crossed.

MacBook Pro 15-inch, Mid 2009 (FRESH BUILD)

Newly installed Snow Leopard from apple restoration disk. Then installed Lion from app store. Restored apps from TimeMachine backup.

Trying to created a Hackintosh USB drive. (Please don't sway from topic - important fact is I can no longer create a USB image using Disk Utility)

Let me also say that I've created plenty of USB disk in the past SO I KNOW HOW DISK UTILITY WORKS.

Steps to create USB image:
  1. Partitioning the USB drive.
  2. Drag the .dmg file to the Source
  3. Drag the USB drive to the Destination
The Lion Disk Utility wants to then scan the Source before making the image. After I type my admin password I continue to get a message, "Unable to scan [volume Media]." (Resource busy)
 
Comment

SnibbleBits

macrumors newbie
Jun 14, 2012
1
2
Ensure source is selected (and unmounted) in disk list

I had this problem and what worked for me was ensuring that the source disk was selected in the disk list panel on left as well. I had the destination disk selected at left but properly had my source disk in the "source" field and the destination disk in the "destination" field.

The program wants to unmount and verify the source and assumes that whatever you have selected in the list of disks at left is also the source. Pay attention to the id of the disk that is being reported as "busy". If you're getting this error then either your source is selected at left and is currently mounted (unmounting it should work) or you have some other active disk or partition selected in the list of disks at left.

Hope this helps someone.
 
Comment

tinmancactus

macrumors newbie
May 28, 2012
17
1
I found the problem after reading all over the net... Mount the image you want to restore first and use the mounted image. It should work.

This worked for me as well. I unmounted the destination drive and mounted ('Open' button) the source disk image. Works fine.
 
Comment

bfeister

macrumors newbie
Jul 2, 2012
1
0
I found the problem after reading all over the net... Mount the image you want to restore first and use the mounted image. It should work.

and

Exact same issue.. something must have been holding onto the USB..

format it as 'free space' with a GUID partition table

physically remove USB

plug back in

( hopefully ) it will say 'disk could not be initialized' click IGNORE

proceed with restore.

Were BOTH the issue for me, it wasn't until I did both that I was able to get the result I was looking for. Hope this helps someone else!
 
Comment

dwilt

macrumors newbie
Mar 14, 2008
4
0
I had this problem and what worked for me was ensuring that the source disk was selected in the disk list panel on left as well. I had the destination disk selected at left but properly had my source disk in the "source" field and the destination disk in the "destination" field.

The program wants to unmount and verify the source and assumes that whatever you have selected in the list of disks at left is also the source. Pay attention to the id of the disk that is being reported as "busy". If you're getting this error then either your source is selected at left and is currently mounted (unmounting it should work) or you have some other active disk or partition selected in the list of disks at left.

Hope this helps someone.

Snibblebits, thank you - this worked.
 
Comment

frtoledo

macrumors newbie
Oct 15, 2012
1
0
Problem solved

I had this problem and what worked for me was ensuring that the source disk was selected in the disk list panel on left as well. I had the destination disk selected at left but properly had my source disk in the "source" field and the destination disk in the "destination" field.

Thanks, I tried your solution and it worked as described.
I am using mountain lion on a macbook pro mid 2010.
 
Comment

jbdjunk

macrumors newbie
Nov 4, 2012
1
0
My Solution - Step by Step

Thank you all for your solutions and help in this forum. It took me a while to figure it all out, but this is what I ended up doing:

1. Open Disk Utility
2. Plug in USB
3. Format USB to Mac Extended (Journaled)
4. Create Partition on USB [GUID for Intel chips, APM for PPC]
5. Unmount created Partition
6. Drag and Drop disk image (dmg or iso) into Disk Utility
7. Open disk image (double click or button in DU)
8. Select opened disk image on left menu
9. Click over to Restore
10. Drag and drop selected image into source field
11. Drag and drop (unmounted) USB partition into destination
12. OK (may have to type in admin passwords and such)
13. Wait
14. Enjoy!
 
Comment

nuube

macrumors newbie
Sep 30, 2012
16
1
Frustating resore error

"Unable to scan XXXX Resource busy" has always referred to the destination drive which seems to be hooked into OSX somehow (despite removal and reinsertion). Creation of a new partition (MBR is all that was required for me) on the destination drive then formatting it resolves the error when attempted to restore again, in my experience :mad:

I usually mount the source archive.
 
Comment

SkippyThorson

macrumors 68000
Jul 22, 2007
1,561
557
Utica, NY
I just got over this frustration. I'm not sure what the problem was. I've been trying to make a Hackintosh USB for about a month.

A year ago, I made one with absolutely no problem whatsoever. Inserted the OSX Disc, clicked the flash drive as my destination after a correct formatting, and let it install. It failed every time under 10.6, 10.7 and 10.8. I could not for the life of me get this generic 32gb flash drive to work.

Luckily, the old one I have is on a 16gb SanDisk Cruzer, and it took 10.7 just fine. I've even wiped it a time or two just to start over. It's never let me down once.

So I'm lost as to why the generic 32gb is giving me such a headache. My final solution was to just make a disk image of 10.7 on the SanDisk, and restore it onto the generic flash drive.

ALAS, I get this "Unable To Scan" error, which has lead me here now. :rolleyes:

I managed to get it to work (somehow) after a few Erase attempts. If I had the flash drive selected, and click restore, it put it in the source column on top. Only after I had the disk image selected, and it was on top by default, did the whole thing seem to work. I dragged the generic drive to the bottom.

As I type this, it's at 13 minutes to go. Looks like it's working... Fingers crossed. What a nightmare this is. I'm still stunned by how easy it was with the other flash drive compared to what a production this has been.

-----

It worked. Once. I got the flash drive to boot. Then it wouldn't shut down. Now the flash drive gives me a reformat error, and it won't even work with the good image I have. It begins to boot, and then the computer turns off. What a piece of crap this thing is. I think it's just the cheap-o, generic flash drive, and nothing else.
 
Last edited:
Comment

supremedesigner

macrumors 6502a
Dec 9, 2005
811
325
Gainesville, Fl
Thank you all for your solutions and help in this forum. It took me a while to figure it all out, but this is what I ended up doing:

1. Open Disk Utility
2. Plug in USB
3. Format USB to Mac Extended (Journaled)
4. Create Partition on USB [GUID for Intel chips, APM for PPC]
5. Unmount created Partition
6. Drag and Drop disk image (dmg or iso) into Disk Utility
7. Open disk image (double click or button in DU)
8. Select opened disk image on left menu
9. Click over to Restore
10. Drag and drop selected image into source field
11. Drag and drop (unmounted) USB partition into destination
12. OK (may have to type in admin passwords and such)
13. Wait
14. Enjoy!

Kudos!!!! You just saved my day! :) All the blibber blubber out there for solutions that aren't working. Thank you!!
 
Comment

BBond

macrumors newbie
Feb 24, 2013
3
0
Thank you this worked perfect!

Thank you all for your solutions and help in this forum. It took me a while to figure it all out, but this is what I ended up doing:

1. Open Disk Utility
2. Plug in USB
3. Format USB to Mac Extended (Journaled)
4. Create Partition on USB [GUID for Intel chips, APM for PPC]
5. Unmount created Partition
6. Drag and Drop disk image (dmg or iso) into Disk Utility
7. Open disk image (double click or button in DU)
8. Select opened disk image on left menu
9. Click over to Restore
10. Drag and drop selected image into source field
11. Drag and drop (unmounted) USB partition into destination
12. OK (may have to type in admin passwords and such)
13. Wait
14. Enjoy!


~~~~~~~~~ Thank you this worked perfect! http://cdn.macrumors.com/vb/images/icons/icon10.gif
 
Comment

adamcarroll

macrumors newbie
May 14, 2013
1
0
Thank you all for your solutions and help in this forum. It took me a while to figure it all out, but this is what I ended up doing:

1. Open Disk Utility
2. Plug in USB
3. Format USB to Mac Extended (Journaled)
4. Create Partition on USB [GUID for Intel chips, APM for PPC]
5. Unmount created Partition
6. Drag and Drop disk image (dmg or iso) into Disk Utility
7. Open disk image (double click or button in DU)
8. Select opened disk image on left menu
9. Click over to Restore
10. Drag and drop selected image into source field
11. Drag and drop (unmounted) USB partition into destination
12. OK (may have to type in admin passwords and such)
13. Wait
14. Enjoy!

Perfect! Thank you!
 
Comment

shamus109

macrumors newbie
Sep 14, 2012
6
0
was having the same problem on mountian lion. opening up "mounting" the source file first so that it appears in the disk utility program did the trick.
 
Comment

Nerdface Killah

macrumors member
May 30, 2013
75
0
Just in case someone else comes across this I was having problems but after I unmounted the partition on the thumb drive everything went smooth.
 
Comment

tasssos8

macrumors newbie
Mar 4, 2010
2
0
Best solution, read this from bigshot007

I found the problem after reading all over the net... Mount the image you want to restore first and use the mounted image. It should work.

Thank you so much!!! Thius is the one and simple solution!!!:apple:
 
Comment

p1ra73x

macrumors newbie
Jul 22, 2013
1
0
Permissions

I just had the same problem, What I did to cause it was copy the file from an NTFS partition to my lion JFS, and somewhere along the line there were inherited permissions. After unlocking the file, chmod, chown, and making it accessible by my and the admin user group it went through properly. Hope this helps, I registered just to drop this in here lol.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.