Lion Wifi Connection Timeout, Help!

Discussion in 'iMac' started by gagneana000, Aug 6, 2011.

  1. gagneana000 macrumors newbie

    May 26, 2011
    After intsalling Lion I can not connect to my Wi-Fi at all. When I try to connect it just says. "Could not join <name>, a connection timeout occured" I even did a clean install of Snow Leopard and then installed Lion. Its not a problem with my router because my iPhone, iPad, MBP, and other computers still connect to it fine. The MBP also has Lion and works great. I am using a 21.5in iMac from January 2011. I have attached my system info. Any help would be greatly appreciated. Right now I'm using an ethernet cable and its working fine.

    Here's a link to my System Information:

    Attached Files:

  2. caspervc macrumors newbie

    Jun 25, 2010
    Did you find a solution? I'm experiencing the exact same problem right now. I just updated to 10.7.2. I had no problems running 10.7.1.
  3. SOLLERBOY macrumors 6502a

    Aug 8, 2008
    I'm having similar issues, the wifi drops out every thirty seconds. Only on the iMac, not the macbook. This only started with 10.7.2.
  4. brilliantthings macrumors 6502

    Feb 13, 2011
    Just upgraded to 10.7.2 and 9 times out of 10 I cant connect to my WiFi router. Really irritating. I'm going to start troubleshooting for a problem I never had before I upgraded.
  5. Funkbefgh, Oct 18, 2011
    Last edited: Oct 18, 2011

    Funkbefgh macrumors newbie

    Jun 2, 2011
    I am also plagued with this madness, though I think yours is more extreme. updated 7.2 in a hurry so i could get my ipad 5.0 before I went on vacation.. and lost remote access to my computer and files within hours of leaving home. home 4 days later and it was running with the monitor asleep as it is normally but disconnected from the wifi. that happens occasionally when the router gets reset for whatever reason (i have roomates) so i sat down at the imac (my imac, they dont touch) reset and reconnected. the drop repeated during work the last two days and again since I got home at 6 tonight. what the hell!? not even an error message or exclamation. I used it for over an hour after work and it had zero connection issues while I was on it. I would have spent more time on today it if I had an error message like that.. only this last drop of connection really signaled alarm bells for me. I'm going to try pinging it. hoping an active connection will keep it locked in.. if that doesn't help I'll likely restore 7.1 before the weekend. not enough hours in the day for this bs. anybody find a good fix?

    edited for spelling.
  6. brilliantthings macrumors 6502

    Feb 13, 2011
    Might have been a false alarm. I was using the MBA outside and it had overheated. I only realised because my iPhone asked me to leave it alone until it had cooled down. Whoops.

    EDIT: But I did actually add a DNS address - the Google one. Not sure if this had any effect.
  7. Funkbefgh macrumors newbie

    Jun 2, 2011
    pinging has kept mine connected for two days. sort of annoying that i have to run terminal to stay connected to the internet, but it is working. good luck with yours! hopefully my bump will let somebody who can help see this.
  8. smith5ae macrumors newbie

    Oct 21, 2011
    I'm having the same problem. After upgrading to Lion 10.7, I was having WiFi issues. So I downloaded 10.7.2 through ethernet thinking it would solve the problem, but it didn't.

    After trying just about all the solutions posted on forums, I gave up and reinstalled Lion. This time I was able to connect in 10.7. But after mistakenly installing 10.7.2 (thinking I was in the clear), I am back to "a connection timeout" error.

    I ordered a power supply for my spare router, hopefully it'll do the trick. This is really beginning to drive me crazy! :mad:
  9. MathiasVH macrumors regular

    Nov 7, 2009
    Did any of you guys find a solution to this problem? I'm having the same issue as you do.
  10. BarkingGhost macrumors regular


    Oct 18, 2011
    Atlanta+35 miles
    I'm not aware of one being out there. If I cold boot I can guarantee that I'll get the dreaded 'Wi-Fi: No hardware installed' BUG. If I reboot/restart (as opposed to shutting down and starting cold) the problem magically disappears, but from a cold boot it will ALWAYS be there.

    Not good considering I spent $2200 for this i7Mac last Friday. And this iMac came with Lion pre-installed (cannot downgrade), and attempts to remove the original Mac OS X partition via an external hard drive Recovery HD cannot be done (will not delete).

    I've reinstalled Lion three times and still the problem persists. I also have a USB issue, too.
  11. kkhair macrumors newbie

    Nov 2, 2011
    Remove the network and add it manually

    I just removed the network for the Preferred network list (Sys Pref->Network->Wifi->advanced ->wifi) , then added it manually (with the + sign under the list) with a wrong password and tried to connect, the password window showed up and when I entered the correct password, it worked perfectly, hope this helps
  12. 617arg macrumors 6502

    Mar 3, 2008
    This is plaguing me right now too. Can't seem to figure out how to fix the problem. Everything was working fine and now I suddenly get "connection timeout" no matter what I try.
  13. drgorb macrumors newbie

    Jan 22, 2012
    Connection timeout on Lion


    I had the same problem and noticed that disconnecting the power cord allows the Powerbook to connect.

    Once it is connected, it will stay connected. At least mine does.

    I noticed because I was so angry about not being able to connect to my WiFi that I yanked the laptop and all of a sudden it connected.

    Every time I get the timeout message, disconnecting the power cord has resolved the problem. I find this very weird but it works.

    Hope this helps someone else.

  14. Coltaine macrumors regular


    Jan 7, 2012
    Hi folks,

    weird WiFi connection problems are nothing new in Lion.

    In case any of you are using a FritzBox, unchecking the option for the use of 300 Mbit/s optimized channels might work.

    Just this weekend we tried to connect a new iMac to a FritzBox and it simply wasn't working. The iMac wasn't assigned an IP by the FritzBox. It took 6 hours of troubleshooting and nothing worked. Then we unchecked the above setting and lo and behold, all issues were solved.
    So if you own a FritzBox or if your router has this option, try disabling it, it might work in some cases.
  15. busteranime macrumors newbie

    Mar 9, 2008

    The solution I just found is to go to About This Mac -> More Info -> System Report -> Network -> Wi-Fi. Under Interfaces, look for supported channels. I had to go into my router settings and make sure I was on a compatible channel. The second I did that, my 5 ghz network showed up and is working perfectly!
  16. pratpreneur macrumors newbie

    Jan 26, 2012
    I used my roommates' computer and fixed it

    I went into the router settings. Changed the admin from WPA to WPA2 personal. That also helped me increase the speed limit from g to s.. and now its capable of going to 154mbps (although, honestly, it never goes above 2 mbps so i dont understand the point)
  17. TheJing macrumors 6502a


    Jun 13, 2011
    Somewhere in Europe
    Macs are excellent computers, if you don't need the internet.

    I've had this problem for so long I'm thinking about giving these pieces of **** to someone else.
  18. mmomega macrumors demi-god


    Dec 30, 2009
    DFW, TX
    For those having the WiFi problems, what sort of network setup do you have? Modems and Routers..

    Just asking because I have 6 Lion Macs in my home, sometimes 9 and only 1 being connected by wire. 2 MacMini's, 2 MacBooks and 2 iMacs. Various years, no 2 the same.
  19. sskoutas macrumors newbie

    Feb 16, 2012
    Wooohooo!!!! Thank you kkhair!

    There IS a Santa Claus! Kkhair, I just wanted to let you know that I joined this forum solely to thank you for this answer above. I've been beating my head against the wall with the connection timeout error (and driving the genius bar crazy) for about a month or two. I couldn't find any solution, but yours worked flawlessly. Thank you, thank you, thank you!
  20. oranabana macrumors newbie

    Dec 26, 2011
    ooooh... worked!

    Also worked for me!! Thanks so much!!!
  21. nyeates1 macrumors newbie

    Nov 11, 2009
    Delete your keychain entries for the WAP


    The problem for many of you is likely a corrupt entry in your keychain. To fix this, open up "Keychain Access" (in "Applications/Utilities") and search for the entry which matchs the name of your wifi network. Then, select all the matching entries (there were two in my case) and delete them.

    See this discussion for more details:
  22. Tim Taylor macrumors newbie

    Mar 10, 2012
    Simple Solution

    A very simple trick that worked for me:
    Just change the WLAN password of the router.
    When lion try to connect just enter the new password.
    Hope that helps.
  23. snow-white tan macrumors newbie

    Dec 11, 2010
    this will work..

    I had the same problem with my Mac Pro/Airport Extreme combo and I figured it out. The problem is the laws of physics don't allow radio transmission between multiple transceivers all broadcasting/receiving at the same frequency without interference. Here's the fix..

    Go to About this Mac > More Info > System Report > Network > Wi-Fi. Scroll down to Local Wi-Fi Networks. You will see a list of all the networks in your neighbourhood/hall of residence/prison cell complex etc.. 10 or more if you're unlucky. You will also see your one. Look at the Channel numbers. Chances are, yours will be the same as the guy next door, or at least someone nearby (mine was shared by two others!). Now just pick a number no-one is using (from 1 to 13) and remember it.

    Now go to your router and change the channel to your chosen number. The procedure will vary according to the make. If you have an Airport extreme you just go to Airport Utility, click on your router and go to 'Wireless options'. It will take a few seconds to update, then you'll be back in business. I've had a full strength signal ever since.
  24. forty2j macrumors 68030


    Jul 11, 2008
    Oh, how badly I wanted this to work. Alas, no combination of deleting keychain entries, forgetting networks, and reconnecting could get my iMac to connect to the 5 Ghz network broadcasting from 3 feet below it for longer than it takes to get an IP address. It picks up the 2.4 Ghz band just fine, but I like to avoid that as it interferes with the Turtle Beach wireless headsets.

    I have the only 5 Ghz network in range.

    I *do* have a repeater, which is doing what it's supposed to and running at the same frequency in a different room, on a different floor.

Share This Page