Lion Woes. :(

Discussion in 'Mac OS X Server, Xserve, and Networking' started by applezz, May 7, 2012.

  1. applezz macrumors newbie

    Joined:
    May 7, 2012
    Location:
    Las Vegas
    #1
    Ok, So I have a Mac Pro With now 10.7.3.. Here Goes Nothing...
    I've Cloned the original & broke DNS.. Fixed it by redo of OD, PostgreSQL is either nonexistent or broken, PG admin gives me the middle finger, I can'y wipe a DB that doesn't exist. I've Tried EVERYTHING I've found in the forums, Apple Just shrugs, I DO NOT WANT TO REINSTALL>> this is production environment. <<
    All I want is for profile manager to work, Somehow, I need to bring postgres to back to original. I might add that things went funky after i "upgraded"
    postgres.
    I've tried to wipe Db.sh
    I've fixed ACL, Which by the way, is not easy when you're running it RAID, because disk util. is useless..
    I don't want to wipe, because all the user permissions & ACL's I have built will be dicked...
    DOES ANYONE know how to default postgres, without a wipe ?
     
  2. jafd macrumors member

    Joined:
    Oct 14, 2010
    #2
    I'm using postgresql from macports, works flawlessly, what am I doing wrong?

    I hope you see your problem now.
     
  3. Mattie Num Nums macrumors 68030

    Mattie Num Nums

    Joined:
    Mar 5, 2009
    Location:
    USA
    #3
    I hate to tell you he's right. Without doing a proper backup and testing the upgrade with cloned db on another machine; upgrading a production machine is dangerous without proper QA. Everyone learns the tough way though, just gotta go at it and change your upgrade workflow next time.
     

Share This Page