Liquid + MBA: Everything works fine but battery's not charging?

Discussion in 'MacBook Air' started by metamercurial, Sep 25, 2013.

  1. metamercurial macrumors newbie

    Aug 31, 2008

    I had a bottle which wasn't closed tight and it kinda spilled in my bag with my Macbook Air inside. Fortunately, it had a laptop cover over it so the laptop wasn't swimming in water - just slightly damp when I discovered the spill.

    Let it dry for a while, turned it on and everything worked as normal - it even charged that evening. The next morning however, it showed Not Charging when i connected Magsafe to it. The battery still works but is gradually dying off and isn't able to charge.

    I'm believing it's probably some sort of protective mechanism on the electrical side because of a short-circuit somewhere and hence prevents charging from taking place to prevent a current surge or something?

    Any ideas on what to do now/has anyone encountered such an issue before?
  2. MacPoulet macrumors regular

    Dec 11, 2012
    How many days did you let it dry out? A week is a good amount of time to be sure.

    Have you tried doing an SMC reset? That seems to work for many users.
  3. cyber16 macrumors 6502

    Jan 12, 2013
    I wager if you go eBay and pick up a replacement magsafe charging I/O board with a new ribbon cable it will work again
  4. metamercurial thread starter macrumors newbie

    Aug 31, 2008
    By magsafe charging IO board you mean this?
  5. lynobinson4 macrumors newbie

    Sep 25, 2013
  6. cyber16, Sep 26, 2013
    Last edited: Sep 26, 2013

    cyber16 macrumors 6502

    Jan 12, 2013
  7. MacPoulet macrumors regular

    Dec 11, 2012
    Interesting. Would a blown I/O board still potentially work off the mains?

    I ask because the MBA I'm tinkering with works fine off the power adapter, but it doesn't register that there's a battery. I'd already bought a replacement battery and same result with that one.
  8. cyber16 macrumors 6502

    Jan 12, 2013
    That was the reason I replaced that board in the mid 2011 13"

  9. MacPoulet macrumors regular

    Dec 11, 2012
    Excellent! I'll order that now. Hopefully it'll take care of the problem.
  10. MacPoulet macrumors regular

    Dec 11, 2012
    The I/O board finally came today. I took apart the MBA and installed it. Connected the magsafe and... nothing. No boot, no green light on the magsafe, which did light up on the old board.

    So it looks like I got a bad I/O board off eBay.


    When I disconnect the battery, the green light on the magsafe suddenly lights up. The computer boots and works fine, as long as the battery isn't plugged in. Should also mention that this is a replacement battery I bought on eBay, and for fun I plugged the old one back in. With the old, corroded battery, the green light on the magsafe came on and it boots, but it doesn't recognize the battery.

    So now, I'm trying to decide what the problem could be. I've narrowed it down to a few possibilities:

    1- The new I/O board is faulty.
    2- The new battery is faulty.
    3- The I/O ribbon cable needs to be replaced
    4- The logic board is faulty.

    Or a combination of.

    I wish I had a way to diagnose the battery and rule it out. I did contact the seller over a month ago and never got a response. Too much time may have passed now for that one...

    Any thoughts?
  11. bizzle macrumors 6502a

    Jun 29, 2008
    Before you start replacing parts you should always assess the actual damage and not take wild guesses. Computer parts start corroding very fast when exposed to water. I'd remove the logic board and use a magnifying glass with a light and inspect all the boards for corrosion. I've managed to revive hundreds of of boards by just cleaning off the corrosion.
  12. MacPoulet macrumors regular

    Dec 11, 2012
    Very good advice bizzle and thanks. This is the thread I'd started about my process:

    I've done extensive cleaning (99% alcohol and a kids' toothbrush on at least four separate occasions, also used a magnifying glass and light) and I *think* I've been going about the process as logically as I could. But I'm always looking for advice and feedback.

    There is some rust after I'd cleaned off the corrosion on the battery connector on the logic board. Not sure if that's the reason for the battery not being recognized or not.

    The new I/O board kinda throws a wrench in my deductions though.

Share This Page