Lite-On 1633s DVDRW drive has strange behavior...

Discussion in 'Mac Accessories' started by Downshift, Dec 28, 2005.

  1. Downshift macrumors newbie

    Nov 1, 2005
    Okay, somebody has got to be able to explain this thing...

    I have a Lite-On SOHW-1633s DVDRW drive from Aug. 2004 in my Dual 1.8 PowerMac. When I first got it the drive had problems reading DVD's, and would most of the time make a vibrating sound (like old floppies in the 80's did when they had read errors.) Took it out, attached it to a PC and gave it a flash with the latest available firmware. Tested it on the PC and it was working great. Put it in the Mac, also working great (thanks to PatchBurn). Fast forward to Nov. 2005. The drive starts acting up exactly as it did before, except this time, no flash will fix it.

    I have tested the following configurations:
    In my Mac G5 -
    - Drive as MASTER / SLAVE / CABLE SELECT - Still doesn't work
    - With and without PatchBurn - Still doesn't work
    - New IDE cable from my PC - Still doesn't work
    - After reseting the drives region on the PC - Still doesn't work (I have one Japanese DVD that WILL play in the drive on the Mac.)
    - External FireWire - Works when I put a jumper on an unlabeled spot in a grouping of 6 pins on the left (as looking at it) side of the back next to the D/A connector. Putting it in on the ATA with this jumper set makes no difference to its operation, just fails to read DVD's from US.
    - AOpen drive (dual layer DVDRW, dunno model) from my Dad's external FireWire case works without a problem in my G5.

    The drive works perfectly FINE in my PC. In fact, the Japanese disc that won't read on the PC is the only disc that will in the Mac unless the drive is connected via FireWire through the external case I borrowed from my Dad.

    So theres the rub - it works in the one computer in the house that I use the least and have the least interest in using at all. I have read online that this drive is supposed to work just fine (and did for me for quite a while) in a G5...All CD's and most of my previously burned media from the systems original drive, my best friends dual 2.0 G5 stock drive, and this drive all read just fine. I am also still able to burn DVDs and CDs without a problem, I just cant watch a movie.

    Are there any known issues with the ATA in the G5s that I haven't read about anywhere? Does anybody know of any tools to give me more control over ATA settings in OS X so I can check if there is some DMA mode problem or something?
  2. Downshift thread starter macrumors newbie

    Nov 1, 2005
    A little more info...

    After checking a good portion of my DVDs, I have found 4 that read and play fine. Several show up in the Finder as blank DVDs, and the rest just cause the drive to make a grindy error sound (its not scratching the discs though.) Anybody? Anybody have any ideas at all?

Share This Page